Installing on Hp stream 11 notebook

I am trying to install the latest beta (from 32bit 3.8x) from june 9th download. OS looks amazing.
I get all the way through the install. On restart the system cannot boot or find the drive - no os is loaded - so i am stuck.

The warning during install was something like "cannot find efivars file and "you booted from a usb - if your computer wont start after install try changing boot order" but that isn't helping...

On second try. After selecting modify boot. I get a warning that the installation of grub reported some problems configuring the system. If you are unable to boot try different options...

Details: grub-install: error: /usr/lib/grub/i386-pc/ dosent exit. Please specify --target or --directory.

Any thoughts?
HP stream 11 laptop/notebook 2gig ram 32gig ssd (non removable)

As a first welcome to the forum .... let's see if we can get this worked out. :smiley14:

As a second:
The information you've given is fairly sparse considering the sheer amount of things that can go wrong.

In general most "will not boot" help requests come down to wrong BIOS/firmware settings or opting to keep an existing installation (i.e dual-boot) where it isn't clear how the previous OS boots... or even unused and forgotten remnants of previously installed systems.

The 'efivars' warning is about a firmware EFI boot sequence not finding the necessary EFI partition.
This could be down to:

  1. It really isn't there i.e no partition. So how did you partition your HD and to what scheme?
  2. You didn't turn off 'secure boot' in the BIOS.
  3. Depending on the previous OS, booting could be set to 'legacy mode' in the BIOS where the installer opted for EFI as that is what the USB did, to boot.

Considering the HP 11 (chromebook?) is quite an old laptop and has a small builtin HD .... It will be probable be an 'Elive-only' install making it best to let Elive use the whole HD automatically.
Also if this "not booting" keeps up and clearly EFI isn't required (no other alien OS) consider booting in "legacy mode" and then installing.

In all cases turning off secure boot is a necessity to avoid problems. If you do feel the need to secure your system .... having it encrypted is a much safer option. :innocent:

I had already turned off secure boot.
Elive is the only os.
Previously windows 10 was just crawling...
I used the entire drive 32gig...
I let elive automatically partition the drive.
I see a 8 mb un allocated amount of space on the drive that perhaps could be used. Attached a screen shot of gparted.

Runs perfect on a usb. 32 bit mode.
Not sure how to add a grub loader that works.

The pc said no os found after the first couple of installs.
Thanks for your help and patience.


Hmm, yes but there are still some remnants of previous (a.o the 8mb free space there) system partitions.
I'm surprised that the Elive-installer didn't remove those in 'automatic' mode.

Those little partitions/space are going to hurt every time you install something new.... so we could force the installation of 'grub' but:
Personally I think simply clearing out the whole disk and creating 1 big 32G empty partition will solve that. After which letting the installer automatically set up the partitions.

Make sure you boot up Elive live in 'legacy mode', just as a precaution and let the installer use the MBR.... it is after all not a machine that's got plenty of space for dual-boot.

No worry, you're welcome and belive me: You haven't tested our patience in anyway. :madness:

On a sidenote, considering you've only got 2Gb of RAM ..... you might want to create a 2G swap partition beforehand too. :thinking:

Here is a screenshot of the bios setup. Since there is no os boot manager, perhaps i could add that? Or fool it into using grub or other boot manager like clover.

Still it should find the drive .. .

Can i force legacy mode on the live usb when starting?
Ill look again. Thinking that a factory installed os should not pose a problem..

Thanks again.


I'm not sure about how to manipulate that BIOS but isn't there an option (like using F5/F6) to change the boot order from UEFI first to Legacy first?

Apparently when changing to Legacy mode the HP will require a 4 digit code on reboot.

Finally got an install to work. Had to boot to q4dos linux wipe the partitions. Boot to 3.04 stable install to the drive. (Live usb would not connect to network), but correctly created partitions. Then booted up the beta. Installed and left partitions alone. Forced no changes to the drive.

Boots fine now!

Only problem is multiple doc layers (3 pictured) in the launcher doc.

Other than that it seems to be working.

Interesting that that would work ......that's perseverance on your side. :innocent:
Very soon the 'Bullseye' based version of Elive will be publicly available, hopefully solving strange stuff like that.

That's a strange issue where it looks like 'cairo-dock' is shown multiple times. I've seen that happen before but I don't recall where. :thinking:
It was due to the mouse-over actions IIRC.

You can see from the 'terminal' how many instances of 'cairo-dock' are opened by using:
'eesh window list'
where there should be only one single instance of it in the output.

this error happens when the system has boot in UEFI mode but cannot read the EFI configurations (this error should never happen)

unfortunately there's not a "reports" send to the server with your forum-username email so I cannot see more details about that

I suggest you to wait for the 3.8.28 release which includes many changes and a full distro upgrade (and then enable the reports during the installation, in case it happens again)

yes this is an issue that was meant to have been solved in the past, but seems like its not and the real cause was never been discovered (is one of these bugs which doesn't makes much sense)... let's see if still happens on the Bullseye (3.8.28) release, so cairo-dock is own-builded now from its last git version

My memory sort of says that I saw that on a very low spec system (500Mb RAM) when doing a mouse-over on the dock.
Could it be that the dock-magnification is done in RAM and doesn't get released?
@e-Solutions , I'd be quite interested to see the output of 'eesh window_list' on how many docks are really opened opposed to left-over artifacts in X11. :thinking:

no, the reason is that the cairo-dock process is run multiple times instead of a single one, but i don't see what causes this, i even included a code that prevents this but seems like still happens, so maybe the issue is on cairo-dock itself which ran multiple instances on startup time by accident (it happens randomly without a specific reason), that's why i said "let's see if still happens on the bullseye builds" because cairo-dock is built directly from its git now instead of being from a debian "older" package, _this also solves a bug that cairo-dock crashes when trying to edit an icon configuration

pidof cairo-dock

this show how many processes are run, but i think @e-Solutions will have this problem "sometimes" on desktop start not everytime the same 3 ones

I have not seen the problem after several restarts or hibernation...

yeah, its a random issue :slight_smile: not easy at all to reproduce!
so let's see if you still having it on the next 3.8.28