Internal display not recognized, how to?

#1

Hello all,
I did a successful fresh install of Elive 3.0.6 on Asus Eee PC 1015P Seashell;
with SSD, Intel GMA 3150 chipset, huge 1GB RAM, Intel Atom N450 / 1.66 GHz

  • after the login screen the display shows black (but still on) and so I came to the idea
    to connect an external display via dsub cable - and strange - I had to learn
    that it is the only main display. So I struggled around for a while and found
    "Screen Layout Editor" but it shows the 'default' monitor only - which is the
    connected external display but with the values from the internal screen.
    For some reason it does not recognize the internal notebook display after login anymore...
    Can someone help, pls ?

(before it was running LM 18.1 Xfce, without problems - so hardware seems ok)
(on other notebooks, e.g. HP Mini with VIA chipset, with same install no problems of this kind has appeared)

Krgds

and best regards to Thanatermesis - I adore your work and concept,
will talk later more to ya :wink:

#2

Thanks for your words :slight_smile:

If is using a configuration that you made with the screens configurator, it should be not used when you reboot with the external screen disconnected

Generically speaking, sounds like you have different hardware/drivers issues not being recognized correctly, you must try the same things with the next beta versions 3.7.x which includes everything much updated :slight_smile:

#3

Hello Thanatermesis,
thanx for quick reply - but

If is using a configuration that you made with the screens configurator, it should be not used when you reboot with the external screen disconnected

... ahm , no.
The external screen was not connected before the issue appeared.
It happens already after first boot after install;
login @ ldm greeter and - oops, leave the lvds display if it would not exist.
After some investigations (cause its annoying me) I guess it has to
do with a misconfiguration of xrandr.
The interesting thing herein is - from where is it coming , because:
I had excatly the same issue with a former install of 'elive_3.0.0_stable_hybrid.iso'
yesterday before I received the dl link for 'elive_3.0.6_stable_hybrid.iso'.
So I started from scratch today, surprisingly wit the same result... look:
(sudo -i)
Xrandr says
root ~ ??? xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 600, current 1024 x 600, maximum 1024 x 600
default connected 1024x600+0+0 0mm x 0mm
1024x600 0.0*

(this is the right resolution from the build-in display, btw)

[Screen 0??]

In Screen Layout Editor is nothing adjustable.

So, what do you think / mention ?

Everything else seems to work fine yet...

Krgds

#4

Mmmh, I'm in fact a bit confused about what is the exact issue that you have :slight_smile:

Ok so, the xrandr results shows you a single possible resolution, maybe your card/screen only supports this one, but is strange so it should give you more ones, maybe is a problem of outdated drivers or because you are using a wrong driver, which graphic card do you have? lspci | grep VGA

#5

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09)

well its not such a big drama -
I could try another download and Install,
no wrong path....
it is not that.
Better:
May be it is a hardware issue - will try same install media
on another machine tomorrow; Acer Aspire i5 | 6 GB Ram and 2 GB Graphics

lets see

will tell you tomorrow, ok

#6

I learned that it MAY BE has to do with Xrandr and UEFI/UEFI BIOS boot,
another user was successful after switching to UEFI BIOS. (He said)

Here on my old Asus Seashell is nothing to adjust in bios :expressionless:

#7

If we have published the version of 64bit this would be easier to verify (much newer drivers & related software), if its fixed, then it only required updated software :slight_smile:

If is a hardware problem, it can be solved from the previous sentence (just maybe)

Note: elive-multiscreens tool is just a wrapper tool that uses arandr tool to configure the screens and load/unload the configurations in desktop start, its more like a feature to save the configuraitons and load them in the correct moment, the tool is located at /usr/bin/elive-multiscreens

#8

I see.
I had the idea - I could copy the related file for the display config (like xorg from /etc)
from the live media -> to the installed system on disk -
but have no idea - which one - and where is it located :wink:

#9

Mmmh, the xorg configurations should be simply autodetected, you should not need them

Let's try another thing: edit the /usr/bin/e_wrapper file and add in the second line this:

export ECORE_NO_VSYNC=1

Reboot and see if this solves the problem of the black screen

#10

done, no change.

Did I explained well that the screen black out
(and switch to external output which was not ever connected before)
AFTER login window - user / passwd

funny thing: If I connect the external display before switch on the PC,
it will not even recognized and I have 2 black screens....
So, I connect the external display after black out of the internal display,
then I can at least see the desktop on the external display and can do some

#11

Just initiated a fresh install (with option "graphic problem"),
will report.

#12

You will not believe it...

After fresh install all worked fine (!) out of the box -
as long I had autologin enabled.
Now I just log out /
login; username; password aaaand zanggggg = black screen.
stay tuned I connect the external display right now...
yep, the desktop environment is now on the external display, internal display is black
wait
I reboot to autologin now, stay tuned...
grub, booting, no - hold on:
udev 4721: killing and so on (can not read through, too fast scrolling and repeating)
shut down now
stay tuned...
ok, boot, grub, Desktop lives.....
$ dmesg:
nothing special, even no warnings

ok I try it again
logout....
ok
ldm greeter (showing "Default Xsession")
ok
login (user name)
ok
password, login
zangggg = pitch black......

fine then:
same routine
plug in the external display
surprise, the DE is over there...
reboot
grub
ok
boot........
ok -> Desktop Environment is alive and looks happy
wlan, buetooth, sound - all fine
chromium is not working but firefox yes (and so what)
Backlight adjustment is not working (but keystrokes yes)

so,
I connect the external display right now additional -
working but just mirroring
ArandR starts up automatically now but shows the same like on former screenshot above,
only 1 display called "default", nothing to do here
I disconnect the external display right now
no effect, all ok

Conclusion
there is something wrong with ldm; I guess - may be in combination with another problem with recognizing the correct display during installation

So I can not logout / login without trouble, but in this case it is not a big drama,
hoping, that it is not a real bug.

may be you should delete this topic it is may be irritating others?

#13

Hum, I wonder if all your problems are caused by the multiscreens configurator, so let's try to disable any action that it does:

sudo scite /usr/bin/elive-multiscreens

Then add in the second line an "exit" and save the file, that's all, reboot and see if the problem is solved

#14

done. but no change, still the same :frowning:

#15

ok, remove the "exit" line then

maybe because of the nvidia driver (if) ?

should be tried with 3.7.x which all drivers are newer :slight_smile: