Is install Elive icon missing in the application bar at the bottom in live mode?

Just booted with Elive 2.9.99 " LIVE MODE " on a USB stick

Wanted to install clean on my ssd drive and the Elive icon that is usually at the bottom on the screen in the application bar was missing.

I had to use the application menu to go to the elive menu then Choose install Elive

I think it was there with previous version… WIll do more test in a VM later

Did you booted in persistence mode?

I just tried it on virtualbox and the icon appears, but there can be something that caused it to not show it in your experience, like a startup script blocked

Please tell me if you still having the issue, 3.0 needs to have that icon :slight_smile:

1 Like

ok here is how it happen

You now make the " multiScreen" configuration tool run before we choose the country, I like that
but
If we say yes, then when we reach the Elive Desktop, the Install Elive icon is not there
If I choose to not run the screen configuration tool, then, it’s ok, the Elive installer icon is there

I was not able to reproduce that behavior in a VM with 2 virtual screen but when booting from a USB stick, with my 2 screen connected, if I run the screen configuration tool, it doesn’t that everytime ( install icon missing)

JF
BTW when we run the scren configuration tool, something tells us to close the screen congiruation tool in a way that I can’t… the only way to close it is in File QUIT CTRL Q If we run it, once we are within ELive, yes we can close the configuration tool with the CLOSE box upper right ( Red)

Hum…

If the languages are asked after to configure screens, then the hooks that includes that icon will be run (so icon should show)

Can you try this? Reproduce the same steps (configure your screens, select language, desktop starts), wait 2 minutes after the desktop has started and reload it (ctrl + alt + end), see if the reloading makes the icon appear

Heh, I understand the issue and unfortunately it is not possible to improve this, let me explain:

  • the tool is run before and after the Enlightenment desktop, which is needed to preload your screen configuration before the desktop and also for some other things after the desktop has started
  • in theory, the tool should be run as preference AFTER the desktop has started, in order to include the close buttons that you are missing (are you using an old version of elive-tools package? maybe the iso includes an old version of it… try to β€œapui elive-tools” and restart to a new desktop configuration to see if the configurator is shown after)

So the reason is that when the tool is launched before the desktop, it means that there’s not a window-manager running in your graphical system, so you don’t have any features that includes a window-manager (enlightenment is the one that we use), so you don’t have borders in the windows, you cannot move a window, your mouse pointer is ugly, etc etc

1 Like

No doesn’t work… Waited 2 minuted, Reloaded the Desktop, the Install icon still doesn’t show right to the Search icon on the bar

I would just make the message more clear. Presently, it says that to quit the screen configuation tool o use the top tabs… ( I know what is a tab and TOP make us think to top right corner… and as you know it’s not that… And it’S not a tab but a menu that we have access to…

I would say, " To quit the window configuration tool, press CTRL + Q or use the file menu… or something like that

  • updated message to using ctrl + q too

Can you show me the output of these commands?

  • cat .e/e17/applications/bar/default/.order
  • tree .e/

note: the second one can be huge, better to paste the contents in a temporal pastebin website like paste.debian.net , using a good expiration time

I am just talking about the usual CTRQ quit available in the File menu

In the window that preceed us running the window manager, you tell people to quit the window manager using the Tabs at the top. Your messing is I think, confusing… It should be go in File Quit or CTRL - Q if you try the installer you’ll see what I mean

JF

Yeah, i updated the message with:

IMPORTANT: You are not yet inside a window manager, this means that you have no window controls and multiple things that can be confusing. Follow these instructions carefully: Configure your screens as you wish to use them. Click apply to test your configuration by moving your mouse among the screens. Click to save your configuration (important). Finally exit the application from the menus or using ctrl+q.

1 Like

The issue is not yet solved, I don’t know what can cause the missing icon

Can you show me the output of these commands? (1 minute after the desktop has started)

  • cat .e/e17/applications/bar/default/.order
  • tree .e/

note: the second one can be huge, better to paste the contents in a temporal pastebin website like paste.debian.net , using a good expiration time

~ ❯❯❯ cat .e/e17/applications/bar/default/.order
terminology.desktop
xchat.desktop
Thunar.desktop
firefox-esr.desktop
rhythmbox.desktop
shotwell.desktop
gimp.desktop
elicit.desktop
libreoffice-writer.desktop
virtualbox.desktop
synaptic.desktop
gnome-search-tool.desktop

                                                                                                                    ~ ❯❯❯ tree .e/                                                                                                                                            1

.e/
└── e17
β”œβ”€β”€ applications
β”‚ β”œβ”€β”€ bar
β”‚ β”‚ └── default
β”‚ β”œβ”€β”€ desk-lock
β”‚ β”œβ”€β”€ desk-unlock
β”‚ β”œβ”€β”€ menu
β”‚ β”‚ β”œβ”€β”€ all
β”‚ β”‚ └── favorite
β”‚ β”œβ”€β”€ restart
β”‚ β”œβ”€β”€ startup
β”‚ └── trash
β”œβ”€β”€ backgrounds
β”œβ”€β”€ config
β”‚ β”œβ”€β”€ default
β”‚ β”‚ β”œβ”€β”€ e.cfg
β”‚ β”‚ └── e_randr.cfg
β”‚ β”œβ”€β”€ profile.1.cfg
β”‚ β”œβ”€β”€ profile.2.cfg
β”‚ β”œβ”€β”€ profile.3.cfg
β”‚ β”œβ”€β”€ profile.cfg
β”‚ └── standard
β”‚ β”œβ”€β”€ e.1.cfg
β”‚ β”œβ”€β”€ e.2.cfg
β”‚ β”œβ”€β”€ e.3.cfg
β”‚ β”œβ”€β”€ e.cfg
β”‚ β”œβ”€β”€ e_randr.cfg
β”‚ β”œβ”€β”€ e_remember_restart.cfg
β”‚ β”œβ”€β”€ exehist.cfg
β”‚ β”œβ”€β”€ module.clock.cfg
β”‚ β”œβ”€β”€ module.comp.1.cfg
β”‚ β”œβ”€β”€ module.comp.cfg
β”‚ β”œβ”€β”€ module.conf.cfg
β”‚ β”œβ”€β”€ module.engage.cfg
β”‚ β”œβ”€β”€ module.everything-apps.cfg
β”‚ β”œβ”€β”€ module.everything.cfg
β”‚ β”œβ”€β”€ module.everything-files.cfg
β”‚ β”œβ”€β”€ module.gadman.cfg
β”‚ β”œβ”€β”€ module.ibox.cfg
β”‚ β”œβ”€β”€ module.internet.cfg
β”‚ β”œβ”€β”€ module.notification.cfg
β”‚ β”œβ”€β”€ module.pager.cfg
β”‚ β”œβ”€β”€ module.places.cfg
β”‚ β”œβ”€β”€ module.syscon.cfg
β”‚ └── module.temperature.cfg
β”œβ”€β”€ fileman
β”‚ β”œβ”€β”€ favorites
β”‚ β”‚ β”œβ”€β”€ desktop.desktop
β”‚ β”‚ β”œβ”€β”€ home.desktop
β”‚ β”‚ β”œβ”€β”€ root.desktop
β”‚ β”‚ └── tmp.desktop
β”‚ └── metadata
β”œβ”€β”€ fonts
β”œβ”€β”€ icons
β”œβ”€β”€ images
β”œβ”€β”€ input_methods
β”œβ”€β”€ locale
β”œβ”€β”€ modules
└── themes

26 directories, 33 files

Ok, I just tried the last 3.0.0 build and this issue doesn’t happens, so i assume it was a small bug in the previous versions

OK will try again
JF

Where do I find this iso ?

They are available here (finishing to upload now the usb image, 2 hours remaining): Index of /development/betatest/

Don’t see them

Ouch, they have been removed due to the forum server ran out of space

Try: http://isos.elivecd.org/development/betatest/elive_3.0.0_stable_hybrid.iso it does work? Change the url if I wrote incorrectly the file name

Yep I was able to download it

Ok try 3.0 iso
It worked
The install Elive icon is now back on the application bar on the right