Legimitation to wifi network

Hi Everybody in here,

3 days ago I managed to install Elive on my old IBM Thinkpad T30 (1.8 GHz CPU [Intel Pentium 4] and 1024 MB RAM). I must say I am very much impressed by the diversity of applications and preferences.
There are 2 things so far I had no success achieving yet.

The first is setting the CPU speed which is set currently to 1.2 GHz . When trying to change it to 1.8 GHz via the radio button, the desired change does not get processed, the setting to 1.2 GHz remains unchanged.
Well, I can live with that, as the PC performs pretty fast so far.

The second issue is the most important to be solved. That's about joining the WiFi home network or subsequently any other network. The network gets found by Elive and the window for legitimation opens, but the button for connecting to the network is not activated after entering the requested password for the connection, although the right password has been entered.
What else could or should I do to connect. As I am planning to take this little machine with me, when I am on the road as long distance driver (meaning not coming home for an entire week or so) to be able to have internet connection.

Any help and/or suggestions are very much appreciated.


1 Like

I assume you are talking about the Stable version, in this version (and/or desktop) the cpu widget never worked as expected for some unknown reason. For that I suggest you to try the Beta version instead which improves this a lot (there's no widget, but there's a correct management of the cpu, you can configure it but manually on the /etc/laptop-mode files)

I also suggest you to try the Beta version because it includes many improvements in every sense, but the desktop experience is pretty different (the stable one looks better), also you must use the last (special version) build which has a lot of improvements in performance too, since this is important for your old machine: Elive Retro (Work in Progress) - #15 by Thanatermesis


a big thank you for this fast response to my post.

After having looked at the link you've sent in your reply, I am not so sure what exactly I need to download, as the link you have provided there seems to be for a 64 bit architecture ( /elive_3.8.32__EliveRetro__beta01__hybrid_amd64.iso.zsync).
Would it be possible that you sent me the appropriate link for the 32-bit architecture you suggested to me?

That would be very much appreciated despite me not being a patron yet!.
At present I cannot contribute any money at all to your work on developing and improving Elive merely to the unfortunate fact, that I am already 67 years old and had to quit work last year due to my wife's illness. The pension I am receiving leaves me (after having paid all fixed costs for water, electricity, insurances and the lot) with some money less than 80 EUR (living in Germany) for food, closing and the necessary needs for hygiene. Thus I am forced to start working again, as the money I had put aside will be soon used up, especially because my wife's illness proves to be chronically and a lot of money has to be paid for medicines and prescription fees . Therefor I only can hope for your positive comity.

Thanks so far


1 Like

If you're looking for 32 bits specifically there's always the option to download the 32 bits Beta version cost-free. It's extremely stable and efficient despite it's name.

You might consider adding some RAM to your machine, though. :thinking:

On a side note: T30 can run 64bit if the CPU allows. Check the BIOS for the specs.

Are you 100% sure that you have selected the widget to enter the password, i.e did you see 'dots' when you typed the password?
You do need to click inside the space there. :slightly_frowning_face:

I think they were talking about the magnet link for the latest retro build?

Hi triantares

guessing you mean this one

The password entered is the correct one

About installing the 64-bit version on the T30: what must I look for in the BIOS, please?


Yes, I am ..... generally the button stays greyed out until the correct number of digits (or letters) are entered, I've noticed but if you're sure that's not a point.
That leaves 2 other options: 1. Your wireless card isn't using the correct protocol which can be changed from the menu 'settings' -> all ->preferences->network connections. Where you'll have to select your wifi and opt for 'edit' and in the subsequent window make sure that in the 'security' tab it is set to 'wps&wpa2 Personal'

or 2. Your card misses the correct driver. IIRC there were some cards at the time that weren't supported by Linux...that would certainly require a newer Elive version.

Well if you've got Elive stable running you can see the CPU specs from there with the output 'inxi -C' command in a terminal .... If you want to see all your specs do" 'inxi -Frnz'.
Be aware that the 32bit Beta is cost-free but the 64bit isn't, excepting the Retro test version.

Hi there,

tried to look

Well if you've got Elive stable running you can see the CPU specs from there with the output 'inxi -C' command in a terminal .... If you want to see all your specs do" 'inxi -Frnz'.

Unfortunately I get the message, that "inxi" is not installed.
When trying to install it with "sudo apt-get install inxi" I get the message that "hddtemp" could not get authenticated because it could not be gotten from http: // repo. wheezy .debian. elivecd. org/debian / pool ...
Not even with trying the suggested --fix-missing

At present I am using my other machine running on Win10 to communicate here in the forum, because all browsers from the installed Elive stable (on the IBM T30) are not supported by the forum software to read rich text, sign in or post.
Updating the chrome browser with synaptic package manager is not possible either.
Looks like one tough luck chasing the other one.

Any ideas on that?


Yes, that is a big downside of Stable ..... It's just too outdated, especially the web-browsers and you cannot update them, alas.

Which usually goes away as an error after doing 'apt-get update' first and then installing.

Anyway, 32bits will install on all the hardware and is a cost-free download after all. I'd advise going the Beta 32bit route and doing that, if it eventually turns out that your Thinkpad does do 64bit then the install can always be 'crossgraded' to 64 bit. if needed.... i.e with the Retro release.

Elive Stable is a dead horse ...... let's stop flogging it. :astonished:

Ok, thanks for explanation.

BTW, I did sudo apt-get update first.

Next thing I am going try to install the iso I downloaded with bittorrent. Hopefully I will have more success by doing that.

Will keep you updated about progresses.



That's the 64bit ....... you'll now know soon enough if your CPU accepts 64bit.
If it doesn't the installer will not even start.

ufortunately yes, but especially because of the browser

maybe palemoon works good on it? - let's remember that we have older versions available to download on their archive page

as @triantares suggests, the beta 32bit version is a very good option, actual betas works very good and stable, the 32 bit version is even lighter... but if you wait for the 3.8.32 release it will be even more because many optimization improvements for ram / resources has been made on that one (or, the EliveRetro version includes them too)

not even boot the iso :stuck_out_tongue_closed_eyes: but the boot informs about that I think :thinking: , in any case even if the 64bit works on his machine, the 32 bit is lighter (in case that is an old machine)

Yep, it does.

Most of my very old machines don't really show great difference in subjective speed it's fast in both versions but keep in mind that eventually 32bit will die out too.

not more like "speed" but "resources", if you compare conky you can see a great improvement in memory usage on the 32 bit version, also the 32 bit has a few modifications in the OS making it lighter, speed can be similar, but RAM is one of the biggest limit in old computers

1 Like