My SSD hard disk is going to fail soon?

After to recovered today my computer from hibernation I saw these messages pop up from hibernation:

[39016.843045] blk_update_request: I/O error, dev sda, sector 466269456 op 0x0:(READ) flags 0x80700 phys_seg 3 prio class 0
[39016.843064] blk_update_request: I/O error, dev sda, sector 466269544 op 0x0:(READ) flags 0x80700 phys_seg 2 prio class 0
[39016.843071] blk_update_request: I/O error, dev sda, sector 466269584 op 0x0:(READ) flags 0x80700 phys_seg 5 prio class 0
[39016.843084] blk_update_request: I/O error, dev sda, sector 318175232 op 0x0:(READ) flags 0x80700 phys_seg 34 prio class 0

I wonder if my SSD is going to die soon :thinking: , google says that ssd cells can be failing by old age (but unrecoverable data) maybe is time to replace it with a nvme disk, in any case, Im going to run a few tests:

  • gnome-disks tests
  • badblocks -vs
  • other tools to scan?
  • thank you elive to warn me about this :applause:

mmh, this smells bad... i just tried to use a chroot that I have on my disk and it failed with an error, then i found it has a "bad state" file inside:

drwxrwxrwt 2 root root 4096 May 15 12:07 tmp
drwxr-xr-x 13 root root 4096 Jun 10 2019 usr
drwxr-xr-x 11 root root 4096 Jun 10 2019 var
-rw-r--r-- 1 root root 0 Apr 1 12:26 '?' <------------ that '?' file
lrwxrwxrwx 1 root root 7 Jun 10 2019 bin -> usr/bin

root /h/t/D/m/c/debootstrap_buster_default_amd64 ❯❯❯ file \?
?: empty

In my case that had similar messages the SSD just suddenly died.

The screen froze in the middle of a session and the whole machine became unresponsive.
The SSD wasn't even readable afterwards .... really totally, totally, dead..... not even recognized as hardware anymore on any system.

So backup important stuff while you still can. :face_with_head_bandage:

i did.... but its really not easy to know "what" is included or not...

I have also a partition of windows which I use rarely (with license, that comes with the laptop), I don't even know how is meant to recover this in a disk change :thinking:, the best will be that the disk won't die so i can still access do that lol

i need to be hurry

I always clone those (including the recovery partition) just in case I want sell the machine at a later stage.
Then I use the space for Linux. :applause:

yeah :thinking: I think that I should start by this -before- scanning the disk... just do a big clone of the HD and then see if anything is wrong (but it totally looks like things are wrong)

Is the perfect time to setup a 3.8.20 with persistence to continue having "access to a computer" lol :applause:

what "clone" tools you use / suggest me? is DD enough?

1 Like

I'm old fashioned and I always use clonezilla to clone to a USB. :smiley:

1 Like

Which reminds me:
I'm intending to try out respin, pinguy-builder and linux livekit and see how they compare.

Keep you informed. :smiley14:

What does SMART say is wrong with your SSD?

Short story:

  • yes my HD was dying, I immediately found some lost data
  • so I buyed fast an nvme replacement (samsung 980 500gb) which seemed to be good, unfortunately the read/write speeds are very fake (what a shame for samsung), so they say 3,5 gb/s read, 3 gb/s write, and the real speeds are 2 gb/s and 0.5 gb/s, but anyways stills a fast disk (even a little more than the previous one), with good quality and all that, unfortunately colombia is no the best place to buy hardware (or any imported thing from the rest of the world), it cost me almost the double of the price, only 1 item available in marketplace, and real shops sells them even 3 times more expensive (dafuk!)
  • I was backuping everything, now im finally back to a working system with almost all my data recovered (comparing with a previous backup), i still need to verify a few more things and delete some huge data using uselessly the external backup disks, this was not easy since it happened in the middle of the release, while I was also debugging and improving the "email checker" from the stable download
  • unfortunately the windows partition was not able to be restored, I would have needed to do much more work (time) to have that but i don't use it much (only for some tests sometimes or a few softwares, but rarely), maybe i look into that in the future but you know... pain and time
  • all the process was an opportunity to improve the installation over nvme and do some tests, for example nvme requires strictly an EFI boot system (not gpt + legacy, doesn't works), this improvement still needs to be made on the installer. Or longevity for SSD's which i still betatesting atm
  • I still very hurry with all the tasks so i probably wont be much available on forum

not much in fact, only "pre-fail" values which I assumed was an indicator, but the good thing happened was:
I restored computer from hibernation, then a popup appeared showing me some disk reading errors (this has been improved too), and inmediately found some data lost, so I didn't wanted to risk the rest of the data even if i have backups and directly proceeding with a replacement & restoring

@triantares for me clonezilla was not a good experience, hard to understand and confusing messages (like you don't know if wants to mount a device for save the backups or erase entirely a partition/disk where to save the backups), but also it was not able to select an encrypted disk where to save the backups so it still became useless since I was not able to save anything.

as a final note i tried to use a debian-testing live in order to have more recent software to do the backup of the winshit partitions but this ended in kernel panics, so i switched back to the perfect stability of the 'best os ever' lol

hmmmm, I see where that can be confusing on a first time.
Usually the (clonezilla) defaults are fine and it does have to warn if you're overwriting existing data.
In general I tell it it to create images of partitions and save them to trhe USB disk. I always attach the disk during the process so as not to make mistakes in deciding the target.

  • all in all it's plain "dd". :smile_cat:

That's interesting ..... never tried that. :thinking:
I always copied my encrypted partitions verbatim i.e in their encrypted state. I've always deemed an encryption on top of an encryption as "overdone".

Testing out quite a few distros (mostly Debian) always find the same. Be it with or without GUI. :applause:

And now you know why I always keep my $HOME in a separate partition. :mwahaha:

no, i mean all my partitions are encrypted, even my big external hd (of course), but clonezilla cannot read these partitions, unlike elive, which is able to list encrypted or lvm partitons:

~ ❯❯❯ sudo partitions-list --show-all
/dev/mapper/elive_vg-root_lv::filesystem::ext4::Elive_OS::Elive_OS::::::1ecc7fec-37af-486e-aa86-06b73b075608
/dev/mapper/elive_vg-swap_lv::swap::swap::swap_lv::(swap)::::::2b88d226-2a70-46c6-9cbf-8086bacf4343
/dev/nvme0n1p1::filesystem::vfat::::(no name)::104857600::97 MB::6757-7E18
/dev/nvme0n1p2::filesystem::ext4::Elive_boot::Elive_boot::314572800::292 MB::8f899262-a600-4c00-b76b-6956a706fd38

so, clonezilla don't know these partitions exist and so i cannot save those dumps anywhere

Correct Clonezilla doesn't/cannot decrypt ---- no real reason to. So in that case you'll have to clone the entire disk verbatim.
After copying it to another disk, the encrypted structure will still be there i.e will be accessible.

There is an option disk-to-disk there IIRC.

I think he means the external hard disk that he's saving to isn't being recognised

In that case, Clonezilla isn't the correct tool...like it's name says, it's a cloning tool.
On top it's rather overkill to clone encrypted partitions to encrypted disks i.e double encryption.

yep, even with the encrypted layer opened (so showing the partition inside as /dev/mapper/something), it doesn't shows up, so im unable to save the dumps

yeah but why this strange behaviour of "select the partition where to save" (what?) instead of "select the mountpoint where to store the dumps" :thinking: anyways...

no its not about cloning an encrypted partition, its about "where to store your dumps"