Printer - Scanner

Trying to add a Printer and the ADD buttons are not clickables Any ideas ?

That Canon Printer MF644Ddw is also a scanner, what is the best way to add the scanner (I tried the scanner app that was looking for the scanner but didn't find it) ?

I think when installing, I clicked the Printer / Scanner support....

Note : it's a Network scanner but could be plugged USB if needed. But the problem is that the Add buttons do not work

yes. You need to press the unlock button to access the Add buttons.


I think I tried lol but will do again
This screenshot was taken while the add button didn't work and the lock seems unlocked anyway I will try


:rofl: You were right TKS

I now have to work a but on the Driver part of it.... Mine is not listed in the Canon list from the GUI
I downloaded this from Canon but it doesn't seem to help

If you want it to work as network printer, you'll have to look around on the LAN but what I see is that there aren't any printers connected to 'localhost' ..... I'd say that is correct.

I'm not sure but I don't think scanning (i.e sane) works well over the network. You might want to configure that over USB. :thinking:

I remember having vehement discussions on the Mandrake email list (with one of the 'Sane' devs) about the uselessness of network scanners because you'd always need physical access to the scanner to put the original on the plate....especially in a corporate office environment. :rofl2:

1 Like

tks will try over usb. As for the Driver, usually, what Debian need ( Driver) is it something that is included in this : ?

If I choose the debian GUI, Canon, then look for my model, it's not there.... And that GUI if I point it to the Canon Folder ( link above) do not find what it needs.... PPD I think (Need to try again later today)

Android phone, Iphone, other OS I tried, recognized my Printer easily....

... @triantares and later you say my UX concepts are bad :slight_smile: :rofl2:


Yeah .... I agree, printers are a mess because it's never clear who controls them.
I got into quite a spat with the SanE dev at the time.
Til Kampeter (CUPS dev) was a great guy but he didn't do scanners. All-in-ones didn't even exist then.

1 Like

If it's network printer, then scan the LAN and it'll show up.....normally no drivers needed. That's a Windows thingy.

Scanners are different beasts ..... do you want me to Google that for you or are you going to do that yourself?

Those are for printers not scanners.

will get back to you tks do not search

1 Like

If the Printer config is locked, it should show LOCKED LOL and not the opposite... IT would be one less question here or frustration for the noobie

1 Like

I used the script from canon and now my printer works well in USB

As for the scanner, since then (I installed the printer using the Canon script), the scanner is recognized but for now it doesn't work. Start and app fail... Will play will that and let you know how I fixed it

Actually that is a dilemma. The button shows the action it takes/does, NOT the actual status.

The best would be to have a text like 'unlock' (i.e the action) or 'locked' (the status) to be clear. Icons just don't cut it here.

1 Like

By what? 'simplescan' or 'xsane' or something else?

Those networked printers sometimes don't show up in the LAN. They are set up to be accessed directly through a preset static IP on first start. Check if other machines see it and what IP address it has....then search for it using that IP address.

Most App and Web interface I used have an icon showing The status... RED (STOPPED), GREEN (Started), Locked Icon (Presently Locked) etc

IF a lock icon for you do not make sense, yes some text could may be help

If I'm the only one asking for that, it means it doesn't worth doing it, else other would have asked for it before :wink:

In Programming or Business etc something people will complain about something and make a BIG THING ABOUT it the question to ask is always to ask : HOW MANY TIMES DID IT HAPPEN during the last month, year etc... Sometime we put efforts at the wrong place.

On another note, if something is recurrent, it needs to be addressed....

Do note that, that little cups configuration applet is part of the Gnome utilities. So it's not something Elive can change ..... other than writing our own applet.

You can ask, but not here. :rofl2:

1 Like

LOL ok

My scanner and printer (on the same Canon MultiFunction) are not running fine without USB cable

The problem was NordVPN !!! As it was my local network, I would not have tough NOrdVPN would influence...

Installing the Canon software and driver using their I think did help also ( as I now see the right model in the list)

But the main issue was nordvpn.....

Yes, if running it from/on a single machine one cannot connect to the LAN and others there cannot see it either.

You can however contemplate on having your router pass through a VPN, that way all local machines can see each other and are all on VPN.

But sometimes NordVPN has quirks like not showing the pictures from imgur on certain exit servers.

1 Like