Printer setup fails for unknown reasons

I am trying to set up Elive as a productive system and not just as a playground, and so today I also finally wanted to set up a printer for the system. I have a Canon Pixma iX8750 connected to my machine over wifi. It is definitely recognized and listed as connected, when I look into my router's network settings.
When I call system-config-printer, there is at first one thing that strikes me (because I have never seen this in other distros): the setup dialogue needs to be unlocked first. Is this normal in Elive or is it unusual there, too?
When I had unlocked the dialogue, I added the new printer, and everything seemed to go as known from distros such a Linux Mint: printer is detected, driver is found and installed, you give the printer a name. So far, so good...
But when you want to print a test page, the process starts, but stalls after a couple of seconds with the message that the printer could not be located.
Now here I am lost: what exactly does this mean? It has a network address, you can even open the webpage (although it asks for a user name and a password which I do not know - I have never set one, but maybe the pre-owner). Unfortunately CUPS is no great help either: other than that error does not show up.
Any ideas what else I could try? Hopefully it can be fixed...

It's yours. The system username and password. e.g. username: emil, password: 123456

Looks like the printer connection is conking out which might be down to a wrong protocol or permissions.

My remote printers (Brother) use ipp addresses but I gathered that your printer requires an lpd: address like 'lpd://'.

Setting remote printers on my Elive systems works best by indeed 'unlocking' and using 'add printer' after which I opt for 'find network printer' and enter the printer's IP address and let it search.
If all goes well, it should automagically install and run the needed software.

Unfortunately not. I have also tried the UN and PW of my router, but that did not work either. So I have no idea what is expected.

I have also tried your lpd suggestion instead of the 2 discovered printers (I had deleted my dead end printer before wanting to have a fresh start). I could complete the setup, but this time, when I tried to print the test page, there was the error: CUPS server/internal error.
I remembered then, that I had still two aces up the sleeve worth trying:

  1. Finding a driver directly from Canon

  2. An original PPD file from my linux Mint machine, where this printer works flawlessly.

Canon does offer a Linux driver for download, I found, and it is an archive with an I gave this one a try, and it worked. No errors. Looking again in system-config-printer, I found the newly installed printer and ordered a test page, and this time I had it. So, that was it, then. Problem solved.
Thanks a lot for your advice anyway - it helped me not to give up too early :wink:

That's what it is for me, sooo

If you've set up a root password, try that username/password.

In general the cups webpage on localhost:631 would ask for 'root' but actually you shouldn't need that weppage in the first place as you've already logged in by unlocking the printer-setup app.

Anyway, glad it sorted itself out and it might be worthwhile to have a look at the printer properties and make a note of the protocol nd the IP address is use....i.e does it use lpd: or ipp: or whatever?

Not really, not until what caused it is known....saving a hassle in the future.

Does not work either, but ultimately does not really matter, because I do not need any advanced settings plus I can access quite a few settings through system-config-printer. I am happy that I can print now...

Not for me. Maybe it's because I have a group setup for my user or something.

Ah, now I see you misunderstood me about the webpage, because I was not clear enough. I was talking about the Canon Printer Network Setup Page which appears, when I enter its actual network address, and not the CUPS page. That one wants a username and a password which I do not seem to know, see below:


Well that would be solved by resetting the printer to factory settings and using the password that can be found in the manual or on the Canon site.
Username=ADMIN at any rate.

Thank you! This is good to know just in case. At the moment I cannot see an urgent necessity for it. The printer does what it is supposed to do, and that's the most important thing :slight_smile:

In the Elive Retro 3.8.32 version, I had printer setup issues resulting in a CUPS internal server error.

For some reason, the CUPS driver information setup did not appear at all, and was bypassed somehow.

In the end I got the printer working by typing in the command system-config-printer, in the terminal. And this time the CUPS driver selector worked.

I was able to print a test page, and that was that.

That's weird as that is the exact command the menu entries and the .desktop use to start.
As an aside you can always get to 'cups' using your browser and aiming it at:

then it sounds more like it needed to be run "again" to make it working, this means that if @linux23dragon try to run it again from the .desktop it should work

Come to think about it. I remember that that printer was off when I tried to attempted to re-configure the printer again. Now what happened was that the printer selection had the printer model label only in the networking sub-menu. Not the networking listings that you see when the printer is on and networked.

So that might be the the case why the CUPS driver selection window worked in the end.

But yes. I did try to configure CUPS again, the second time, and it worked.