Problem upgrading from 2.0 to 3.0.3

#1

I tried to upgrade from fresh Topaz 2.0. I had run the repository fix script and when I did an update with Synaptic I saw that elive 3 installer was installed.

I have downloaded with another computer the 3.0.3 iso hybrid stable image (because the iceweasel on 2.0 wont show any buttons on elive webpage). I have put it in the downloads folder.

I opened the upgrade elive, chose the iso image from the folder and the program started to work for sometime. At last it said that complete and I can reboot and upgrade.

When I reboot and choose upgrade from the bootlist there only comes a black screen with few lines of a starting texts and then in the end file not found error 15.

Now I tried also to see the Upgrade Elive sertings through the Settings panel path but when I click the Updater from the list I get the notice that it stopped suddenly. But at the back there appears the box to download the image and upgrader continues normally. Now trying again the upgrader. Is there some certain place where I should save the iso image?

0 Likes

#2

Autoupgrade image_dir=upgrade/system resolution vga=788

Error 15: File not found

Press any key to continue

0 Likes

#3

This looks a lot like problems I have had. It lseems as if UUID gets changed or that an earlier partition table is getting used, pointing to the wrong or non-existing partitions.
Creating a completely new partition table (the gparted version on 3.0.3 does not have that option afaik) might resolve that. “testdisk” utility should be able to do that too but my results have varied from disastrous to dificult.
In your case I would certainly advise to get “superGrubDisk” and see if that can boot your system.
Download it (only 20mb) from: https://www.supergrubdisk.org/
I suspect that apart from not booting correctly, probably the whole system is correctly installed.

0 Likes

#4

Installed ploplinux on cd and got an option to boot from usb so now trying usb install of 3.0.3 but not sure if it will work.

Not working. I get the installing screen to choose language and keyboard and then it starts to set them but after that the screen goes bad with nothing but grey squares, then black and after a while white and makes the machine do a boat horn sound with full volume. That is quite scary.

I think I get the installation to the desktop but its all white/grey texture. Is there a way to start xterm and there run the installer (what would be the right command?)?

0 Likes

#5

Hmmmm, frankly you remind of a cat chasen it’s own tail. Why not use the SuperGrubdisk to boot the already installed system?
Methinks it boils down to your graphic card again…it’s maxing out its memory.

0 Likes

#6

Maybe. I just believe this machine could run - I mean crawl 3.0. Being slow doesn’t bother me ss much as not being able to even try. Now I think I have to wait if there comes some updated lighter version with more graphic driver support (which I believe is the problem, display not recognized properly).

0 Likes

#7

Nope its the hardware.

0 Likes