Running 3.8.30 on a Thinkpad X1 No UEFI boot

Trying to boot the new 3.8.30 in UEFI mode gives me a totally black screen i.e it never reaches the USB-drive whereas "legacy-first" boots fine.
Trying on another Thinkpad that has UEFI, does allow 3.8.30 to boot.
That makes me wonder if having 'refind' installed on the X1 could have something to do with it. :thinking:

Anyone else see this behaviour?

Not booting in EFI has a downside when using the installer to upgrade, as it will ask to create a 8 mb partition (which is already there) .... I opted for 'No"

A gripe I do have is that on start-up of the live desktop I opt to NOT start conky but it starts anyway.
IIRC I saw this behavior with 3.8.29++ as well. :thinking:

Ultimate result:

A totally unbootable system, be it in legacy or UEFI mode. Gahhh! :face_vomiting:

In addition:
Subsequent reruns of 3.830 live and the installer do not even offer the upgrade option anymore.

Looks like a case for clonezilla. :shocked:

I just tried it in the Macbook i have (with refind) and no problems, all the options boots (list detected from refind and options listed outside refind) except the legacy detected one (which is normal because MacBook doesn't supports legacy boots)

Make sure to record your usb's with DD (or usb-bootable-elive, which is the same but more safe)

I don't know what is going on your side but is worth to investigate, we don't want Elive's unbootable on some computers :slight_smile:

Also, just make sure the MD5 of the iso is correct :thinking: and / or record it again

yeah you need to keep your system in the same efi / non-efi mode all the time, efi option is better, if asks for that partition is because it needs it so if you say "no" you may have a wrong installation, but again is better to keep the efi / non-efi mode all the time instead of switching

these things sounds very strange :thinking: for me it boots in both modes and the installer also offers this option :thinking: :confusing:

I have no idea either. it just refuses to boot the USB in UEFI mode.
It looks to be down to that specific machine and I just put the backup copy back in place (took 3 hrs) with clonezilla.
Tried again with removed 'refind' and same result, Elive will not boot in UEFI mode but somehow others will.....I just get a blank screen no blinking dash, nothing.

I'll try using a different USB drive to write Elive to and see if that helps in anyway.

I did find something strange on the machine (you can see it I submitted all install runs with my proton.me address):

Filesystem                    Size  Used Avail Use% Mounted on
udev                          3.8G     0  3.8G   0% /dev
tmpfs                         783M  1.7M  782M   1% /run
/dev/mapper/elive_vg-root_lv   39G   25G   13G  67% /
tmpfs                         3.9G     0  3.9G   0% /dev/shm
tmpfs                         5.0M  8.0K  5.0M   1% /run/lock
/dev/sda2                     399M  164M  219M  43% /boot
/dev/sda1                     217M  274K  217M   1% /boot/efi
/dev/mapper/elive_vg-home_lv  410G  354G   44G  90% /home
tmpfs                         783M  144K  783M   1% /run/user/1001
overlaid                      783M  144K  783M   1% /run/user/1001/triantares-chromium

As you can see I've got '/dev/sda2' mounted on '/boot' and then efi (on sda1) mounted on it again.... where sda2 is ext4 and sda1 is vfat...and sda3 is encrypted.

Device       Start       End   Sectors   Size Type
/dev/sda1    16384    466943    450560   220M EFI System
/dev/sda2   466944   1327103    860160   420M Linux filesystem
/dev/sda3  1327104 976773119 975446016 465.1G Linux filesystem

That is really weird .... I've no idea how that got to be there. :shocked:
Frankly, I'll have to delve into that to get it sorted out without messing everything up again. :face_with_thermometer:

update:

Doesn't boot on a totally different USB medium either. :frowning_face:

AS to sda2 and sda1 .... they are as they should given the OS on sda3 is encrypted..... so still looking. :work:

OK, solved it!

I did some cleaning up with 'efibootmgr' as UEFI was getting cluttered but I doubt that was the issue.

What I did do was go into the BIOS and set USB-HDD as the first boot device. Before that I simply choose the wanted boot device using F12, apparently that mucked up the boot sequence on this particular machine/mobo.. :shocked:

Prolly because the GPT partition scheme got removed on the first upgrade.

BTW this doesn't make UEFI any popular:

so the bootloader loads (menu with kernel options etc..) but next doesn't? what about pressing TAB (or "e") to edit the boot options like remove "quiet" and "splash", and adding "vga=791" ? i think the "graphical problems" does the same thing... if goes to a blank screen is at least something! seems like is stuck on the first boot step, try all the options to see if you have any debug info (try also the "debug" option from the list)

yeah, sometimes we don't expect that it can be these things... also i suggest to try the "-c" option from usb-bootable-elive tool (to cleanup all the USB, in case is not working good)

yes, that's perfectly normal, so you have an extra /boot partition and the efi partition needs to be mounted inside a subdir there too

good to know it was solved :slight_smile:

No, it didn't it never did anything....clearly a firmware(UEFI) quirk as 'legacy mode' (BIOS) didn't have any problem booting Elive.

But again, let's be abundantly clear:

There is clearly something wrong with the firmware on this laptop i.e other laptops with similar specs and same manufacturer do NOT have this issue.

OTOH other USB devices do launch/boot albeit with some slowdown. ElementaryOs does boot when using F12 to choose the device but it does so extremely slowly and with some checking of stuff.

Here's a pic:

But eventually it does boot ElementaryOs where with the Elive-USB the machine just sits there doing nothing.