Running and installing Elive3.8.27 on an Acer Aspire 3610

My exprerience running and installing the latest Elive on this ancient machine that has a single core Celeron 1.50MHz CPU and only 500Mb RAM. On top it's the only machine I own that still has a working Windows on it.
It's WinXP and I need it for the proprietary software to connect and (re)program the Siemens S7 PLCs on one of my ships that has a hybrid electrical propulsion system. So the XP has to stay on it and has to stay untouched 'cause of all the licenses required.

So feeling audacious I went ahead and wrote the 3.8.27 32 bit Elive to a flashdisk, stuck it in in the Acer and hit F12 for a boot-menu. :happy_dance:

Boot is excellent and I simply choose the default option to run the machine. The boot script sees that the machine is low on RAM and offers to create a temporary swap file on the existing free space of the local disk housing XP (sda1) and I agree to let it do that.
It creates a 500Mb swap file on the NTFS partition and mounts it .... that's really great work. :+1:

The rest of the boot sequence is relatively fast, given the specs of the machine, and bingo it's up and running. Elive running in live mode is real easy on the (500Mb) RAM, using only 112Mb and 43 on the swap file. Even the old 1.50GHz Celeron CPU isn't overly stressed. :applause:

So let's give the installation routine a go.

On running the install script I get warned that I will not be able to use partition while the temporary swap file is on it. Very good but not actually what I had in mind.
So I rebooted to see if I can have the swapfile on my USB stick or an extra flash-disk.... Alas, the installer seems set on using the existing sda1 and no obvious way of pointing it elsewhere. :frowning: Couldn't the flash-disk that Elive booted on be used for that, if it has sufficient space? :thinking:

  • On a side note: I found that the Elive animation, on exiting shouldn't be the same as the one when booting. It had me wondering if I'd already rebooted or not. :thinking: .... at the least add a "Goodbye" or something to the 'shutdown' animation to differentiate.

Having resized the NTFS partition and creating a second ext4 partition on sda2 I went ahead, rebooted and accepted the swapfile into sda1 again .... and ran the installer again.

Installing Elive next to XP is a bit of a struggle, even to me. I think the installer needs to be clearer here that it's intending to use the partition next to the NTFS one i.e leaving the NTFS untouched.
On installing it wants to remove the swapfile from the XP partition and offers to make another on the separate empty flash-disk I've got there.
I refuse because in my view "so what? It's not in my way now!" but then I notice not having any swap at all ---- so I quickly created a swap partition on the flash-disk and mounted it (using 'mkswap' and 'swapon') for fear of running out of memory.

.
Interesting to find out what'll happen to my swap after a reboot. :thinking:

  • Addendum: Turns out grub then cannot find the resume device (the flash-disk) and slows booting down considerably. That required some editing of '/etc/default/grub' and updating grub.

Using 'tmux' for the installation info is good .... but there's a downside: If you've never used 'tmux' before, you wont know to hit "enter" to see the scrolling info that the installer is spitting out. You'll be stuck on the welcome screen...or at worst close the window, which could be harmful :frowning:

  • A thought about future low spec installations: Maybe a minimal install next to a 'full' should be an option. In about the same way Slackware used to offer.

After reboot everything is fine, offering a dual boot with Elive and XP. Once booted Elive needs either a swap partition or swapfile (which I hadn't made, remeber)....for efficiency I temporarily used the flash-disk again.

  • Might be a nice enhancement to have an elive-tool for creating a swap file in an existing partition already in use. Especially, as in my case I'd used up all free space for the root partition and didn't feel like resizing and messing around with 'gparted' again.Hint,hint ... nudge,nudge.

Anyway, the installation runs surprisingly fast where I'd actually expected to be needing Stable to get it running nicely .... Well done! :applause:

I did have a strange warning about shaking the machine .... So I suspect I'll have to keep an eye on my HD and at the least make a backup of the so direly needed XP there. :stuck_out_tongue_winking_eye:

Now where did I leave that 'Clonezilla' disk?

2 Likes

Very detailed report and helpful.
Thank you

:nod:

Did you try to install that software in elive? :slight_smile: wine may make it working

Good, long long time since this feature wasn't tested :slight_smile:

That's very good to know :slight_smile: , the 32bit version but especially the overall elive system optimizes things when there's low resources to make it lighter (dynamically on live mode), good to know that works so well in only 500 MB of ram :happy:

Improvements made:

  • improved message when asking to create swapfile, telling that you cannot reparititon a disk while using a partition and suggesting to use a different disk in case of wanting to install
  • when auto-loading the existing swapfiles found in your disk, asks you first if you want to load it (so you can skip it to use a different one in another boot)
    • if you select "no", the swapfile will be deleted to cleanup space on that had

Done (untested)

messages and behaviour can be improved, but we need to know "which" exact message we want to change to what, or "which" exact behaviour to change to what, actually I don't know what are you referring exactly on the installer (and whats the improved suggestion)

I will need to investigate that more with betatestings since its a complex thing

The welcome screen on -that- moment was a small bug (hopefully) fixed for the next build, but closing it doesn't harms anything :slight_smile: that's why especially tmux is used for that task

I'm not sure to understand what you mean but i if correctly understood, elive offers this option in a better way, since you have the options to unselect features and if you unselect all of them you have the most minimal install possible, that's important this way because there's no specific preferences, let's say somebody wants a small install but also needs dropbox for work, or debugging packages installed, etc... Note that most of these options are pre-selected based on your hardware / needs / etc dynamically, so just clicking in "next" (aka: users that don't read) stills the better default option :slight_smile:

yes, this was planned since long time (just use a swapfile on existing root partition), this implementation requires a bit if UX brainstorming but also a correct implementation (hibernate should recognize it), maybe better to wait the switch to bullseye before implement it

yepeee! :happy: :happy_dance:

This is a funny feature, my ex moved a lot the computer while running (mechanical disk) and I told her many times (unsuccessfully) how dangerous for the hard disk was to move it while running, so I understood an UX feature for that would be needed, it ended on this feature, a watcher of "shakes" received (just like a detector of bad blocks in your hard disk) :slight_smile:


Note: moved thread to #get-involved:betatest category
Note2: @triantares I think we should not use tags for these betatesting / reports threads, I mean using them will make the thread appear in a tag-searching, but these threads are not useful for normal users, are mostly useful for staff / very-active users

Nah, it's a thingy about how they connect (USB-Serial) and also a stupid dongle. Expensive shit. :frowning:

Well on the installer you've got to use the "my disks are already partitioned" option (if you've created a spare partition) which could be clearer in the sense that a text like "continue and keep your current partition scheme" or "continue and install next to existing Os" or something like that.
The current text sounds very definitive, as if you're actually going to quit the installer.

Less complex than it sounds:
Due to having my swap on /dev/sdc1 which got changed/removed on first reboot after install, 'grub' is looking for a resume device (by UUID) that isn't there anymore. After a while it gives up trying 'mdadm' and continues to boot.

I set the resume device to 'none' for now as I'm not sure yet if my 'swapfile' is sufficiently large or even recognized. :thinking:

Yes but this makes the install procedure quite tedious as it's actually uninstalling stuff from the default full desktop experience.
That would mean offering a downsized 'minimal' option on booting the USB and installing from that.

Exactly what I'm trying to find out, as mentioned before.
I tried pointing grub to the file but that didn't work. Looks like it requires UUID and prolly some systemd magic.

Yeah but believe me the machine is very, very still and I still get these messages after every fresh boot.
I also notice the disk(I think) giving 5 or 6 very audible ticks every time (only on Elive not XP) I boot.
It's also the only non-thinkpad machine I own, so that might also be why I've never seen that message.

As to Note2:

  • A few of those tags get added automatically due to the content .... I'm not sure if that's always as it should be. :thinking:

I wanted the positive report (it's actually more of an article) to be found and shared because of the hardware specification and also to show how that it's something still actively being pursued by Elive. ....I don't think there are very many distros that can beat the lightness of Elive here.
I mean: "Look at at it !! A full fledged desktop at only 120Mb RAM" : :applause:

Very nice written.

Windows XP is very forgiving. So I would try to convert the running host to a fully virtual machine.
The process is not official supported by Microsoft or Oracle (Virtualbox), but it worked for me:
https://www.virtualbox.org/wiki/Migrate_Windows
Should also work at physical 265MB RAM.

In another case (Win7) I needed to migrate the physical Host via VMware (Standalone Converter) to a VM and convert this to Virtualbox. Much more complicated, but works in the end as well.

Today I am struggling with Hyper-V. I really want to go back to the well community documented Virtualbox, with a real CLI (works even headless).

that might be an option once the Acer dies but for now the machine only needs to boot up if I want to diagnose or re-program any of the PLCs.... the interface for the whole shebang is Win CE and took me (and others) multiple days to install and setup. I don't want to go through that ordeal again if I don't need to. :face_with_head_bandage:

Linux can directly access the S7 PLCs over USB but the available options are fairly so-so and my propulsion system too intricate to play games with. We've already messed up too often in that sense.

Going off_topic here: :offtopic:

What I'd actually love to do is virtualize that whole propulsion system and then start experimenting.
The whole hybrid installation was set-up in 2014 and wildly out of date nowadays....certainly if I compare it to what my new Hybrid Honda can do. :thinking: Which after all is a somewhat similar arrangement.

I don't think it is offtopic, at all.
You've described how great Elive is working on legacy hardware. If we can virtualize the running WinXP and run as guest on Elive as host -> Win.
A topic, often discussed in flavor 'Dualboot yes/no?'.

The charm is, that there is no 'setup again'. It is the same setup 1:1.
VirtualBox is able to pass through USB without problem.

I hadn't thought of that ...... good idea. :applause:

I'll give it a go and see if I can virtualize:

  • as a first I'll try getting the clonezila copy I just made to run on Vbox
  • then remove all the Siemens stuff and cruft to minimize
  • then create a .vdi

Putting the .vdi up for public download does probably create an issue with M$ and the licensing so it'll have to be a HowTo explaining how to do this oneself :thinking:
Of course a basic XP is downloadable elsewhere already:

Depending if the host (Linux in this case) sees the dongle and connection correctly, which it didn't at the time ....... believe me, I tried hard. :face_with_head_bandage: