Snap/bin not working

spotify /snap/bin
Command 'spotify' is available in '/snap/bin/spotify'
The command could not be located because '/snap/bin' is not included in the PATH environment variable.
I have just tried to put it in the path still not working and also apt wont install firefox cant see why

fixed it was me when installing wifi failed very helpful

Thanks for commenting about it. I don't like much the using of snaps but that's a user's choice :slight_smile: and is better if elive can simply make them working without dealing with things like your PATH issue

By updating the package zsh-elive it is now directly supported, you have your snaps available from your terminal directly :slight_smile: :happy_dance:

yes I can run snaps from the terminal but that path thing has got me stumped I tried some things from the internet but no luck do you have any ideas:sleepy:

well, try this command:

apui zsh-elive

then try to run the install snap (the executable name of the app) from a new terminal it will work

or... you meant how to run them from the menus ? (so they don't appear in menus?)

Mmh.. I need to know where it is located the installed .desktop files first, so it can be in directories like:

ls /snap/gui/
ls /var/lib/snapd/desktop/applications/

maybe other directories?

after to know where it is installed, we will make to appear in the menus :slight_smile:

its ok mate I got it working its in the bin directory I managed to get it in the menu

I am using the elive I installed on the gigabyte nvme pcie it is very fast but things arent working like they do on the ordinary ssd.I didnt do anything different on this install,also I noticed when I put a program in the cairo sometimes arent there when I reboot not sure whats goin on there