(SOLVED) Max Resolution 1024x768 in VirtualBox

I think this is a driver problem, but I cannot get past it. I've the latest Virtualbox Guest Additions installed, but cannot get my display to resize above 1024x768
Is this not supported running Virtualbox, or maybe a Virtualbox problem, or something I can change in my Elive 3.0.6 installation ?

~ ❯❯❯ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 0.0*
~ ❯❯❯ gtf 1920 1080 60

1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz

Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync

~ ❯❯❯ xrandr --newmode "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
xrandr: Failed to get size of gamma for output default
~ ❯❯❯ xrandr --addmode VGA1 "1920x1080_60.00"
xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "VGA1"
~ ❯❯❯ xrandr --addmode default "1920x1080_60.00" 1
xrandr: Failed to get size of gamma for output default
~ ❯❯❯ xrandr --output default --mode "1920x1080_60.00"
xrandr: Failed to get size of gamma for output default
xrandr: screen cannot be larger than 1024x768 (desired size 1920x1080)
~ ❯❯❯

On a first, be sure to give enough memory to your virtual graphics card. 1024x768x6(=4,655,040.00 bits) at least 50Mb. After which you set the display size from the guestOs.
On a second, it's always worthwhile to install the extensions pack. See here for more.

Thank you - I'm already on the latest extensions pack, and assigned the max of 128Mb to my graphics card.
I will test the same now using VMWare, to make sure this is not maybe specific to Oracle's VirtualBox

Well that is very strange.
On my laptop (on default installed Vbox, without even the EXt packs) I run 2250x1440 without a problem which would only point to a configuration problem on the GuesstOs, in your case.

  • You're saying you've got 3.06 (which is fairly old) running as HostOs, so could you tell what Vbox version you've installed and also what GuestOS you're trying to run?

BTW
Take care not to allow too much to the virtual card and in that way stifling the HostOs.

I also downloaded the latest version of Virtual box today, which is:
Version 6.1.14 r140239 (Qt5.6.2)

My Elive version I installed is:
elive_3.0.6_stable_hybrid.iso

My Host OS is:
Windows 10 x64, with all the latest updates.

I've installed VMWare this afternoon to see what that one does. I just want to get most of my Windows stuff to work with linux equivalents, before replacing my Host O/S with Elive Linux.

Ah, that makes it all a lot clearer.
So summarizing:
You are running/installing 3.0.6 on a virtual machine and need to resize/set the screen resolution and are using xrandr to do that.

Primarily, seeing you have a Win10 64 bit machine I'd recommend the Beta release which has more up to date drivers and software in general.
3.0.6 is extremely Stable albeit a tad old and in some respects lacking software due to it being 32bit...so if you like it use/install it and if not, definitely try out Beta.

As to 3.0.6:
To set the screen resolution, best you use the GUI tool (arandr) for that:
Choose "applications", "preferences", "screen settings"

and in the tool choose the menu item "outputs", "default", "resolution" and choose the desired resolution among the offers.

and apply the choice, it will go into effect immediately.

I've got 3.0.0 running as GuestOs on Elive 3.6.17 Beta Host, which gives the following resolutions and the VirtualBox setting using 60Mb for the card as can be seen in the settings on the left.

Thank you for the detailed feedback. That's weird , I can only get one resolution setting

I have 32Gb RAM on my Laptop and have 8192Mb to this VM, and 128Mb Display Memory.

Ran out of time yesterday to test with VMware - will do the test today

OK, not sure what is causing this, VMWare does not show this problem, only Virtualbox, whcih is with the same RAM/DisplayRam/Storage/CPU cores.

I will compare hardware settings between the two installs to see if I can detect the problem in VBox (Other people night also have this problem)

So it's a setting in Vbox, probably the graphics or a wrong 30.6 installation but suspect the first.
Here's mine:

This is what I had it

I changed it now to match yours, and rebooted, but still the same (Just bigger because of the "125% scale factor")

image

setting the controller to VboxSVGA gave me better ... x60 values ...... so maybe try out the others too.
It's a bit dependent on the Host hardware you've got, whether it's SVGA or VGA.

BTW did you use the same installed 3.0.6 image voor VmWare or did you create a fresh one?
If it's the same image, it definitely is Vbox setting.

So it might be worthwhile to checkout Vbox forums or a Vbox related search in general.

It's the same ISO file I used - I only have the one I downloaded 2 days ago. Both VMware and Vbox detects the same graphics card. I agree, it is definately not something in Elive - It is something in Vbox.
I'll put this to rest for now, and post an update should I be able to find what is causing this.

1 Like

@triantares, Thank you for the guidance. I changed it to vBoxSVGA and that worked - I have multiiple screen resolutions now.

image

Also found this note, which confirmed what you said:

"So as stated above, it does seem that VBoxSVGA is a better bet for Windows and VMSVGA appears to be better for Linux."

It does not allow me to put "links" in my posts - here is the screenshot of the above info

image

To stop that from happening, just read a few posts on the forum and you'll get Trust Level 1. I took the liberty of adding the link to your post so people don't have to manually type it.

Also welcome to the forum :smiley14: