Support for Broadcom B43 WiFi driver


#1

As many you know, B43 is a very tricky wireless driver that 90% of the times give problems having them working for the linux users

Elive is very glad to have them now working for the final version, just like did in older stable versions of Elive

Special thanks to Stephan for allowing the remote needed tests to make it working, this will benefit the entire community!

How to use it in your actual Elive

From a terminal run:

apui elive-tools
sudo b43-driver-fixes

That’s it! And your next reboot will have the WiFi perfectly working, comment here If was not the case for you

:boogie:


#2

@Thamatermesis: Thanks for your effort to create a script in our remote session to get this B43 driver working.
Excellent job; works perfect for me now!
And so it will for the rest of the world!

Cheers,

Stephan


#3

@SickNature the original script that we tried changed pretty much, to be better integrated with the system

I would be happy if you can confirm that the new one works correctly, this can be a very fast test by booting the Live mode of elive and running from it:

sudo su
apui elive-tools
EL_DEBUG=3 b43-driver-fixes


#4

More features added:

there is a common problem with some cards managed with the b43 driver, it gets disconnected randomly, with an error in dmesg saying:

If users are affected by this issue, Elive automatically adds a configuration fix in the system


#5

@Thanatermesis: Unfortunately I keep on facing issues when executing the b43-driver-fixes.
The following error messages are displayed:
/bin ❯❯❯ sudo b43-driver-fixes
FATAL: Module brcm80211 not found.
mv: Aufruf von stat für „/lib/firmware/b43“ nicht möglich: Datei oder Verzeichnis nicht gefunden
mv: Aufruf von stat für „/lib/firmware/b43legacy“ nicht möglich: Datei oder Verzeichnis nicht gefunden
FATAL: Module brcm80211 not found.
mv: Aufruf von stat für „/tmp/b43“ nicht möglich: Datei oder Verzeichnis nicht gefunden
mv: Aufruf von stat für „/tmp/b43legacy“ nicht möglich: Datei oder Verzeichnis nicht gefunden
E: B43 device not installed correctly:
06:00.0 Network controller [0280]: Broadcom Limited BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
/b

the lines starting with mv: state that the desired file or directory cannot be found.
any ideas?


#6

Can you connect to the chat? it will be faster to look at it from there


#7

perfect! thanks for the tests, 2.9.99 will have the extra things to make it working for more users :slight_smile:

Tell me if you have any issue with it


#8

Luckily I found this post!
The fix works perfectly, thank you!
Till now it had a weird “attitude”: it was either unable to connect to internet, or it didn’t detect any wifi connection but I was able to surf the net once the connection was manually set up.
There’s something I do not understand, why using elive in live mode it worked perfectly while once elive was installed it needed this fix? It happened all the times I installed elive on any laptop with b43


#9

That sounds bad, are you using the 2.9.99 version ?


#10

Yes I am
It doesn’t sound that much bad in the end, once I read this solution the problem was gone already. Maybe a reminder during the installation would be enough already to solve any trouble to anyone in the future!


#11

not much people read / search / ask for a solution, they normally ignore the problem and live with that, just like bug reports… today’s, almost nobody reports bugs

That’s not optimal, there can be many different issues (topics) to remind the user’s about, the best way is to detect needed things and do actions depending on the needs, and of course the optimal is to just make the things work correctly (just like it correctly works on Live mode)

In fact, the Live mode makes these drivers correctly work thanks to this script which is run at boot time if b43 hardware is detected

By other side, I’m just reading the source code and it should be also run the installed mode, why it is not run? I don’t know… but make sure that:

  • in a new / first desktop configuration on the installed system, you are asked to select which daemons / applications to run at the start of the desktop, one of them is called “enable wifi”, which is the one that runs this script in case is found

Could be nice @stoppy98 if you can betatest these steps to know where is the issue in order to fix it in Elive permanently:

  • do a new install (users and files are saved with the migration mode) of the 2.9.99 version (to make sure that the driver is removed)
  • boot the new system, wait 5 minutes after the new desktop is created and check if wifi works
  • run “apug” to upgrade the system, reboot, and wait again 5 minutes to see if the wifi works
  • make sure that the dir /var/cache/firmwares/ contains files
  • if still not works, run the command: gksu /usr/sbin/b43-driver-fixes
  • check if wifi works
  • run “sudo su” and then “EL_DEBUG=3 b43-driver-fixes” to know/see some debugging messages if still not working

Final note:

After to brainstorm these steps, if that command did the fix in your actual installed system, it means that was not automatically run by default and the only reason of that should be that you unselected the desktop application “enable wifi” at the first desktop creation… can you confirm that?


#12

i always looked at what i was checking, however this time reinstalling everything (even doing a clean install) on my laptop didn’t cause any problem.
Looks like i messed things up a bit during other installations then (maybe my attention was caught by these damn amd drivers causing only troubles!!).
P.S.:
that comment at the beginning of live session about AMD drivers is fun, but didn’t have that much more luck with Nvidia legacy drivers! ahahah

edit:
it happened again :confused:

edit 2:
this time i needed to repair the system after i ****** it up Just a little bit after trying to fully migrate to 64 bit architecture.
I haven’t been asked to automatically activate wifi in this case since supposed to be using the previous configuration i guess.
Anyway the above steps you listed worked perfectly, moreover during a normal installation i didn’t meet the problem anymore so maybe it was just due to my distrction.


#13

Well, the good news is that “it works by default correctly” so that’s very good news for the final release :slight_smile:

Note that if you change to another kernel is possible that the driver not works (and probably fixed too using the that command)