Time & Date error, stuck at 2002

I'm fairly a beginner Linux lover .. and I installed Elive on my ViewPad 10 pc tab.
Everything went well and things work fine .. except time and date are wrong and cannot be corrected if I select my time zone correctly .. Chrome and web browser won't load because of that.
Any idea for help
Many thanks and regards

Open a terminal and try running "sudo dpkg-reconfigure tzdata" or if you haven't allready, go to "settings" and use "hour configurator" which will ask a password too.
The latter is just a frontend to the same command.

Do make sure that your Viewpad BIOS/firmware has the correct time setting ..... that'll save some ado.

You were right! ... I corrected BIOS system date and time ..
The date was corrected but the time remained 2 hr different even after I ran the command successfully in terminal and it read my Time Zone correctly ...
Many thank for helpful reply

Once your machine has an internet connection it should set the time correctly .... if there's no connection you can always set your BIOS to your correct timezone yourself.

Chances are that the OS is trying to correct for winter/summer time aka daylight saving.

Precisely ... I tried this now
Strangely .. my other Win PC had the same 2 hr difference problem .. I had to reset it manually then ran Win 10 update the sync in order to correct the problem
Thanks again for your kind reply