Unable to install Epson L3250 printer

Downloading driver according to the tutorial gives error:

Error: Dependency is not satisfiable: lsb (>=3.2)

Tutorial:
https://forums.linuxmint.com/viewtopic.php?t=245471

Well the tutorial says to download Ubuntu1804 (that's 4 yrs ago :astonished:) drivers, which will be outdated on Elive. Current LSB on Elive Beta 3.8.30 is now at 11.10
As you didn't mention which Elive version you're actually using, I'm supposing it's Beta so:

As a first install 'cups- printer-driver-escpr' from the repositories and then checkout if adding the printer will work (i.e is recognized) through 'settings', 'printer settings' in the menu.

HTH

They were on IRC, so here's some info they provided: (I removed some unnecessary messages)

<TheTechRobo> EliveWeb_86: What happens when you try?
<EliveWeb_86> Error: Dependency is not satisfiable: lsb (>=3.2)
<TheTechRobo> EliveWeb_86: What are you trying to run? Also, what version of Elive? (Stable, beta,...)
<EliveWeb_86> elive_3.8.30_beta_hybrid_amd64
<TheTechRobo> Try running this command:
<TheTechRobo> api printer-driver-escpr
<EliveWeb_86> ok
<EliveWeb_86> I'll try
<TheTechRobo> Let me know if it helps :-)
<EliveWeb_86> it is the most recent version 1.7.8-1
* EliveWeb_86 has quit (Quit: Connection closed)
1 Like

Your advice is good ..... more exact mine has a 'cups' which shouldn't be there.
I'll repair that. :innocent:

error

it didn't work I still can't print

Again: That what you're trying to install is an outdated package, and not from an Elive (or Bullseye) repositorie....it just doesn't work that way.

On my machine it installs fine:

~ ❯❯❯ api printer-driver-escpr
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following NEW packages will be installed:
  printer-driver-escpr
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 296 kB of archives.
After this operation, 536 kB of additional disk space will be used.
Get:1 https://deb.debian.org/debian bullseye/main amd64 printer-driver-escpr amd64 1.7.8-1 [296 kB]
Fetched 296 kB in 1s (548 kB/s)              
Selecting previously unselected package printer-driver-escpr.
(Reading database ... 273392 files and directories currently installed.)
Preparing to unpack .../printer-driver-escpr_1.7.8-1_amd64.deb ...
Unpacking printer-driver-escpr (1.7.8-1) ...
Setting up printer-driver-escpr (1.7.8-1) ...
Processing triggers for cups (2.3.3op2-3+deb11u2) ...

Albeit AFAIK the package should be installed already already on your system .... which leaves the question, if the printer is recognized or not by your system when you tried to add a new printer.

The 'Howto' you've been referring to is from 2017 and meant for MInt (Ubuntu base) NOT for Elive or Debian11. There isn't much chance of getting that working here... :innocent:

Did you plug it in?

Meaning: That is about the worst (and most often heard) description of an issue, I can think of.

Methinks that the following Howto is more relevant:

Thanks for the replies, I'll try and let you know.

did you go to the epson website and download the driver from there?
Their driver worked just fine for my XP640

Actually that printer is supported OOTB on Elive 3.8.30: