UrbanTerror fails to start

Downloaded 387 64. Run from stick. I have a 1TB usb disk with a lot of stuff. One partition is ext4 and there is my favorite game UrbanTerror. I run it, nemas problemas, 120 fps, and then I installed Elive on the desktop harddisk. Went to the usb disk clicked on the program and it didnt start. System told me something about wine-bla bla bla. UrbanTerror is for Linux, Mac and Windows, no need for wine. Tried as root, no success. I copied the game to my home dir but no change. What did I do wrong? It runs perfectly in Mint, Puppy, EasyOS, Debian, Ubuntu and so on, I had never a problem.

1 Like

Well, from what I can see it is a .exe file so unsurprisingly it might require "wine".

BTW I would recommend upgrading 3.7.8 either through "apug" or downloading the .iso. Youroriginal link should still work.

1 Like

Thanks for trying! But listen, I played this game for many years under a LOT of Linux os, did never need wine period! Just for fun Ive run it in wine too, just for to compare fps and so. And thereto: I could run it from the live session before i installed Elive.

1 Like

from apt-get, i get those results:

~ ❯❯❯ apse urban terror
ioquake3/stable 1.36+u20181222.e5da13f~dfsg-2 amd64
Game engine for 3D first person shooter games

on which looking to the description of the package, seems like it can be used to run this game (never tried)

Description: Game engine for 3D first person shooter games
This package installs a modified version of the ioQuake3 game engine,
which can be used to play various games based on that engine, such as
OpenArena, Quake III: Arena, World of Padman and Urban Terror.

1 Like

yes, from the live session on my usb stick the game started and I had 120 fps. But fails to start from Elive installed.

In fact the issue is a little more complicated, as long as we don't speek about the same input/output.

There are games, only for one platform. The devoloper decided that is the best and who wants to play need to use the plattform. This happens not only to computers, even to console games, advertised as 'PS4/XboxOne exclusive Title. That is the reason I've got 5 consoles at home, to be able to play everything.
Some years ago, the developers from ID discovered they are able to split the engine from the 'game'. So the Doom Engine was born and the .wad files described how to use 'em. Later a few gifted have reversed the engine end created prboom. as interpreter for .wad files ...

Than the Unreal Engine (UT99, ...) Quake Engine (no need to explain), the Source Engine (HalfLife, Portal, ...) developed. Some engines where even OpenSource.

As I see here, you're having the game on your stick. In which format? And there is a engine available, called ioquake3.

  • I don't know how you can show us the game on your USB Stick ... Maybe per ls?
  • please show us the status of the engine:

bm@lydia:~$ LANG=en_EN sudo apt search ioquake3 |grep ioquake3
ioquake3/oldstable,oldstable 1.36+u20161101+dfsg1-2+deb9u1 amd64
ioquake3-server/oldstable,oldstable 1.36+u20161101+dfsg1-2+deb9u1 amd64

Nevermind the LANG=en_EN (It is a german System) or the sudo (it isn't a elive here).

Than tell us: What are you doing to start, and what exact is blabla saying in the 'wine-blabla' dialog?


But you explain it very well.
Thank you for that clarification. :1up:

Although I did mean to understand the issue @Gunnar_Mossberg has, is about the game not starting on the installed system although it starts fine using Elive in live mode.

1 Like

Yeah, I do understand the cunfusion, too. But I don't understand the reason.
So I asked myself 'what would I do, to clear things up?' ... And this is what I wrote down.

At this moment I see two ways of get a solution:

  1. See what @Gunnar_Mossberg did and reproduce the steps, than understand the issue
  2. See what @Gunnar_Mossberg did and have a lot of experience and knowlege to understand the issue

I'm not 100% sure, but during the installation are so much questions about 'what do you want to have installed?', that maybe thre are preinstalled packages in Live, that are missing on this system, because of some answers.

We could use a hammer here, or try to understand.

** backup on live system
dpkg --get-selections > ~/Package.list
** restore on installed system
sudo dpkg --set-selections < ~/Package.list

I really doubt the installed system will still working after that.
But we could use the dpkg --get-selections > ~/Package.list from both systems and scroll though a diff ... maybe later.

And maybe all this is unessecary, if he only clicks in the filebrowser at a files and a magic handler (mime?) is doing -ehm-magic to find the matching app for the extension and is working.
At the moment I've don't see the steps, how to reproduce this behavior at my local mashine.

Thanks for replying! But now urbanterror runs, no problems. I downloaded the latest version, clicked on the program file for linux and nothing happened! Started from terminal and found why. Its about q3config. I made a file q3config.cfg and put just "seta com_hunkmegs "512"" (its about allocating memory) and tried to start from terminal. Now I had a message from where I understood that urbanterror tried to start in higher resolution than my Elive installation. Altered the system to 1280x1024, success, UrT started! Could alter to 1369x768 in Urt. Then back to alter system resresolution and all was fine!

1 Like

hum, do you still having this issue? sounds like a serious thing to know what happen, if