VNCServer Installation

Hi Everyone,

I'm trying to install a VNCServer to Elive.
However when I start the service the log complains about the following:
xrdb: can't open file .Xresources
Any idea where it should be pointing? Has anyone installed a VNCServer on Elive before?

1 Like

I don't have vnc installed so guessing a bit here.

"xrdb" shouldn't be pointing anywhere unless you want to change some default settings by using .Xresources which clearly isn't found in $HOME.

If you want to know what your current settings are, use:
"xrdb -query -all"

Not sure where that xrdb load command is in your setup but I suspect you used this blog post:

That uses/expects Xfce Desktop.
So either try

  • removing or commenting out the xrdb line in your ~/.vnc/startup (you might not need it)


  • create the wanted file and fill it with the "xrdb -query -all" output (or any changes you specifically want)

Good luck and do tell us how you go. :smiley_cat:

1 Like

There's different VNC services available, ones works better than others, maybe elive should include a remote desktop app by default :thinking: but again, there's different ways to access a desktop remotely, with different goods and bads

Elive 1.0 (IIRC) included an own manager for that, making everything more easy

btw the .Xresources file should not be an issue, thats not a OS requeriment, but you can create it yourself just in case its really needed for that application, as:

touch ~/.Xresources

If i'm not mistaken i used rdesktop and it looked easy to use, fast and light. Maybe it good be a good option. Thought, it is in need of a new mantainer :confused:
While for the server side xrdp worked great too

talking about a user-side perspective, what will be needed is a way that directly works remotely, and this is not quite possible without opening ports (and there goes the user's nightmare, including ip changes), a good option instead will be to connect to remote machines in your local network, but for that my always working-perfectly solution is to use ssh, which runs remote gui apps in my local machine, example:

~ ❯❯❯ ssh -Y zeus.local thunar

SSH is perfect, with the only downside (if you can call it that) that you cannot take over an existing session.
On the other hand, I've seen Win machines in production environments where the operator was busy chasing his cursor half the time 'cause some dev was maintaining/repairing the machine at that same moment. :madness:

Maybe it's an idea to do something/variation of your remote access script ? :thinking:
I made a personal one using my homeserver (and reverse ssh) to access my smaller ship's Siemens S7 setup over a GSM (USB modem) connection when needed....for emergencies or software updates. :w00t:

yes you can :slight_smile: have you tried ssh between elive machines? :wink: sessions are kept and running! but you need to not exit from the session, instead disconnect the tmux session with "ctrl + a" then press "d" (or just close the window terminal with the ssh)

I use a lot of opened sessions with tmux between machines, also the elive server, and I also use tmux locally when I need to run processes that takes hours (just in case desktop crash, which is not the case, or being able to restart the graphical server or exiting the session)

Yes, I know .... I use "screen" for that. :happybounce:
Very handy on a mobile connection with limited data plan.

I was referring to taking over the GUI desktop, mouse and all. :smiley_cat:
Witth "ssh" it's always an additional user next to the first one, if at all....... not like eg. teamviewer where you get to look at what the other is doing.