Wayfire is compiz for wayland (with links)

I have found a site that allows compiz to work with wayland. The site project is called Wayfire.

Check out all the wayfire demos on youtube:-

Old demo

new demo v0.5.0

And they just released v0.6.0 on 8th of November 2020.

The wayfire site has howtoos for plugins

IIRC, the reason that compiz doesn't work on later E versions is because in E17, the compositor was an optional module, but sometime after that, the compositor became mandatory - part of the core - and so Compiz won't work without many changes because there'd be TWO compositors. If that's what you're trying to ask. Correct me if I'm wrong anyone.


1 Like

I think you can use Wayfire with E24+. Soon i will download Wayfire.and run it with
64 bit beta of Elive, and try things out

1 Like

Do let us know how that turns out. It would be amazing to have compiz integration in E2*.

ok. i've installed the latest beta version of elive, and upgraded also.

The left mouse button does not work. Something to do with the upgrade after installation.

I'll wait for the next upgrade. Hopfully that will fix the mouse button issue.

I don't know if we can use Wayfire but it sounds promising :slight_smile:

You* can try it and play with that, the Enlightenment of Elive beta versions includes wayland support, to use it you should simply run enlightenment_start from the console (ctrl + alt + F1, out of the graphical system), probably suggested to stop lightdm before to run it too (sudo service lightdm stop). You will notice that you are running in Wayland mode instead of graphical system because of some small differences, probably window borders too

Also, could be good to talk / ask about that in the #edevelop IRC chat channel :slight_smile:

We may have these visual effects back for Elive in the newer versions! :happy_dance:

1 Like

Seems, there is no Xmas in Spain?

meson and probably ninja needs to be updated. Meson-0.56.0




indent preformatted text by 4 spaces
~/wlroots-master ❯❯❯ meson biuld
The Meson build system
Version: 0.55.0
Source dir: /home/david/wlroots-master
Build dir: /home/david/wlroots-master/biuld
Build type: native build
Project name: wlroots
Project version: 0.12.0
C compiler for the host machine: ccache cc (gcc 8.3.0 "cc (Debian 8.3.0-6) 8.3.0")
C linker for the host machine: cc ld.bfd 2.31.1
Host machine cpu family: x86_64
Host machine cpu: x86_64
Compiler for C supports arguments -Wundef: YES
Compiler for C supports arguments -Wlogical-op: YES
Compiler for C supports arguments -Wmissing-include-dirs: YES
Compiler for C supports arguments -Wold-style-definition: YES
Compiler for C supports arguments -Wpointer-arith: YES
Compiler for C supports arguments -Winit-self: YES
Compiler for C supports arguments -Wstrict-prototypes: YES
Compiler for C supports arguments -Wimplicit-fallthrough=2: YES
Compiler for C supports arguments -Wendif-labels: YES
Compiler for C supports arguments -Wstrict-aliasing=2: YES
Compiler for C supports arguments -Woverflow: YES
Compiler for C supports arguments -Wmissing-prototypes: YES
Compiler for C supports arguments -Wno-missing-braces -Wmissing-braces: YES
Compiler for C supports arguments -Wno-missing-field-initializers -Wmissing-field-initializers: YES
Compiler for C supports arguments -Wno-unused-parameter -Wunused-parameter: YES
Compiler for C supports arguments -fmacro-prefix-map=/prefix/to/hide=: YES
Found pkg-config: /usr/bin/pkg-config (0.29)
Dependency wayland-server found: NO found 1.16.0 but need: '>=1.18'
Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency wayland-server found: NO

meson.build:98:0: ERROR: Invalid version of dependency, need 'wayland-server' ['>=1.18'] found '1.16.0'.

A full log can be found at /home/david/wlroots-master/biuld/meson-logs/meson-log.txt
~/wlroots-master ❯❯❯
indent preformatted text by 4 spaces

Not sure what to do with this issue?

As a first it looks you're missing "cmake" and prolly other (Debian) build tools. You need to get:

api build-essential autoconf automake autotools-dev dh-make debhelper devscripts fakeroot xutils lintian pbuilder
And mesonbuild has some clarifications:

It's a bit tricky to install LFS stuff on a Debian system as you will miss out on some dependencies.
It might be better to get the latest versions either as a .deb package (which will prolly fail to install, lacking dependencies) or from the meson git page.

There are ways of creating an own .deb from a git repo containing source code BTW.

After installing cmake , wlroot still errors on wayland-server version.

I tried to upgrade the wayland-server but cannot uninstall the preinstalled wayland-sever without taking out a lot of software packages at the same time via synaptic.

could you please show me how to create *.deb so I can try to upgrade via apt-get upgrade?

EDIT:- I could downgrade wlroot
EDIT2:- I found wlroot-0.10. That installed fine.

Edit3:- i might have to install the earler packages, but i find that you need the latest wayland-server. i'll play around and see what i can install

After downgradeing, I think that we need a wayland server update.

At the moment we have wayland-server 1.16.0

We need wayland-server-1.18.0. That is if you want to make it all happen.

Be carefull not to make so many changes that you lose oversight. :face_with_head_bandage:

For building packages for a different architecture, I used "cowbuilder" but that was with existing .debs that were available as source packages.

I suspect, disclaimer: I don't have any personal experience there, that "git-packagebuilder" is what would bring along the needed tools:

git-buildpackage/stable,stable 0.9.14 all
Suite to help with Debian packages in Git repositories
This package contains the following tools:

  • gbp buildpackage: build a package out of a git repository, check for local
    modifications and tag appropriately
  • gbp import-orig: import a new upstream version into the git repository
  • gbp export-orig: export an upstream tarball from the git repository
  • gbp import-{dsc,dscs}: import existing Debian source packages into a git
  • gbp dch: generate Debian changelog entries from Git commit messages
  • gbp {pull,clone}: clone and pull from remote repos
  • gbp pq: manage debian/patches easily
  • gbp create-remote-repo: create remote repositories
  • gbp push: push content to remote repositories
  • gbp tag: tag a Debian package in git
  • gbp pristine-tar: create pristine-tar commits

I just remembered using the following "checkinstall" trick too, which is a lot shorter:

  • Clone the git repo with "git clone"
  • cd into the directory and mak a "build" directory (mkdir build) ,cd into it and run
  • cmake .. -DCMAKE_INSTALL_PREFIX=/usr/bin
    make -j4
    sudo checkinstall

You'll need to install "checkinstall" first :nod:

so the question is....

when will we see a update of wayland-server?

We need wayland-server-0.18.0.

this will allow me to install wayfire-0.6.0 or 0.5.0

I doubt it will be upgraded before we upgrade the system to Bullseye which, alas wont be very soon, the way things are going now.

Wayland Server 1.18.0 is available on Debian Bullseye.
Can it filter down in back ports for buster?

You could just try installing debian bullseye, install enlightenment, and then install wayland server 1.18.

We're planning on moving to bullseye anyway, so the test would be more accurate.

I tried Wayfire on Garuda linux (Arch based) but it very unstable as it is now. Wayfire is a complete rewrite of Compiz and it doesn't have all functionalities for the moment. It's definitely not ready for anything other than Beta testing. My laptop isn't recent and may be a little old for that (HP Pavillion G6: AMD A6-3400M APU/Radeon HD Graphic card).

If you want try something else based on wayland. I found that Sway desktop (An I3 on Wayland) was very light and quite stable. But its a totally different desktop experience. I kept it as a backup desktop and since it is light, I use it when I want to run VMs on KVM.