3.7.10 alpha release

Again, another build, with again, much improvements :slight_smile:


  • kernel updated to 5.2.19
  • reiser4 dropped (you should save somewhere a copy of 3.7.9 if you still need to use reiser4 in the future)
  • nvidia drivers updated to last version
  • virtualbox updated to last version
  • includes all debian buster updates
  • cairo-dock conf improvements:
    • added logout launcher
    • added hotkeys launcher
  • SecureBoot enabled
    • secureboot is not wanted, but our isos can boot in secure boot now (more people able to boot elive), what will happen next is that a message will show to the user in the first Live boot messages, saying that his computer is limited by secureboot and should disable it, saying which things is not going to work if still uses secureboot
    • maybe i should include something more "noticeable" than just this boot message warning? users may forget it and still continue using secureboot... suggestions? a warning in every desktop start? lol


  • someone can try to boot in SecureBoot mode? my only computer with it seems to not boot on secure mode, the bios says that there's no keys configured (my secureboot is on "Setup Mode"), you can test if is running over secureboot using "mokutil --sb-state | grep Enabled"


If we wont to update a current installation to this version, what are the steps ?

Is an UPGRADE the only way ? That I know how, but always require some manipulations after the upgrade as not everything follow..


Idea: "Do you really want to stay being a gentle slave of mr the slave Gates of hell
and its masters & followers?" :thinking:

I suppose that reiser4 is dropped only cause of the new kernel but not itself?


as I always said, check the changelog to know what changed, if you are happy with only "apug" that's good for you, if you don't need specific new features (like nvidia if you don't use nvidia, same), etc.. for everything else, its explained on How to update your Elive, the correct way

yes, but also because we have seen a few issues with it; "du" reports wrong values, you cannot do specific things like mounting in bind or loop mode (i dont remember), it is slow on external HD's, etc..

I know how to update components.
But you're using the last KERNEL in 3.7.10 (5.2.19) and now I use 4.19.0-5, so what would be the best " elive" way you suggest for someone that need or want to update the last kernel available for BUSTER 10 ?


So: testing live on the eeepc 1015pn (N550, nvidia Ion2, 2Gb), Elive x64: Rocks!
Nvidia (340xx) ok!
This time,
-Fn keys are ok for light screen (still not for sound, tested with audio configurator set to "intel" or "nvidia"=same)
-Battery indications are ok, historic & co included! :slight_smile::ok_hand:
-Always the conky over screen:

-Always too some too much large windows (here the one for saving the screenshot:

The PrtScr key seems not working; I used it via /utilities/Screenshot...

An other thing about Cairo-Dock: I think that it should be configured with visible icons (up to an eventual window), when going completely down the screen with the mouse, cause here, if a window is in this side, it comes needed to move the window or going to an other desk or area to have the access...


Only a few words to say that 3.7.10-32 is running in my HP Mini 2 GB RAM since this morning, without issues, apug runs fine and system is smooth and fast.

I'll install both 32 and 64 bit flavours in Acer 1 GB RAM in a few days as I'll came back home from Belgium


well, there's not really a reason to update the kernel if all your hardware is working correctly (you won't see any difference), but if you want to have it just make a look to the already installed kernel packages and install the equivalent ones for the 5.2 one:

dpl | grep linux | grep 4.19

its not a so easy operation (to select the correct ones) but like i said, you could instead just wait for future releases until you decide to upgrade your system which will replace the old kernel too

1 Like

Will wait for the kernel


Direct live from installed 3.7.10 x64 on the eeepc 1015pn:

First, when booting with usb key, it take a bit of time when dealing with nvidia; time during witch the screen goes to economy mode (black screen), and if leting it as it, things can be much long because it didn't comes back when operations are finished or so... Having to e.g. touch a key (Ctrl to eventualy avoid "stranges") to see what's going on each time screen comes black...

As precedently writed, the nvidia stuff went ok, included nvidia x server settings; But, after installation & booting on the fresh install, all seems ok, having the nvidia splash screen during boot sequence, but this time, no line in preferences for nvidia x server settings (Cairo nor Elive menus)...
Blender didn't lauch & Stellarium graphicaly weird & freezed...

After a reboot, in case, nothing more for nvidia x server settings, but Stellarium ok & Blender idem...

Eeepc 1001px side, live, x64: quite ok, still no sound keys... Seems a problem for web connexion (stays saying "disconnected" even with configured wifi & keyboard key on)...
Blender didin't launch (apears briefly in Conky & nothing); Gimp, Inkscape, Libreoffice for testing starts ok...

Still the diffrence betwin eeepc 1015pn & 1001px on Conky concern...


On the eeepc 1015pn: after the reboot, I see that conky was suddenly more tiny as previous, and setting back the fonts to size=8 fits normaly in the screen as for the 1001px!!! Strange thing here!!! :question::grey_question::interrobang::thinking:


Canceling 3.7.10 install kills existing partition.

Experience running 3.7.10 installer on a Vbox running 3.7.9 (sda5) and 3.0.0 (sda3)

18 Sept ca 10.00 AM.
data submitted using my protonmail address.

  • Started installer -- OK
  • Select Upgrade? -- YES
  • Which partition? -- sda5 (3.7.9) chosen -- OK
  • Add boot/GPT partition? -- YES
  • Chose partition -- sda3 chosen -- OK
  • Format sda3? -- NO
  • Are you sure, needs formatting? -- YES
  • Continue? -- CANCEL and
  • and cancel again.
    The installation stops

Restart the installation at 10.10 AM.

  • Install --YES
  • Upgrade? -- YES
    No question about which apartition to upgrade
  • Install boot/GPT? -- NO
  • CANCEL and cancel again.
  • Installer quits.

Reboot without 3.7.10 iso:

  • No /boot/grub found bla bla bla.

I haven't checked yet what happened exactly but I suspect the partition table got borked despite the installation being canceled.
This should not happen !
There should be no way data gets written to the target before the ultimate OK
Looks like data was written to sda3 both sda3 and sda5 despite the "NO" inputs.
It both partitions contain 3.7.10 data now.


@triantares: I was thinking about self hallucinations (even if I can't be drunk & smoke nothing at all), when I install 3.7.10 on the eeepc 1015pn, was in fact upgrade from 3.7.9, and I have too on the same ssd a test of morphing from CAELinux with 3.7.9 but after upgrading the "pure" Elive partition, I had in grub 2 3.7.10 options..!
Something to clear here!!!
By the way, this upgrade was a very long work in compare with usual install or upgrade of Elive in that machine.......


Could you be more specific here?
It would be normal to have the grub installed by the last installed system, in this case 3.7.10
Do you mean that 3.7.10 was the only boot option?

Well, normally, I should have two Elive 3.7.10 lines (normal one & options one), and two others for Elive 3.7.9 from CAELinux...
I have: "Elive 64bits 3.7.10 (alpha) GNU/Linux" plus its options line, and "Elive alpha 3.7.10 (10) (sur /dev/sda3)" plus ~...

Was thinking too about an eventual option to name (say for "exert mode") usely those lines at install/upgrade or there's no other way than dealing with that later in grub config' (e.g. Elive xxxx & Elive CAE xxx or Whatisok xxx)..?

OK .... you meant two 3.7.10 entries and not Grub2. :innocent:

Not sure (again) what you mean. :thinking:
Renaming can be done in grub afterwards but grub itself probes for other OS'es and will use the names it found ....... even if you renamed partitions in i.e "gparted"

Yep! I didn't explore if it's possible to tweak that at installation...

1 Like

It should be possible (it already does by adding the sda3 in your example) but also an action that could create a mess if left to the user. :nod:

Ugh... If the user, when it's just about giving a name, can't deal with "AAA xxx / BCD yyy"... :laughing::face_with_hand_over_mouth:

1 Like

to know if nvidia is running on the installed system you can try this command:

sudo lsmod | grep "^nvidia"

if there's a result and the third column is a value greater than zero, then it is being using the driver

another option is to run this command with the -t option, like in this example (not very tested):

~ ❯❯❯ sudo nvidia-privative-drivers-install -t
I: No nvidia graphic cards found on this machine
~ ❯❯❯

the conky default configurations (at least in live mode), has been shrinked a bit to fit better on small screens :slight_smile:

@triantares installation reports:

I see in your logs and description, that:

  • tried first to upgrade 3.7.8, but then the installer requested you to add an extra GPT partition which was required (strongly suggested but you should be able to install 90% of the times without problems without using it, so it was simply optional), but since only was sda3 available (your other Elive install) you selected it (you selected it?) and then answered NO when asking to format it. The installer then ignored it and continued, where you inmediately canceled the install. This is why this system has been marked as unusable (incomplete) and didn't showed later as an option to upgrade
  • same thing for your second install, you manually canceled the installation when the data was starting to be installed on the partition

There should be no way data gets written to the target before the ultimate OK

In short, there's nothing wrong with the installer, you followed the steps and after the system was started to install, you canceled, which ended into a broken installed system

But you have a point here, which is a "last step confirmation" :thinking:

something like "Elive is ready to start the installation, proceed?"

Which im not against to add this "extra" confirmation step, but it adds "just another popup more" to the user (which are bad, there's too much), but before that, there's already partitions that has been formated after confirmation...

Do we think that we need this "start install" final step confirmation? (votes please! :slight_smile: )

I disagree.
The installer asked questions about partitioning and offered options yes/no and then on realizing this an unwanted situation, no space or mistake, the first cancel that follows is hit.

None the less, the installer continues writing to the partition. It isn't just "marked" but actual 3.7.10 data is written (and existing deleted) to it....... The installer definitely needs to fully stop and not alter anything at this stage.

It is not just about an extra pop-up, I suggest a loop. It's about avoiding unclear situations during partitioning ........ the stage of adding boot/gpt partition is actually too late or too little info, with dire results.
In an "upgrade" like this situation, it shouldn't even pop-up but follow the existing partition scheme tightly.

IMO, when the user effectively chooses yes he/she should be returned to the partitioning phase i.e the choice "gparted", "gnome partitioner" and be able to alter the partition scheme as a whole ..... or not. This should loop until the user is either fully satisfied or he/she stops and starts searching for more info on what is expected.
So: Noloop, until satisfied OK continue or Cancel and die gracefully.

If I read correctly @Franc , @maxinou and have encountered the same "issue" and there will be more if left this way.

1 Like