3.7.11 alpha release

Changelog:

  • filesystem sorted in isos for a slighty faster access to the files in boot-time (causing smaller distance in the needed random searches in mechanical medias)
  • conky: shrinked size by removing useless entries in the default conf, good for small screens
  • gnome-search-tool is not available anymore, we switched to catfish instead
  • cairo-dock added wifi launcher configurator
  • fixed icons "home" and "trash", visible for example from thunar
  • gtk theme configurations fixed, now you can configure and pick your gtk theme that will be used in e16 among reboots
  • Microphone default volume is assigned to 60% instead of 100% because it can make microphones feel very distorted in some computers (with integrated gain aparently)
  • elive-screenshot won't include the black-line in the borders anymore when using it taking a selection range
  • e16: menus are automatically regenerated in every new desktop, this is needed in order to feature it to be dynamic and have them always updated to the packagtes that we have installed or removed
  • e16: when the menu is regenerated at init of the desktop, an audio clip related subconsiously to the menus is played (only if the user has the sound themes enabled)
  • e16: darkone theme: fonts are a bit bigger
  • e16: boosted startup time! now you won't even see the startup progress bar! (use elive-skel in your installed system to get this update)

BETATESTING NEEDED:

  • someone can try to boot in SecureBoot mode? my only computer with it seems to not boot on secure mode, the bios says that there's no keys configured (my secureboot is on "Setup Mode"), you can test if is running over secureboot using "mokutil --sb-state | grep Enabled"

1 Like

Same problem here. :face_with_thermometer:

what a crappy secureboot system in every sense lol

sounds like "after a computer has been booted with an OS, secureboot locks it to not boot any other OS ever!" lol :woman_facepalming:

& @Thanatermesis, too:
The funny thing is....
do you know who is managing the keys - no ?
Ok then,
google for it, you might be (very) surprised
( and I don't need to type that hated name here )

:madness:

yes i know who :slight_smile:

and that's the reason of why Elive is so against this SecureCrap

not a bad name :thinking: "crap guaranteed" :thinking: :thinking:

can somebody contact microshi-:speak_no_evil: to propose this better slogan? :runningfast:

1 Like

Hi,
This 3.7.11 is 32bit, 64bit or both?

all of them :slight_smile: I have sent you a message with the download links

On the download page at the bottom, the Elive philosophy could use a slight beautification:
Old
“Elive is not made for newbies. Elive is not made for experienced people. Elive is not made for enterprises or personal user. Elive is art. It is simply for the people who appreciate it and want to use it. Feel free to try Elive, because only you decide what you want in this world!”

Where there are 2 mods:
“Elive is not made for newbies. Elive is not made for experienced people. Elive is not made for enterprises or personal user enterprise or personal use. Elive is art. It is simply for the people those who appreciate it and want to use it. Feel free to try Elive because only you decide what you want in this world!”
And removed a comma on the last line before "because". :happy:

If the whole philopsophy recital is up for debate .... then maybe a few other mods could be worked out. Though I wouldn't change the premise: "It's art, like it or leave it !" :wink:

1 Like

VOTED !

Also for my "German Ears" sounds this nice and understandable, so to say...

Thanks!

This was an around 15-years old sentence, it sounded a bit strange for me too :slight_smile: looks better now :happy:

I will try to install it directly. Already have to download link but i obviously wont mention it here. I think my dell xps 13 doesn't support secure boot. The linux version of the laptop is modified to disable secure boot.

Welcome to the forum @Nick_te_Lindert! :slight_smile: I have sent you the download links of in work-in-progress future page :smiley:

There seems to be a problem with automatic partitioning. It seems like the installer can't find the block devices. I use a nvme ssd. I will try to manually partition it.

Manually partitioning worked well. Although gparted started complaining that it couldn't find the block devices after partitioning. I looked for the block devices in /dev/ and they showed up correctly.

Install went correctly although somehow pcsx showed up in the menu while i disabled games on the install. I checked and pcsx doesn't seem to be installed.

I notice that the frequency of my CPU is really high when i dont do anything at all. As a result my battery drains. My battery life is less than half of what it normally is with for example Fedora. The driver for cpu powermanagement in fedora is intel_pstate. Elive uses intel_cstate. The cpu governor on battery is set to performance, which is probably not the best governor when on battery.

Why are there multiple applications which all have the same purpose? I see Rhythmbox, Audacious and Musicbrainz picard(Added to the menu twice). I saw the same thing for some graphical programs.

Just a question of interest: Why do you use a custom installer when calamares can probably be modified to suit your needs? It also saves some time because you don't need to maintain your own installer.

Note: I am autistic and sometimes my communication can be interpreted as harsh or a little too direct. But i ensure you i mean well:)

1 Like

First of all:
Welcome to our community!

2nd:
Thanks for your extended report of your installation just made, it's appreciated.
For Calamares we had discussed about it earlier,
alas in the moment it's not an option for several reasons.

For the applications which seems doubled,
between them is a quite difference in usage,
so the users can take their preference and remove unwanted ones by themselves.

For the prob you encountered with cpu/ draining power - this is not unknown here, but we would like to have more details. Could you please copy & paste the output of
inxi -Frnz
herein.

Last but not least
actually we do prefer a direct communication
and pay the price that it sometimes sounds harsh....
clear so far !? :rofl2:

Kdrgds
:madness:

1 Like

so sounds like the problem is with gparted, gnome-disks is another partitioner tool... the important thing to know is that they shows up correctly on the installer later so that you can select correctly the wanted partitions. The installer has already nvme-ssd implementation (or it should!)

thanks, noted, it will be fixed soon :slight_smile:

thanks for these details, let's try to solve them:

  • first, about the cpu high usage, do you know what is the process that consumes it so high? run "sudo htop" in a terminal and with F6 you can sort the processes by cpu usage, your conky widget also can show them (but is not run as root), and there's a gui application too that shows processes details if im not wrong
  • about the intel_cstate VS intel_pstate, do you know what decides which driver to use? normally is the kernel (and udev) who decides that
  • elive uses laptop-mode-tools which has nice configurations for laptops and their power management & configurations, you can make a look to the settings in /etc/laptop-mode/ , there's also a GUI included in the menus to configure them (maybe more options from the /etc files and reloading the daemon), this package should be kept installed on laptops but not on towers (you can verify if you have it). And, it is (should) be already configured to change the power consumption between connected and on-battery mode :thinking:

well, they are not -exactly- the same (but the user can remove them himself, so its good to give them as options), for these ones you said, unfortunately there's not a nice good full-featured audio player, I liked songbird but is a bit bloated and I found it not possible to install on new versions, about the ones you said:

  • audacious is a nice light one, similar to xmms (similar to the old Winamp in windows)
  • rhythmbox is a more standard one for general purpose and bigger music library, I have a ton of music and it would be not possible to manage it from audacious, rhytmnbox has a better organization system by genre's etc...
  • picard (musicbrainz) is not exactly a player, but more like a "tagger" of your songs, let's say you downloaded some music and it lacks a correct artist / songname / genre entries, picard scans the audio fingerprint from an online database and corrects all of them, is one of the best softwares for that i have ever seen!

Same for graphical tools, they are some similar, but for different purposes

because the elive installer is much more featured and adapted to the elive needs :slight_smile: yes it can be a little more ugly and based in popups without "back buttons", but as said, its the needed one for elive

your comunication is really good and welcome @Nick_te_Lindert, thanks a lot for the reports :slight_smile: :slight_smile:

first, about the cpu high usage, do you know what is the process that consumes it so high? run "sudo htop" in a terminal and with F6 you can sort the processes by cpu usage, your conky widget also can show them (but is not run as root), and there's a gui application too that shows processes details if im not wrong

I want to clarify this, the CPU usage is acceptable. But it keeps running on 3000 to 4000 mhz when doing nothing. Which obviously results in a loud spinning fan.

Some clarification on the pstate vs cstate part. It seem like the pstate driver for newer generation cpu's isn't available in the kernel.

I will check if laptop-mode-tools is installed.

ah ok, so I assume that we are simply talking abou the cpu governor then, where:

  • tower computers: always in performance mode
  • laptops in AC: always in performance mode
  • laptops in Battery: should turn to powersaving (probably in around 30%, not on the minimum)

So the last one is not very tested in the recent versions :slight_smile: , your laptop doesn't decreases the cpu frequency when on battery? you should be able to play / adjust that from the laptop-mode settings, which by default should work correctly... tell me if there's something that should be fixed on elive by default

update: I have been playing a bit in my Intel-i5 laptop and it doesn't seems to change / control the cpu frequencies at all (I tried multiple packages / daemons / tools), maybe my cpu is not supported to be controlled from userspace? (i should try with a Intel-Atom laptop too)

any ideas @triantares? maybe you played with cpu frequency tools too?

Not really.
My Lenovo Thinkpads and tablets work remarkably well with current Elive including long battery life.

Methinks @Nick_te_Lindert should run a check to see if there are no hidden processes keeping his CPU alive/wake....and keep an eye on the temperature.
As for using intel_pstate or intel_cstate ...... I always assumed it was both i.e and not or.

At least both are there on my laptops.

I changed the cpu governor with cpufreq to powersave and that seems to work correctly.
What i5 cpu do you use? I know there is some difference in used drivers between different generations of intel cpu's. I use a Whiskey Lake which normally uses pstate as default. But it is also support by cstate, although cstate seems to be less efficient for the newer generations. I have removed elive from the hardware because it was overheating constantly. So i have to use a live USB for more tests.