3.7.6 betatesting experiences

Changelog:

  • updated kernel with patches and fixes
  • updated opera version
  • some few improvements in confs, installer, and low-ram management
  • nvidia drivers improvements & fixes, version 390 works too (non-tested)
  • Menus for cairo-dock working back
  • keyboard correctly reconfigured when "logout" from e16 in live mode

Notes: if you installed the previous version, this one won't make you any difference than just running "apug" (except for the menus, so install e17-menus for having it)

1 Like

Ehm, can I "apug" my way from 3.7.4 to 3.7.6 or is that a jump too far? :innocent:

com on homey* - don't be so lazy .... :laugh:

= *homey

The fondest of friends.
Term of endearment towards another to signify closeness.

well, as explained in detail in How to update your Elive, the correct way , you should read the changelogs of the releases to know what has changed and then you can see what things you have "updated" with simple apug or other things

for example from 3.7.5 to 3.7.6 basically you can apug and install e17-menus and you are done, from 3.7.4 i dont remember now :slight_smile:

in short, apug only update packages with improvements but on the case 3.7.5 -> 3.7.6 it will not make your system to install e17-menus which you need, or if there's a default-conf improved you will not have it because confs are not restarted in every upgrade (install)

well, the good thing is that reinstalling is not a "big task" with the upgrade mode of the installer :slight_smile:
Elive had in the past a very nice feature where you just needed to download the .iso and your system boots from that file just like a real usb/cdrom and you can reinstall from that (so you dont need to burn / record any usb/cdrom at all ) :boogie:, could be nice to have that feature back :eyepopping:, by other side, recording a usb is not a big task too (unlike the times where we needed to record DVD's or DVD-RW, which was also not a very reliable media)

Updated from 3.7.5 to 3.7.6 with apug, and reporting an issue I had seen in 3.7.4 & 5 periodically with nm-applet. After hibernation sometimes, networking is not available and I have to start nm-applet manually. Has anyone else had this?

yep, this looks like an issue with the dbus service which seems to lost the connection have, you can verify that by running "thunar" from a terminal and check if you have dbus error messages

Actually I don't know if the cause is e16 itself or the OS itself (you can verify that by trying the same thing with another desktop, like e22 by installing the package "enlightenment"), could be good if you can confirm that :slight_smile:

Nvidia

anybody tested if the version 390 of the nvidia drivers works on this version?

Hi!
At boot, (live) when asking about brightness: brightness not functioning, so check "No"

Note: during boot, there's some "tak tak " on the speekers...

At a moment, got a black screen (economy) during the process... A bit surprising (even on battery)...

forcing ECORE_NO_VSYNC=1
...
unable to run...
console >>>sudo nvidia-privative-drivers-install -a nothing

sudo nvidia-privative-drivers-install -u -f -v
sudo nvidia-privative-drivers-install -a blue I: Install complete
sudo nvidia-privative-drivers-install -d blue I: Nvidia detected
sudo nvidia-privative-drivers-install -c nothing
sudo nvidia-privative-drivers-install -t nothing

startx server error

When lauching sudo nvidia-privative-drivers-install -a from E16, seems run ok, ask if run NVIDIA X server, checking the green check, but find nothing after in menus or system monitor...
if >>>sudo nvidia-privative-drivers-install -c tells: nvidia drivers for your machine is: current

sudo nvidia-privative-drivers-install -t nothing (by the way: what is the mean of >>> red orange yellow & >>> red red red?
For now, my ultimate nvidia test is: going in Blender's perf's/System/Cycles Render Devices None / CUDA / OpenCL... And for both CUDA & OpenCL, says "No compatible GPUs found"...

BUT when trying to install BumbleBee, CUDA, OpenCL stuff via Synaptics, during the install process, it says that the current nvidia driver is "Nouveau" (not "current"), and needs to reboot for it to go BUT, re sudo nvidia-privative-drivers-install -c still says "current"!!! Miss I something???
Blender (2.79 or 2.80): no more CUDA or OpenCL...

Reboot, choosing 390 "graphic system can't launch normaly" >>>startx xinit: server error
Reboot, strait to go E16 again and continuing tries, but have to quit cause batteries HS... :frowning:

Elive E16 Menu no icons/
Audio/ : "Mixx" & ""MusicBrainz Picard"(2)" (first has an icon, not the second)
Elive/ : "Elive installer" & "Sliverlight Netflix installer"
Games/ : 6 lines without icons
Utilities/ : "Unisson"
Video/ : "cin" & "Flowblade Movie Editor"

sudo nvidia-privative-drivers-install -c : no reply, even with -v
sudo nvidia-privative-drivers-install -t : same as -c

Salutations!

:neutral_face:

i cannot do / know much the causes of the nvidia not working without a machine to test

maybe if i connect remotely to a testing computer, like the one of @Rebel450 which needs the version 390 :thinking:

Interesting. Running Thunar from the terminal gave a DBUS error like you said, though Thunar runs OK (didn't record the error, sorry). Installed e22, tried the same, no DBUS error. But logging out of e22, the screen brightness dimmed of its own accord. Now in e16, Thunar from the terminal reports no DBUS error. Hopefully all this means something to you. :confusing:

.... is already standing here in the living room,
waiting for packing:

Don't forget ! you will need a keyboard...

4 Likes

Just upgraded my X1 from 3.7.4 to 3.7.6 and am confronted with a major problem.
See screenshot"

Will boot into rescue or live-mode again to see what's on those lines.
.

Try
sudo -i

and rpl pls

That's the same command -- Don't be silly.

"gksu" does work, though.

Seems that the sudoers group is not permitted?
What happens by
su

rpl pls

(upgraders ... :meditate:

same as "gksu" of course. :nod:
Better question/reply would be to show me your (upgraded 3.7.6) "sudo -i" output so I would know if it's a general upgrade bug or just my machine.:innocent:

No, not "of course" -
system-d usually deny this command
"Methinks" that through the process of updating
something went wrong with locations expected
or with skel / taking over the former permissions granted; remember upgrading is a root process
I guess that @Thanatermesis will already know why / will have a solution.

Nope, I don't do upgrades on alpha/beta
I can't see any sense on it
and so I simply can't tell you about

(just to remind you: Am on bare metal, not vm, ok)

:kissing_heart: rpl pls

Nope not on this Desktop, running 3.7.4 i.e "su" to root works using the user pasword.
A clean install on the same machine does allow for "sudo" as well as for "su" so it's definitely an upgrade issue.
Me I'm not too sure whether I like the "su" option to be available that way. hough it doesn't have a lot of differences with "sudo" except maybe some X11 consequences.

Changing my "/etc/sudoers.d/sudo_nopasswd_generic_" by adding antares at the end and then updating the contents by adding antares as the user too ..... solves the "sudo" problem but not the upgrader bug.

1 Like

yay! :happy:

unfortunately I could not play with it before end of july :pleading_face:

aah! finally some news about the sudoers problems!

notes:

  • to login as root you must use "su" and not "sudo su", or better, "su -"
  • you can also access to the console and login as root from it
  • gksu was deprecated and it doesn't exist anymore, but elive uses now an alternative to it which should work in an equivalent way, as a wrapper tool, check it from /usr/bin/gksu (this means, that it probably rely on a sudo system working correctly)
  • a new install+upgrade will fix your actual system problem (with updated installer)

normally i should need the contents of the file to know the issues of this conf in detail, but i don't need them because is already visible on the screenshot (filename doesn't contains username after the last _ char), so this is fixed now, problem was from the installer

@triantares:

  • can you tell me how many dirs contains your /home dir ?
  • does your /etc/elive-version contains a "first-user: " correct value set ?

you should try it :slight_smile:

your next install, don't do a plain install, just let the installer use the upgrade mode :wink:

small correction: using the root password (which is by default the same), so "su" has no relation with the "sudo" system (and so, the user password is unrelated to it)

good, that should fix it

for the upgrader, you should try "sudo elive-upgrader-root --ping" from your user and it should reply "pong", but:

  • you said it worked, but i receive errors on the server about that
    • or... wait! i don't see them anymore, maybe i was reading pretty old reports and I was thinking the last messages were recent
  • in fact i think (and suggest) that all these problems (your recent one & elive-upgrader one) should be fixed with a simple new install+upgrademode