3.8.5 betatesting

Hello!

Installing from scratch one the eeepc 1015pn, via usb .iso: Didn't see (but wasn't staying in front of the screen) the installation window for user/password & co; Installer says "install ok" >> reboot >> LDM didn't comes, startx by command line gives ...xinit server error... sudo startx = same...

Holle!

...is somehow a very special candidate LOL :rofl2:

but - thanks for report ! :work:

@Franc alright, if the user creation window didn't appear you won't have autologin and so all the other issues... the question is why it didn't come out this window?

It happens everytime you install or it only happened one time? (maybe you closed it accidentally?) can you try again ?

New beta won't install drivers on my Asus g50vt ( 9800) model This is quite an old computer, originally came with Microsoft Vista installed. It IS my favorite machine though, because it takes 2 hard drives.

@eserv
seems, you got the Nvidia GeForce 9800M GS...
.
if you don't come any far you may try with the proprietary driver:
Advise:
First try with Synaptik,
if it doesn't work out:
https://www.geforce.com/drivers/results/135161
.
how to: Chapter 4. Installing the NVIDIA Driver
.
ping @Franc: Any experiences comparable ?
.
ping @Thanatermesis: Issue ?

The 3.8.5 has been updated with correct nvidia drivers, so... :thinking:

looking at the drivers versions, seems like @eserv needs the version 340 of the driver

@eserv so in live mode, you select the version 340 and it doesn't works? or you have tried with a different version?

1 Like

The suggested driver is 340. I tried installing it in live mode but it loaded and failed to work. I tried the other drivers too and they wouldn't install. The computer seems to be fine with the free drivers but curious how different it would be with the correct ones. The 340 drivers do install and work with 3.8.2

When I installed the 340xx drivers from synaptic the computer won't start. it gets to the file clean report then that disappears and an it remains stuck there

Nvidia Notes:
Updated nvidia-installer in the 340.xx legacy driver series to default to installing the driver without the NVIDIA Unified Memory kernel module if this module fails to build at installation time. The 340.xx legacy Unified Memory kernel module is incompatible with recent Linux kernels, and the GPU hardware generations that the 340.xx legacy driver series is intended to support do not support Unified Memory.
Added support for X.Org xserver ABI 24 (xorg-server 1.20).
Improved nvidia-bug-report.sh to check for kern.log which is the default kernel log-file location for many Debian-based Linux distributions.
Fixed a bug which could cause X servers that export a Video Driver ABI earlier than 0.8 to crash when running X11 applications which call XRenderAddTraps().

yes the drivers on that version where different, but we needed to switch to the versions from "debian-buster-backports" instead of "sid" for compatibility reasons, so on 3.8.2 it was a bit newer, for some reason it didn't worked for you the other version (but it worked for me on a machine so the driver itself works, but not with your model)

if you still have 3.8.2 and you boot it, you can see the exact version of the package by running:

❯❯❯ appo nvidia-legacy-340xx-driver
nvidia-legacy-340xx-driver:
  Installed: (none)
  Candidate: 340.108-2~bpo10+1      <----------- this is the version

so on 3.8.2 you should have a probably newer version

now, if you want to install the drivers on your side (which is very probably), i suggest you to follow the howto: Nvidia Privative Drivers installation but it actually doesn't provide a mention of installing the drivers from SID repos or externally from the official page, so if you are going to need to install them tell me so i can update the howto with the needed info for you :slight_smile:

I'm not going to spend any time on it. I really prefer 3.0.6 on this machine anyway so I've reinstalled it. I am experimenting with 3.8.5 on a much newer Asus model g74sx and the Nvidia drivers install correctly on it.

3 Likes