Nvidia Privative Drivers installation

Some people can experience difficulties installing the Nvidia privative drivers, this howto explains in better detail how to reach that.

Introduction

The correct way to install the privative drivers in a Debian system is by using their own provided packages

  • nouveau module should not be loaded
  • have the kernel headers installed to compile the module
  • install the correct packages & versions to use
  • module is compiled and loaded with modprobe
  • maybe you need to add an /etc/X11/xorg.conf* template to make it working
  • you may want to better check official instructions for debian NvidiaGraphicsDrivers - Debian Wiki

Tool provided by Elive:

The tool provided by Elive makes all the process to just follow a few questions and guides the user, installing and doing everything needed for him.

Please report any modification to the tool if needed in order to work easily and automated for everybody

The live mode boots, when an nvidia card is detected it shows a dialog asking to the user if wants to install the privative drivers, eventually is needed to reboot with a different boot option (privative drivers) in order to not load the nouveau driver, which will conflict with the other nvidia driver and it wont work (everything is guided from the nvidia installer)

When the user is proceding with the installation of the drivers, it shows different driver versions to select, every graphic card would need a different version, the installer suggest a recommended one, but if not works you must try with the other versions too.

Next steps of the tool is:

  • install the required packages
  • which compiles the driver module
  • then try to load the module
  • if everything is fine, the Live mode continues and starts the graphical system
  • if fails, it proceed with removing the privative drivers to switch back to the opensource option (nouveau) and continue the boot

If the drivers succeed and eventually the user runs the installing of elive to the hard disk, the same nvidia option is used for the installed system

Auto / guided installation

  • :point_right: Boot in Live mode and just follow the instructions :applause::excited::coding:

Manual installation

Live mode

If you have the option "privative drivers" before to boot, you must select this one in order to not use the nouveau driver to proceed with the use of the privative ones, both drivers cannot be loaded at the same time

Optionally you can press TAB or "e" to edit the boot parameters and append "nox11autologin" to run the tool yourself manually

Elive already Installed on the hard disk

  • Boot the computer select Advanced / Recovery mode
  • Login as root from the provided console
  • Make sure that the module "nouveau" is not loaded, using "lsmod | grep nouveau"
    • if is loaded, you must reboot and press the "e" key in the boot menu to edit the bootloader and add the boot parameter "modprobe.blacklist=nouveau", then press F10 to boot in this mode
  • run the tool 'nvidia-privative-drivers-install'
  • if the driver was correctly installed and loaded, try to run the graphical system with "startx" or "service lightdm start"
  • update your initrd with "update-initramfs -k all -c"
  • reboot

2nd option:

Do not run the Elive provided tool and try to make it working entirely by yourself, if you are successfull and the provided tool by Elive don't worked, report what it needs to be added to it

Extra

The Elive tool automates all the needed steps process, but it may be not perfect, so maybe trying to install the drivers there's a missing package to install or step to add. You must open a temporal console / terminal if says that it failed in order to check the package / drivers status and try to make it working yourself, then, report to elive the improvements needed to the tool in order to make it working by default and for everybody.

Tips:

  • Update to the last version of the tool before to use it, which may include fixes or improvements:

apui elive-tools


Be free to improve this howto with better instructions

Hello!

Dell M6700 Nvidia M5000M Optimus Elive 3.7.5 live mode
So, using this way:

  • boot in live mode, select "privative drivers", and add the boot parameters "nox11autologin" >(press Tab to add it) (seems ok)
  • when asks for installing nvidia, say "no" >(ok)
  • having connection to internet, run "apui elive-tools" to update the tool >(ok)
  • run "sudo nvidia-privative-drivers-install -l" (check the other options with -h if needed)
  • try to install the driver, specially other versions than "current", improved options has been added too >(seems going, no brightness with the keys so "no" (but tryed too letting "yes"), no red links, no green ones, only white ones, running too fast at the end just before the blue-violet screen...)
    Success or not? "seems"?
  • if success, try to run the graphical system with "startx"

( doesn't run, complain with, on continued line: >-ile at "/home/eliveuser/.local/share/xorg/Xorg.0.log" for additional information.(EE) (EE) Server terminated with error (1). Closing log file.he The X.Org Foundation support at http://wiki.x.org for help. (EE) Please also check the log f->
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
~>>>

Each time: sudo nvidia-privative-drivers-install -u -f "~reboot now~" "no" to test other ways...
Tries with current, legacy390xx, even legacy340xx...
Ctrl+Alt+F1....12...2 not better...

sudo nvidia-privative-drivers-install -d
I: Nvidia card detected (blue tetters)
sudo nvidia-privative-drivers-install -t no return
sudo nvidia-privative-drivers-install -c no return
sudo nvidia-privative-drivers-install -a no reaction
sudo nvidia-privative-drivers-install -l -f -v no more result
sudo nvidia-privative-drivers-install -m current -f -v (-v seems inefficient) no more result
sudo nvidia-privative-drivers-install -m legacy-390xx -f -v idem...

Salutations! :sweat:

1 Like

Acer Aspire 5750 g
Intel core i5 @ 2,5Ghz
6 GB RAM
Nvidia GeForce 610m 1GB ; Optimus

boot in live mode, preselect "privative drivers"
done

and add the boot parameters "nox11autologin" (press Tab to add it)
done

when asks for installing nvidia, say "no"
done (was not so easy the point for saying 'no' here, btw...)

having connection to internet, run "apui elive-tools" to update the tool
done

run "sudo nvidia-privative-drivers-install -l"
done

(check the other options with -h if needed)
HOW?

try to install the driver, specially other versions than "current", improved options has been added too
done,
dialog box came up with saying:
wrong driver - is not capable to your hardware found
= "OK" =
erasing the installed driver

no success yet.

if success, try to run the graphical system with "startx"
nope

Actually I am successful with installing the driver
but
on the already installed to disk system;
it's even not comfortable to get it done;
will report a bit later

~ ❯❯❯ sudo nvidia-privative-drivers-install -h
Usage: nvidia-privative-drivers-install [options]
  -a: auto install
  -d: detect only (return true or false if we have nvidia or not)
  -l: live mode (don't pre-download packages, pre-ask if want to install, more interactive)
  -f: force install (if no nvidia cards are found)
  -q: quiet mode
  -h: help usage
  -c: check only (tell which version of the drivers we need)
  -t: test driver only (if the driver is correctly installed and working)
  -m: model (version of drivers) to use
      - like:  current, legacy-304xx, legacy-173xx, legacy-96xx
  -u: uninstall drivers
  -v: verbose mode

I could not be able to test nvidia 390 until end of next month

Unbelievable, but I got it running .... (at least a bit :wink:

Acer Aspire 5750 g
Intel core i5 @ 2,5Ghz
6 GB RAM
Nvidia GeForce 610m 1GB ; Optimus

OK, here we go now:

**Part 2: Resume - inside the fresh installed DE

apu

apug

apt-get install linux-headers-$(uname -r|sed 's,[^-]-[^-]-,,') nvidia-legacy-390xx-driver

reboot

apt-get install lshw

sudo lshw -c video | grep configuration

sudo apt install nvidia-settings-legacy-390xx

Half way done;
if I run "nvidia-xconfig" - it fails and can not boot anymore.

NOTE:
The soundserver is not working anymore after install nvidia-settings-legacy-390xx...

Bumble Bee gots installed too, but seem not to work yet.

@Thanatermesis : Ideas?

Hello!

Nice: a step!

1 Like

the elive tool doesn't use this, but it creates an xorg template which seems to be required

mmh, did you tried from the updated tool ?

LOL
trust me, I tried everything available - :typing:
now I need to reach out for external sources/repos - :mwahaha:
but doesn't make sense as we are in Elive testing here ....

:omfg: :nod:

well, the official installers by nvidia is another option but:

  • is not so clean / best option to install them
  • we want to have it working with the provided tool by elive (so that it will work for everybody :slight_smile: )

I ask that because I found your reports of other things but not mentioned about the updated tool instructions (boot in live, update the tool, run the tool)

in any case, 3.7.6 includes the changes I did for the nvidia provided tool which -maybe- (i dont have the hardware to test it) works with the version 390

Hello!

Dell M6700 Nvidia Elive 3.7.6 installed, via 3Gb option (no privative drivers).

Just find something perhaps usefull?


Here it is? Two last lines of the description: "Furthermore using the nvidia-installer to install a new version of the drivers is prevented as long as this package is installed."

One more: !

Plenty of conflicts.......

..... mhm-m :nod:

= :face_vomiting:

NO, at first you will need 'nvidia-detect',
then - continue as per my description on top of this topic - but
of course - you will have/need another driver then, I guess (?)

Hi!

I got a new test machine for it: eeepc 1015pn: Atom N550, Nvidia Ion2 512Mo GRAM, Optimus & CUDA (for now with 1Gb RAM & no hdd)...
Starts & runs well (3.7.8, 64bits, E16, live), using nvidia legacy 340xx... (but can't figure out to see datas about the graphic ram).
A thing at start, after the nvidia driver choice, a black screen, apparently all suspending, things coming back when touching -seems any- key (usually Ctrl)...

Salutations!

1 Like

I have found a bug on the tool which has been fixed, you can try:

  1. plug your LAN cable
  2. boot in "console mode", with the boot option added (press TAB) of "modprobe.blacklist=nouveau"
  3. say "no" when asks for installing the drivers
  4. when console is available, run "apui elive-tools"
  5. run "sudo nvidia-privative-drivers-install -l" and install now the driver
  6. run "startx /usr/bin/e16" or similar to start the graphical system with drivers running

for the installed system that wont work, but you can reinstall them later in the installed system with similar steps (updating the tool and installing them manually)

next build should include the drivers correctly working (tested with 390-xx which didn't worked before, not tested with "current")

1 Like

So far two annoyance issues
en_SV is not in the extended list of locales ;-/
when ejecting a USB storage the message "Unfinished writes" (or some such) remains on screen, presumably forever, long after the kernel is done releasing the device.

1 Like

Considered. :rofl:(remember?)
Seriously, will forward to the head of devs.
(Again...)
Thanks for report :typing:

@Thanatermesis please:
Swedish / English language/locales issue;
and dbus (?) is not responding to ejected USB drive (or what, we had this bug earlier, what was it again?):

yes same bug, not possible to solve it I pressume, since looks like to work as a simple notification message, which is not the optimal, the issue is that thunar is using this system to show the message

About the language, @Hammer459 I see that there's a special option added called "Other", have you tried it to see if works? (maybe I should put it on the first of the list)

Hi!

On the eeepc 1015pn, now with 2Gb RAM: starting (3.7.8 x64 live) with the 1 to 6 points, a bit long to wait but it goes to the Nvidia splash screen & e16 launch...
Little things as usual (stopping sounds....);
One point (for long) about the system monitor in the menu: why two ones (a "gnome" + "gnomeless")?
How to fit Conky prefs (on this little screen, a part goes down the limit & I didn't figure out to resize it)?
System comes quickly about freeze and hot (full vent)...
Is there a way to monitor the graphic RAM (didn't in Conky (or need extended one), nor in System Monitor)?
I presume the 512Mo video ram should help? CUDA idem?

Salutations.

1 Like