3.8.9 betatest


It's not the first time (at least since 3.8.8): after installation and fist boot, Elive doesn't want to stop/reboot/hibernate... invoking some other user or thread, session... Having to force stop with hard button (even a sudo halt is not that efficient)... After this hard stop, it wents ok...
Still not that for cuda or opencl (have to retry a full install with nouveau and ad opencl (in this case off course without privatives & cuda), to see if it goes anywhere)...


I see the same behaviour sometimes on my thinkpads.
Messages about waiting for running jobs to end, which are related to laptop-mode tools or indeed hibernation/suspend..

Sometimes I let the thing sit and take it's time but mostly I hit the "off" button.

So there's actually 2 things:

  • processes that stills running (you should wait, it can take around 5 minutes to finish shutdown)
  • computer blocked

in the second case I experienced this behaviour in an intel machine, apparently with the new 5.4 kernel, im betatesting it with the default 4.19 kernel which is much more stable to see if it happens with it too (aparently not)

About the first-boot issue, yes this is an issue but i don't know what causes it, apparently seems like the first boot requires some final setup configurations to make these features working (user without privileges aparently?)

you mean for shutdowns/reboots? there should be not running jobs from laptop-mode or hibernation/suspend :thinking: :thinking:

In general it is very hard to see what is keeping the machine from shutting down. In the sense that there is no message as to what those jobs actually are. And there is no way to access anything on the machine any more.
I have the impression these "slow downs" happen after suspend/hibernate actions that didn't work as they should.

hum, i have the inverse experience here, so my suspend / hibernate always work, but instead, a shutdown sometimes is stuck because there's a process that still working

note that sometimes, elive-upgrader (which means "apt tasks") can be the cause, so this is a background process that may still working, just like other backgrounds processes that i personally have on my computers

I tried this 3.8.9 version this week, only using a USB key and it worked very well on my Acer Aspire 3 new laptop.

Strangely, I could not get 3.8.8 to boot correctly, even from a DVD. It was stopping in the middle of the loading or was doing strange things, not using the correct graphics drivers, etc...

From 3.8.8

Thanks a lot for reporting this @gtech , I have received some reports about this issue but I didn't seen anybody having it in order to know what is the cause / fix it

So, the strange thing is that 3.8.8 doesn't works but 3.8.9 works, this is strange because it should use the same drivers and kernel and everything...

So let's try to know what causes the issue:

  • boot 3.8.8 in the same way from dvd, reproduce the issue and say "y" when asking to start a console shell (like in the photo says), then from it, run the commands "sudo dmesg" and "grep EE /var/log/Xorg.0.log" and "grep EE /home/eliveuser/.local/share/xorg/Xorg.0.log" in order to see if we can have some useful information about the issue
    • check also if you have error messages and specifically about squashfs
  • try to record this same 3.8.8 to an USB, to know if the cause is because you booted from DVD instead of USB, this will tell us if the issue is because of that or because what's included in 3.8.8

Right now, I’m in the process of installing 3.8.9 on a 3rd partition, because it works so well right now that I can now install it as a beta on my laptop :wink:

But I will try 3.8.8 later to try to find the difference as you suggested. I thought it was only me, and didn’t have time to go further. But now that I know I was not alone that had problems...
Btw, at first, I thought it was a problem with the fact that I was using a USB key, but it was not better from a DVD.

More later, I have to finish this installation first.

I tried installing 3.8.8 and from what I noticed it unpacked all the graphics drivers and found none that were good for my card. It took a lot of time but this time I was able to install it, don't know how...

I have a very long text file as a result of what you asked me to do. How can I send it to you?

There are many errors, some with squashfs...

Testing 3.8.9 from the liveDVD, it was getting fun to use... :wink:
The picture is the Live DVD version
So it is now installed it on a 3rd partition without problems.

you can use any pastebin website for long pastes, just make sure that you set the expiration time at least more than a week

hum, so this sounds like the cause then

more exactly, a squashfs error means that there's errors reading your elive media (bad blocks in the USB media, errors in the USB, DVD incorrect reading, etc...), in other words, if the data of elive is not correctly readed (so corrupted), it cannot be loaded correctly, so the graphical system cannot be launch

probably, your 3.8.8 download is broken, can you verify the md5sum of it?

here is on Pastebin


I'll check if I still have 3.8.8 :wink:

In general it is very hard to see what is keeping the machine from shutting down. In the sense that there is no message as to what those jobs actually are. And there is no way to access anything on the machine any more.
I have the impression these "slow downs" happen after suspend/hibernate actions that didn't work as they should.

thanks, this paste is pretty useful, the next version will autodetect these cases and tell the user about re-download elive (download may have been cut) and to record it on a USB as suggestion than DVD

stupid systemd... maybe there's a way to enable "debug" or "verbose" mode on it so that it shows what is waiting for :thinking:

we would need to betatest this with the different ways to hibernate / suspend, for example we can use:

  • pm-suspend
  • hebernate --suspend (similar to the previous one but should be more stable)
  • "systemctl suspend" (we should generically use this one since is systemd based and it is meant to work everything from systemd now)

@triantares check if your suspend / hibernate works better with the systemd commands, also there's a nice article with troubleshooting cases: Power management/Suspend and hibernate - ArchWiki

note that suspend / hibernate always can act differently based on the hardware of the computer and their different drivers


Running E23 on 2 (fairly) identical machines namely Thinkpad X1 Carbon 3rd gen.

One I have running 3.8.8 upgraded through the installer on a flashdrive:
It hibernates/suspends fine (from the menu) and wakes up fine too albeit only through the on/off switch or shutting and opening the lid.
Not too clear where the difference between suspend and hibernate lies as I don't see the machine shutting down or giving different kernel messages on the ssh session I have running, following the /var/log/syslog entries.
It runs 5.4.0 kernel

The other machine is officilally 3.7.16 and has continuously been upgraded through "apug". Running 5.2.0 kernel.

On E23 suspend/hibernate using the menu entry does not give any messages on "/var/log/syslog" but does blank the screen albeit leaving a moveable pointer/cursor visible sugesting USB is still up.

Waking up is difficult and requires using the on/off button (deftly) which with luck switches on the backlight to show the "turn computer off?" widget. Closing/opening the lid gives a short flash of the desktop and goes dark again. :face_with_head_bandage:

All slightly infuriating and maybe a messed system....although that shouldn't be happening. :slightly_frowning_face:
I will proceed to upgrade this machine using a flashdisk with 3.8.9 and see what happens.

alright, lets see if by using newer kernel &/or OS solves then problem, in such case, we should not worry about anything :slight_smile: , except of knowing the differences between suspending using the 2 first tools or the third one (systemd based), in other words, we may probably move to the systemd one soon (featuring it directly into hebernate)

In my case it turned out to be some E23 setting (no idea which).
Deleting the .e/ directory and thus starting from scratch makes everything work well on the second laptop too.
Although "entrance" does not want to start up properly anymore so shifted back to "lightdm", which could also have been part of the problem. :thinking:

I've left both machines with the lid closed and running (aka suspending) over night without connecting the AC adapter and ...

Both machines wake up perfectly fine with hardly any battery loss. :w00t: So that's very, very good and should make my daughter happy if it weren't for the closure of the university due to the virus restrictions. :slightly_frowning_face:

1 Like

I have also realised that my laptop runs hotter now ( processor temps regularly 68 -72 degrees regularly, cooling fan constantly running)and gets worse with firefox browser than before. (Running kernal 5.2.0-0.bpo.2-amd64. Dont want to up date with usb live disk because i would lose my settings and i hate that).

I also realised that my battery charger now remains hot throughout even when the laptop battery is charged 100%. In the past the charger would cool down as the laptop was using live mains power when plugged in. I suspect that now the laptop is continually draining the battery even when plugged in and the charger has to keep topping up the battery hence it is permanently hot. I fear this will shorten the life of both the battery and charger . Is there a way some one can confirm this, suggest a solution etc?

Is it possible to update the kernal alone safely without affecting the other programs?