ASUS EeePC 1015CX blank screen after installation

Hi,
I'm new to Elive Linux, but I have experiences with Linux in the past on different PC.

I have an ASUS Eee PC 1015CX, originally shipped with Ubuntu 12.04, and I want to install Elive on it.

This PC has 2 GB RAM, an ATOM N2600 CPU 1.6 GHz, a 320 GB HDD, Wifi, LAN, 3 USB 2.0 port, bluetooth, 10.1 screen ( 1024x600 ), webcam.

LXLE distro 16.04 was installed and run without problems.

I first run Elive 3.06 i686 from USB stick and, since it was running without problems, I decided to install on HDD.

The installation process run without errors, I enabled Video acceleration end disabled experimental video effects.

At the end of installation, I rebooted the PC.

After the boot, the login screen appears, and then I insert the password.

Then the screen became black, i heard the intro sound, but nothing visible on screen.

Pressing the ON/OFF button, the PC shutdown.

I tried to start in recovery mode, insert the password, and digit the command 'startx'.

The screen appears and I was able to use Elive.

I suppose I have done an error during installation, or selected a wrong option.

What can I do to correct the situation?

Sorry for my bad english, it is not my native language.

pzeta

@pzeta,

First of all a warm welcome to you here in our Elive community!

Actually in the moment we don't have a solution yet,
but probably in August.

Your problem encountered is known,
there is just a workaround for especially this issue and Elive on this model.

If you got an external display ....
you could connect it and you would see that the video output had switched to the external video port (VGA, but for HDMI unknown).

This happens
when you logout
or
you disabled 'auto -login'

This issue is known, as said before,
but not solved yet.
It occurs mainly on Eee PC Seashell series and similar builds.

What you can do
Enable 'auto-login' (on external display, if available)
Avoid to 'logout'....

I know, this is not the golden nugget as solution,
but at least you can deal with your sweetie (PC)...

@Thanatermesis,

we had the same issue before -
the related hardware is also handover to you
as per your service (Asus Eee PC Seashell, nearly same configuration like the issuer above)
(since it has a Ger qwertz layout, you may connect an USB keyboard by your choice)

@pzeta

One more thought to your problem as described:

There is a function key on top of your keyboard,
it looks like 2 little monitors,
you could try with thisone, in my case it failed,
may be, you are more lucky....

First of all, welcome to our community of Elive Linux users :omgomgomg:

This PC seems almost a clone of my HP Mini 210-4130 sf except in my HP are only 1 GB RAM

I had the same issue because my system doesn't support OpenGL (in E17 of 3.0.X versions) try to install again and be sure that you unmark the case asking you for OpenGL

Curiously, in alpha versions 3.7.X that actually use E16 instead of E17 I can use OpenGL in this slow laptop without issues, but in Elive 3.0 with E17 I can't.

As your HW seems to be equal than mine, try to reinstall again unmarking OpenGL (or disable it in your installed system)

Thank you to all for your replies.
Before my post in the forum, i search for a similar problem, without success.
I reinstalled Elive with automatic login, and now the system run without problems.
And is very nice and fast even if the Eee PC in from 2012.
I'm writing right now from Elive lnux on the PC.
Thank you again to all.

pzeta

2 Likes

Fine, thanks for report!

@Thanatermesis,
we should follow up this Eee PC phenomena when you are back and ready ...

not really, is better to not spend much time on the stable release in order to improve the new alpha/beta versions, unless we know specifically what happens to these cases, i don't know why the screen becomes black but it works when auto-login (good to know that @pzeta solved it!), but is probably related to specific drivers (since happens only to him) on which we cannot do much about that

I "solved" it, btw
It happens to that model, not only to him.
I had same issue before.
It's tiring to repeat many things because you don't take time to read through.
Makes forum work obsolete with the time.

BTW, I suspect that those ASUS EeePC are almost clones to HP Mini like mine (and @Rebel450 ones).

In my case the issue as I said before was that OpenGL is NOT SUPPORTED in E17 from 3.0 stable releases.

Strangely is pretty well supported in E16 from 3.7 alpha releases....

The biggest issue in my opinion @Thanatermesis to work in should be a dialog box that opens 15-30 seconds after selected the accel options to confirm that OpenGL works and if not, make the system return to normal VGA modes in an automatic way, likes Windows does. Actually in this system (my HP Mini, but I suspect the similar issue on those EeePCs) the main problem is that when screen become black the only way for a non experimented user is to force shutdown and install Elive again (that maybe push some people to look for another distro) several times until understand that he mustn't mark OpenGL acceleration (I had several times this issue in my first contact of 3.0.3 and I finally choose the safest live mode, with graphics problems).

So, is possible to make a confirmation window that returns to classic VGA if user doesn't click on "OK" to confirm that accels runs well after some seconds?

Not for 3.0 stable (maybe) but for next future releases....

..... the video output had switched to the VGA port indeed.
Then XRandR does not recognize the graphics unit correctly and switches to a default resolution.
Imo (avoiding 'methinks' here) it is a driver issue
already founded on the Debian level;
@Thanatermesis can test personally soon :hugs:

Hi!

On mine (Eeepc 1001px: 64bits 2Gb ram), I normally set OpenGL and it goes right... With 3.7.7/32 or 3.6.7/64...
Sometimes I unset it, with -no difference- in my way of using it... (When set, unable to run Blender (or old one) because hardware OpenGL limitation... Too light machine for that, but I test in case it can at least show a project without thinking about working on it...)

Salutations!

1 Like

@maxinou
@Franc

The 'blank' (black) screen appears

  • when you try to login at the LDM greeter, right ??

(Name - Password ; ok)

If you read well, I never had ~ ..! :see_no_evil::wink:

Ok, then I go back to all your postings first....
:rofl::shocked:

@Franc
AND
@maxinou

Can you copy & paste the output of

inxi -Fxrz

from your specific machines herein, please?

Thanx :coding:

Device-1: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics
vendor: ASUSTeK Eee PC 1015PX driver: i915 v: kernel bus ID: 00:02.0
Display: tty server: X.Org 1.20.4 driver: i915 resolution: 1024x600~60Hz
OpenGL: renderer: Mesa DRI Intel Pineview M v: 1.4 Mesa 18.3.6

Here you are!

BTW: seeing it sees the 1001px as 1015px.....

In my own case as I set auto login on the issue was at first start while E17 was auto configuring itself, I was able to listen Elive's intro song but screen was black, as I didn't know anything in Exx DE if I switched into another session with Ctrl+Alt+Fx I wasn't able to look for which file I should investigate, so the simplest way was to install again (several times until I understood where the issue was) as previous step to big hammer. Fortunately after some attempts big hammer wasn't needed :smile:

Here you have from 3.7.7-32 where I have not this issue and normally OpenGL is running.

System:
Host: Elive-HP-3-7-4-32 Kernel: 4.19.0-5-686 i686 bits: 32 compiler: gcc
v: 8.3.0 Desktop: N/A Distro: Elive testing 3.7.7 (alpha)
base: Debian buster/sid
Machine:
Type: Laptop System: Hewlett-Packard product: HP Mini 210-4000
v: 0797200000204600000300100 serial:
Mobo: Hewlett-Packard model: 338D v: 37.19 serial:
UEFI [Legacy]: Hewlett-Packard v: F.08 date: 02/21/2013
Battery:
ID-1: BAT0 charge: 30.1 Wh condition: 30.4/30.4 Wh (100%)
model: Hewlett-Packard Primary status: Charging
CPU:
Topology: Dual Core model: Intel Atom N2600 bits: 32 type: MT MCP
arch: Saltwell rev: 1 L2 cache: 512 KiB
flags: nx pae sse sse2 sse3 ssse3 bogomips: 12800
Speed: 1564 MHz min/max: 600/1600 MHz Core speeds (MHz): 1: 1454 2: 1532
3: 1443 4: 1530
Graphics:
Device-1: Intel Atom Processor D2xxx/N2xxx Integrated Graphics
vendor: Hewlett-Packard driver: gma500 v: N/A bus ID: 00:02.0
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
resolution: 1024x600~60Hz
OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.6
direct render: Yes
Audio:
Device-1: Intel NM10/ICH7 Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k4.19.0-5-686
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 01:00.0
IF: eno1 state: down mac:
Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter
vendor: Hewlett-Packard driver: ath9k v: kernel port: 3000 bus ID: 02:00.0
IF: wlo1 state: up mac:
Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 4-2:18
Drives:
Local Storage: total: 298.09 GiB used: 176.88 GiB (59.3%)
ID-1: /dev/sda vendor: Western Digital model: WD3200BPVT-60JJ5T0
size: 298.09 GiB
Partition:
ID-1: / size: 29.40 GiB used: 8.26 GiB (28.1%) fs: ext4 dev: /dev/sda6
ID-2: swap-1 size: 5.00 GiB used: 393.5 MiB (7.7%) fs: swap dev: /dev/sda2
Sensors:
Missing: Required tool sensors not installed. Check --recommends
Repos:
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/aaa-elive.list
1: deb http://repo.buster.elive.elivecd.org/ buster main elive efl games ports fixes drivers multimedia non-free
Active apt repos in: /etc/apt/sources.list.d/debian.list
1: deb http://deb.debian.org/debian buster main contrib non-free
2: deb http://deb.debian.org/debian buster-backports main contrib non-free
No active apt repos in: /etc/apt/sources.list.d/ggg-marillat.list
Info:
Processes: 177 Uptime: 6h 24m Memory: 991.4 MiB used: 571.8 MiB (57.7%)
Init: systemd runlevel: 5 Compilers: gcc: 8.3.0 Shell: zsh v: 5.7.1
inxi: 3.0.32

Tomorrow I'll start my 3.0.6 partition in the same machine and copy you the result in 3.0 releases where I must disable OpenGL in E17 to avoid this issue to see if there are some differences

Thanks a lot, appreciated

1 Like

@Franc,
Thanx for this,
But the complete output like @maxinou handover
would be more helpful, please ?

so its a hardware / drivers problems, i cannot do much for the stable version which is not going to be updated

we can try to detect it which is not a 100% reliable test,

but elive has something similar already included, as you can see in the "hardware acceleration" in e17 is pre-selected in some computers and not in others, so the user can always overwrite the default option. There's no need for a "fallback" thing since there's no way to know if worked correctly or not, only the user knows, on such case, the user only needs to reboot the live system and try the other option

Which is exactly what wasn't a proper solution.
I think @maxinou has a good solution there:

If: the user doesn't click "OK" within a certain period ....then: fall back to the previous configuration.

No need to detect, let the user do that.