Broadcom BC4313 wireless finicky behaviour

Have also seen several issues with the Wireless hardware driver BCM4313 on linux wonder whether that is something you have encountered. Issues with connectivity like mine, slow speeds even when connected. Meanwhile i install latest kernel as you suggested

I don't have any Broadcom built-ins but I might have a USB somewhere but probably a different chipset version.
IIRC almost all versions require firmware blobs from the non-free repositories. :face_with_head_bandage:
Check what's installed with "apse broadcom |grep 43" and see if the firmware-installer is there.

I think it is present
Here is the output:

b43-fwcutter/stable,now 1:019-4 amd64 [installed]
utility for extracting Broadcom 43xx firmware
firmware-b43-installer/stable,stable,now 1:019-4 all [installed]
firmware installer for the b43 driver
firmware-b43legacy-installer/stable,stable,now 1:019-4 all [installed]
firmware installer for the b43legacy driver

In that case you can check what modules/drivers the kernel is running "lspci -vnn" and find the info.

Then search a bit the net for more pointers. the 4313 is a fairly old device so you shouldn't need me searching for you.
From what I know you'd at the least require "brcmsmac" loaded by the kernel.
As it's a shared device (with bluetooth) you could try disabling bluetooth (rfkill) for it and see if it gets less finicky.

I sat down and researched all the information i could find on these broadcom drivers as you advised and came to the conclusion that NetworkManager is probably the best tool to un this program seeing as its as old as the BCM4313 , So I uninstalled all the other networkmanagers and reinstalled NM. Only that i have lost the nm-applet (gui) connector on the Ibar. So far so good will wait to see how the system fares.
Thanks for taking all the time to walk me through :bowing_man:

Actually NM (like connman) is just a bunch of connectivity scripts and wont do anything useful if there's no proper driver administering your hardware.
You don't need to uninstall or reinstall anything as you can just disable/enable either NM or connman as a service at will, as I've tried to explain here.

You're barking up the wrong tree, it's kernel hardware modules/drivers with non-free firmware you need .... a level more basic than the connectivity programs that cannot do anything if the hardware isn't handled properly.

  • I'd like to walk you through but I don't have the hardware nor can I emulate it, so sorry about that.

Looks like you're in for a crash course hardware recognition, proprietary firmware and kernel module loading. :scream:
No easy copy/paste commands, alas. Not that those are really easy ..... they tend to be a trap if you don't understand what they do.

Ah bummer, I realised the issue of closed proprietary drivers and hardware after extensive reading, but didnt recognise the issue of connman and NM just being a bunch of scripts albeit with different properties. Thanks for this clarification. I was unable to answer earlier because of you guessed it; connectivity issues. Will now try those other steps of walking through installing the workaround drivers you suggested early. Cheers, should be a nice learning opportunity for me

1 Like

I followed that like a catechist, only challenge was i did not understand the going on in the background, now i do

1 Like

There are quite a few things to reckon with when looking up and applying these drivers.
First and foremost: Most Q and As are as old as the chipset i.e around 2010 and most will be relevant for the distros of that day and age.
Be wary of Ubuntu forum solutions (be sure to read those threads all the way) and always corroborate them with other sources like stackexcange or distros like arch or gentoo.

I was hoping that the latest kernels might have gotten the drivers properly reverse engineered and built-in by now.
Otherwise I'd check the broadcom site and download their firmware (usually a .sys file) and try to insert that with "b43-fwcutter" -- "man b43-fwcutter" for more info.
You might have to blacklist already available b43x modules to get it to load and the chances of better behaviour are slim ......... but try none the less, another step on the continual Linux learning curve. :madness:

  • "lsmod" is the command to view all the modules your system has loaded and to what use.
  • "inxi -N" will tell you what driver is in use by which network device.

Yes , the most exciting is when you realise that the power lies in the commandline/terminal , the end all be all, its overwhelming. The GUIs are just masquerading superficial frontends nothing really happens there other than collecting instructions and sending them to terminal.

You got that exactly right. :w00t:
On top most GUIs are "simplified" in their options as to not overwhelm the non-savvy user or simply because showing all options would really clutter up a GUI into total chaos.

Just for the fun of it you could run "man mplayer" and then think about how the hell you are going to get all that into a GUI. :wow:

I got dizzy just from scrolling! :dizzy_face:
But it felt much more powerful , i guess you get closer to 1010110 of computing the deeper you venture.

Finaly solved the problem :whew:
I noticed that the signal from the wifi kept gradually diminishing over the days, so that i could not even browse a page when close to wifi router. Suspected a deteriorating piece of equipment. Opened up the laptop but could not see anything amiss other than a frayed wifi antennae ( white wire.) Swapped the white one with the black one and signal completely dissappeared. Decided to replace the wifi module with one from an old laptop , same manufacturer, Lo and behold , the internet bounced back at a tremendous speed . Finally the old wifi module was the problem, probably including its frayed antenna wire.
Typing from my laptop's innards as we speak; too excited to put it all together first! :w00t: :w00t:

1 Like

Hi there

I know this thread has been solved, and it was a hardware issue, but I grappled with broadcom devices a while ago, as a result, I helped on linux forums for a time, sort of specialising in bcm### chipsets. The following continues to work for me on an my old laptop from that time, and I though it might be useful for some people to share it here.

In a terminal

Install the broadcom kernel module

sudo apt-get install -y bcmwl-kernel-source

Remove these modules (the ones after -r)

sudo modprobe -r ssb wl brcmfmac brcmsmac bcma

Install the wl module to the kernel

sudo modprobe wl

Best wishes

1 Like

Definitely helpfull, thank you for that.

Which certainly does not guarantee it's the same device. Could be a totally different chipset i.e not a bc4313.
Can you tell us what output "inxi -N" gives now?
and might as well add "lsmod" too. :madness:

You're welcome.

I can't sorry dude. That machine is currently out of commission. Without a working charger to be precise, but it was the bcm43 family :slight_smile:

That was meant for @IamElive, no worry. :smiley14:

haha cool, is is still not working then?

It's definitely working now but it's not clear what it is.
So all in all, it might just be that the original bc4313 was quite alright i.e not broken and has now been replaced by another, better supported chipset.

We'll wait and see.

Exciting...I wait with baited breath :slight_smile:

1 Like