Disabling network-manager for connman

You would uninstall a lot of other stuff that depends on it of which cairo-dock is the most prominent on Elive.
In that sense, it might be an idea to look for another dock to have available for E16. :thinking:

"nmtui" is just a terminal ncurses interface to NM as the name shows, so: No nmtui will not be usable as that will be removed too.

EDIT

Since "network-manager" is a daemon .... you could see if stopping/de-activating network-manager makes any difference in your case. On my machine it only seems to work if network-manager hasn't already kicked in somewhere. :face_with_head_bandage:

You can do that with:
"sudo /etc/init.d/network-manager stop"
or:
"sudo service network-manager stop"

Obviously you can start or see the status of the service in a similar fashion

On my system too terminal indicates that networkmanager has been stopped but i still have internet access and the network manager icon in the shelf persists working.

1 Like

It looks like permanently disabling Network-Manager.service doesn't affect the system either.
Use:
"susdo systemctl disable NetworkManager.service"

If things do go awry you can always enable it again with "enable" in that command. :smiley14:

It does not , until you boot the computor again! and then no more network manager or wifi internet. :cry: I had to renable that service

That's strange I don't have that ... but then I boot straight into E23 on mine.
All in all, connman runs exceptionally well now that network-manager.service is disabled.

AFAIK systemd-networkd.service is the one that raises the network interfaces, although network-manager obviously will not run if it's service is disabled.
So if you're dependant on i.e cairo-dock icons/extensions or nmtui to connect you would need network-manager.service.

The system itself should connect using connman AFAIK.

My problem may be that i have not updated since 3.8.1 , Hate losing my settings and starting afresh from with the factory settings . I guess i just have to byte the bullet sometime

If you have run "apug" as well as enabling "elive-upgrader" (see the info on the "E23 - please expand" post) often, your system will be up to date except (maybe) the kernel which you can upgrade yourself.

On a side note .... Today's upgrade message:
shot-2020-05-11_17-53-33

I wouldn't call that a "small" issue, it's been bugging me for ages. :face_with_head_bandage:

I have been apugging like a missionary, but did not to elive-upgrader
Now got several errors messages like this on elive-uprader
"E: Failed to fetch http://repo.buster.elive.elivecd.org/pool/main/e/elive-daemons/elive-daemons_3.8.12+git2c57bc700-6buster1_all.deb File has unexpected size (117380 != 117384). Mirror sync in progress? [IP: 139.59.157.208 80]
Hashes of expected file: "

But elive-upgrader progresses without stopping skips over these. Now i cannot upgrade any more . apt-get update doesnot help . Any ideas?

Give it time to finish or reboot.

1 Like

Been running E23 with network-manager.service disabled for 5 straight days now on my main laptop and have to state:

  • Connectivity works exceptionally well. No glitches of importance when waking up after suspend or "lid-close" or reboot. :love:

My idea: Bugger network-manager and use "connman" and "connman-gtk" by default, including E16 . :idea:

How do i do that and set connman and conman-gtk to default? Looks like in my case they look for networkmanager and when they dont find it , they throw a hissyfit

Nope, no need to set connman to default .... if network-manager doesn't come up then connman keeps on running.

Connman is the one that always runs and gets taken over by network-manager. You can check on your system if it's running with:
~ ❯❯❯ sudo service --status-all |grep connman

  • resulting in:

[ + ] connman

Where you should see a + sign if it's loaded
If it isn't running (for some strange reason) you can enable it (permanently) with
"sudo systemctl enable connman.service"

  • To see what it's up to, use:
    "systemctl status connman.service"

To check wether network-manager is indeed turned off:
~ ❯❯❯ sudo service --status-all |grep network

Resulting in:

[ - ] network-manager
[ + ] networking
~ ❯❯❯

And of course, have "connman-gtk" installed for a GUI.

Succeeded but still having finicky wifi performance on this particular laptop, while other devices are perfectly okay. Network manager is gone. Is it possible to configure WICD? I have it on the laptop but it doesnot see the wireless card, probably the Chalk it down to probably a hardware problem.

Very probably.
What you can try is to install the latest available kernel and see if that helps.

Small HowTo:

  1. Determine the kernel version you are running with "uname -r"
  2. Find out what kernels are available: :apt-cache search kernel-image" and determine which one you want/need. Stick to the same type of kernel, only bump up the release number ... current is 5.5.0-0.bpo.2
  3. Install it: `"api linux-image-[version_you_chose] linux-headers-[same_version_chosen]"
  4. Wait until the install finishes. There will be a lot going on in your terminal screen, don't be alarmed.
  5. Reboot

If it wont boot the new kernel then boot into the old via "advanced options" in the grub start-up screen.

2 posts were split to a new topic: Broadcom wireless flakey