Elive first impressions (and a few questions)

Let me begin with a short introduction to myself. I am a swedish guy that has worked with computers for many years. As a matter of fact, I wrote my first program in around 1976. I use both Windows and Mac-powered computers daily. I have tried out many variants of Linux over the years, but there has always been some thing that have kept me from using it as my daily driver. Having said that, I dont work as a programmer or hardware designer, I work in the defence sector.

When I was digging in my pile of old junk the other day, I discovered a small laptop, a Acer Aspire One netbook. It had been lying in that pile for several years, so there was no real use for it. I decided to see if I could make it do something useful. It is powered by an Intel Atom CPU and just 1GB of RAM, so I didn’t put my hopes up too high.

After trying various Linux distros that claim to run well on low-powered computers, I found one or two that actually did run well enough to be useful. These were LXLE and Q4OS. But none of them had a very pleasent browsing experience, so I decided to install the operating system it first came with – Windows XP. This was a very frustrating experience, since there was no old media to dig up (the netbook came with XP pre-installed, and there is no CD-ROM drive). I had to find media on various sites on the Internet and when that was done, I had to google for all the drivers needed (and Acer had long ago forgotten about). To my surprise, when everything was installed and I had found a browser that worked with most modern web-pages, the experience was not that bad.

Then I found out about Elive, and since it claimed to work with both 32-bit computers and in under 1GB or RAM, I decided to give it a try. To sum the experience up in one word, it was DIFFERENT. Different can be both a good thing and a bad thing, and in this case, I would say it was mostly a good thing. The desktop felt snappy and launching programs was also snappy. I even liked the Winamp-esque Audatios player in the top left corner. But it was also confusing with all the shortcuts you seem to have to learn (because it was thrown up in your face at login), and all the various pop-ups that kept coming long after you started something. But the important thing was that most things worked.

Then I started to compare the Win XP experience to the Elive experience on the netbook, and my conclusion is that Win XP still is the better operating system for this old netbook. Sure, I am aware of all the downsides of running a non-supported operating system, but with this old piece of hardware – who cares?

But I didn’t stop there. I had an old MacBook (early 2009) laying around to. This was more powerful than the netbook: It has an Core2duo CPU running at 2 GHz and no less than 4GB of RAM, so I decided to download the 64-bit version of Elive and try it out. So this is what I am writing this ”first impressions” on now. In LibreOffice Writer (to be copied to the forum). It works very well. It feels like a completely new computer, one that I could use as a daily driver even, if it wasn’t for the fan noise. I decided to download Google Chrome (because that is what I run on my other computers) and sync it up. It works perfectly, even on the very heavy Youtube site (which the netbook really struggled with).

There are only a few niggles:

  1. The camera doesn’t work. The hardware doesn’t seem to be detected at all (tested with booth Cheese and Zoom). Also, there doesn’t seem to be a screen-saver that activates after a certain time of inactivity. I am sure the latter problem is easy to solve, but what about the camera problem? Also, the trackpad is giving me a bit of a headache, as it is activated when I don’t want it to be activated, like now, when I am writing (a bit of my hands touch it when I write, but this has never been a problem with MacOS). Would I want to go back to MacOS on this laptop? Hell no, Elive is so much faster!

I also did a quick boot of the live USB of Elive on a HP ProBook 6450b, an even younger laptop (just 10 years) :slight_smile: That laptop is powered by an Core i3 CPU and 4GB of RAM. It worked perfectly, but since it already had an install of Linux Mint, I decided to keep that on that laptop.

Looking forward to engage in this community. It seems to be different in a good way!

2 Likes

Well first of all: Welcome to Elive and the forum in particular.

I'll try to catch your "niggles" there where I can.

1.- On the Acer you apparently tried to run Beta 32bit. To get that using a tad less of RAM you could disable "cairo-dock" as it uses quite a bit by itself.

  • The dock can be replaced by lighter apps such as "tint2" or "plank" if you want to.
    I'm working on what and how is best (low CPU/RAM usage as well as pretty, stable and useful) and posted some try-outs but not a Howto yet.
    Once I'm in the clear where and what it has to be I'll be doing that., which isn't too far in the future by the looks of things :happy:

2.- I would definitely advise into running Elive 3.0.3 Stable on that little machine, which would be a fairer comparison and ...... will really get the machine a lot more snappy.

  • Downside is that some apps aren't updated anymore as the 32bit versions don't exist any more.
    Do try it, you'll be surprised. :nod:

3.- As to macbook hardware: I'm not too acquainted but I think our resident Mac-o-phile @Rebel450 will be glad to help out there.

  • A screensaver isn't installed by default (waste of resources where you can simply close the laptop) but you can if you want to, yourself.

  • The trackpad can be adjusted using the config tool in "settings", "Touchpad configurator". The latest synaptic drivers in the kernel are very (maybe too) responsive.

Stay with Elive for a while and get used to it's goodies, you'll have a hard time finding a nicer replacement. :happy_dance:

2 Likes

First of all a warm welcome to our our community!
2nd:
Thanks for your extended introduction,
this is rare, highly appreciated - tack se mycket :grin:

For the MacBook - I personally stay away from calling it old; this is just the Apple's suggestion.
On mine (late2009) runs with triple boot Catalina, SnowLeopard and Linux.
All hardware working on Linux, btw.

If you like (!?)
I would point out how to get there.

For the Acer

  • the same: All working oob and damn fast, even with low ram.
    A hint: Put in both machines a SSD, it ain't that hard and gives a magic experience to the machines...

Kdrgds

3 Likes

Thanks Rebel450! Yes, I would very much like to understand
a) how you got ALL hardware working (as I mentioned, my camera doesn't work), and
b) How I would go about getting a dual or, as in your case, triple-boot. Running Snowleopard would be great!

I forgot to mention that both machines already have SSD in them. I have realized long ago that this is the single most important thing you can do to make old hardware feel like new again.

Thanks a lot triantares! Yes, it was the 32-bit Beta I installed on the Acer. Will try the older version one of these days. I would like to point out however, that it is not lack of RAM that makes the Acer feel sluggish. When running nothing but the standard desktop and a browser such as Chromium, I still have a few hundred MB free space in RAM. So the problem is rather a very sluggish CPU in combination with - what is seems - not optimized graphics. This is especially noticable when viewing videos on Youtube which cannot be viewed at a higher resolution than 480p. The same goes for videos from my own archive: DVD's are OK, but anything higher (720p or 1080p) cannot be done. But with Win XP it can.

I am looking forward to your forthcoming tutorial!

True, there's more to it than that.
Believe me, that Acer will fly using Stable albeit the advice to use a an SSD is extremely sound. It makes an enormous speed difference.

I've got Stable running on an old (2009) Thinkpad X61T and it has no problems running videos in Firefox from the net.....though the screen res of the machine is only 1024x768 it will run movies fullscreen w.o any problems.

.
mhm, no - I suspect here another (typical) issue.

  1. Debian does not support the fan control on certain Mac hardware.
  2. He mentioned, he installed a SSD; sometimes the temp sensor from the former Mac HD is missing therefore - on the other hand he would encounter the same by running Mac OS (nowadays called macOS :ohmygod: )
    So, @hgpuke , can you confirm the loud fan on Mac OS, too - or ?

Otherwise I have to check out what is missing on the Debian install.... :typing:

1 Like

well.... at a glance I got this solution handy only -
but be aware: it is meant for Ubuntu - it should also work on debian (hopefully)
You can give it a try - or at least it makes you understand which step is neccessary...
usually I don't give away untested advises, but this time I had no time for a deeper checkout
this time this is a trial on Elive /Debian:

How2 iSight problem on Intel Mac :

mount existing Mac partition and go to:
(Your mounted OS X Volume)/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport

Then install the firmware extractor and let it do the work for you:
sudo apt-get install isight-firmware-tools

If the path is incorrect, you will NOT ! be prompted for another location.
You must purge the installation and redo before trying again.
sudo apt-get --purge remove isight-firmware-tools
sudo apt-get install isight-firmware-tools

After success, SHUT DOWN and then boot fresh.

Test with cheese;
sudo apt-get install cheese

If not succeed, check:
MactelSupportTeam/AppleiSight - Community Help Wiki
__

1 Like

BTW, just for the fun of it.

You can get a linux/unix like experience with XP (it'll still be a security disaster as OS though, if you go on the web) ---- install "litestep" as a window-manager, it has virtual desktops and all. :smiley14:

Find it on github:

1 Like

Hmm, that WOULD have been a way forward if I had a MacOS partition left om the SSD. But I don't. I had troubles with getting MacOS to work well, so I decided to scrap it altogether. However, if you have information that would allow me to find a working copy of, say, Snowleopard, I would most certainly try to install it (again) and try the solution you suggest.

I cannot confirm that the fan noise is different in MacOS compared to Elive, simply for the reason that I no longer have MacOS installed. Sorry. However, what I can say is that Elive seem to manage the fan, and that it knows what the CPU temperature is. So the fan noise is not constant, it varies depending on the CPU temperature (which in turn varies with the CPU load).

So in all likelihood, everything works as it should and the problem is either that I am doing too "heavy" things - like playing a Youtube video - or - more likely - the fan is not doing it's job too well because of dust accumulated inside the casing. Would you have a link to a document or video that explains how to take it apart? I have only been able to locate videos of other Macbook models. Mine is a white early 2009 Macbook (without "Pro") model.

Interesting, but not soo good on a netbook where screen estate is in short supply. I have only 600 pixels on the "y-axis" on this little bugger...

Which is exactly why it is good. ...... you in fact virtually resize it to 4 times that.
It was the main reason I installed it on my PC riunning Win98 at the time :nod:

Can you please handover the exact model number,
eg. if it runs on Linux the program inxi is doing the job, it looks like this:

for getting the desired info - fire up a terminal and type:
inxi -Frnz

Then copy & paste just the first line ("Machine:") herein.
With this we can assist you more specific.... :nod:

Note:
If inxi is not installed yet, just
sudo apt install inxi
and you are done
:madness:

If so, you should install MPlayer (hint: make sure to install the mplayer GUI frontend, too)
I would advise to use synaptic for the installation.
It will play even YouTube directly. I had amazing experience on very low equiped PC's with this.

My friend..... :happy: =
You are close to lose this machine, if so....
Move yourself, open the back, get a brush & vacuumcleaner and remove the damn dust!
:mwahaha:

If you are a bit keen with hardware,
it is also a very good idea to remove the 12year old :spider: :spider_web: thermal compount
and put new thermal compount on top of the processor and GPU.
These both resides under the same shared cooling pipe.
If you dunno how2 do it, find a gamer kid or such - they will know very well how to do it -
this procedure will give you a "like new computer" - and it will last long.
Otherwise you can say bye, bye to your GPU soon....
...
Just as a personal comment of mine :rofl2:
​
​

check your pm for:
"Elive Moderator response"

1 Like

11 posts were split to a new topic: Modern browser on 3.0.6, because the thread has gotten clogged.

The printer is probably newer than the drivers on Stable.
That doesn't have to be a problem in the sense that you can look for the needed (32bit) PPD file and use that.
OTOH I personally would use another machine as printer-server and print over the local network (LAN) as there isn't any real logic in using a portable device as a consistent server.

Methinks, @hgpuke has a lot of input for today :madness:

... am kinda curious, when he will reply to some of my numerous suggestions then :omfg: :runningfast: :typing: :work: :whew:

I think this thread needs to be split in two(or more) ..... considering we are:

  • working out issues on 2 extremely different pieces of hardware.

  • Working out issues on Stable or on Beta.

Try to be very clear what is being answered! :idea:

@TheTechRobo will you sanitize this thread, please?
This is worse than an IRC chat page. :shocked:

Cleaned up the thread a little - moved 11 posts to a new thread, deleted a few useless posts, and merged two replies by the same author into one. :nod: :happy:

not perfect yet. I'm still not the best at this kind of thing. :thinking:

2 Likes

A post was merged into an existing topic: Modern browser on 3.0.6