Modern browser on 3.0.6

So I installed the Stable version instead. Mixed results. Overall, the experience is better. Apps start more quickly and the interface looks more "polished", albeit a bit "dull".
I was able to connect over SMB to my NAS and play movies in DVD resolution as well as 720p, using mplayer. 1080p was a bit too much, but it almost worked too.

I have two new problems though, that I didn't have with the beta version:

  1. I can't find a single browser that works for all sites that I normally visit. My preferred news-site is "omni.se" and either the content is displayed wierdly with big pictures and no "fold-out" functionality on the articles (Chrome does this), or is not displayed at all (Firefox). I also downloaded a bunch of other browsers, but none of the worked with this site, and Chromium didn't work at all! With regards to playing youtube videos, I could get Chrome to do this but only at low res.

  2. My networked printer (a HP Color Laserjet M477 mfp) doen't seem to have drivers for it in this distribution. It does in the beta version and in all other distributions I have tried. Don't know how to solve this problem.

I can live without having the ability to print, but the netbook is almost useless without a fully functional browser. Is there a way to install a more modern version of a browser than those included in the default repo?

Thanks!

I've been nagging Thana to update the ISO to add the latest Palemoon...but to no avail. :face_with_head_bandage:

3 Likes

Thanks, will try that immediately!

So I managed to find an old 32-bit compatible version (28.1.3 I believe) and got it to run! Yeah! However, navigating to "omni.se", I first see the page, then it is replaced by "Oops, this page does not exist", exactly the same way as Firefox displays it. No luck!

Hmm... probably it doesn't like the browser. Strange. :thinking:

Try installing this palemoon addon:
https://addons.palemoon.org/addon/sasuga/

then change the user-agent for that site to

Mozilla/5.0 (X11; Linux i686; rv:86.0) Gecko/20100101 Firefox/86.0

which is the user-agent for the latest Firefox (which Stable does not have). See if that works.

I'll prolly compile the latest palemoon for 32-bit if I can find the time. They say on that download page that while its not supported by them, some packagers do it, so it must be possible. :nod:

1 Like

This actually insinuates a network/connection problem i.e nothing to do with a rendering of said page.

Really? They apparently see it for a second and then it disappears, so I was thinking a redirect if an outdated browser, but the page was moved or something.

My (old) post has 28.10.0 so maybe you didn't search well enough. :thinking:

continue reminding @Thanatermesis then, it's not unimportant :mwahaha:

3 Likes

I am sorry to say that changing the user-agent didn't work either. This is really strange, since when running a different live Linux operating system "EmmabuntĂĽ", I managed to get the page displayed correctly using the Firefox-ESR browser.

That is most likely an internet issue. Sure that it's all set up?

Try this in a terminal:

wget --tries=1 https://omni.se

fine, you try :madness: Stable 3.0.6 sereously needs web browser updates