Entrance: development issues (boot process, login privileges, etc)

First boot....and the subsequent ones, which were first boots too as it never finished.
Reverting to lightdm solved it ..... haven't retried yet with "entrance"

Edit

Restarted with "entrance" and no problem whatsoever so DANG !! not reproduceable.
Hopefully a fluke and won't happen again.

Just reproduced the situation.
I set /etc/entrance/entrance.conf to the user me (antares), with choice Enlightenment and enable autologin.
Everything works fine and boots into E23, albeit that now the shutdown, reboot suspend, hibernate options are greyed out. :thinking: only "lock" and "logout" are allowed.

If I then disable autologin (as it was before boolean = 0) the hung situation on boot occurs. There are no errors on F12 though.
I need to change the .conf file again I suspect but it beats me why this happens as the settings are back to what they were before. :slightly_frowning_face:

Editing the conf file and setting the bool for "ask password" to 0 allows a normal startup through entrance.

I notice on that "plymouthd" keeps running on the machine that boots with "entrance" taking up to 60% CPU.
When using "entrance", "plymouth" doesn't quit and lies at the base of the boot problem.
I've seen the same 2 messages again in F12 at that moment.
"A start job is running for Hold until boot process finishes up (32s,/no limit)"
Switching to lightdm makes it go away on boot as it should.

Ok so there's 2 things to consider:

  • entrance is not considered "stable" so we should make sure that the issue happens with lightdm to say that there's an issue with Elive
  • in any case sounds like we have a bug in entrance, which is good to know / report it in order to have it fixed :slight_smile:

So i have checked the code and in the systemd service file for entrance, which is a copy of the lightdm one for compatibility reasons, i found this piece of code:

# replaces plymouth-quit since lightdm quits plymouth on its own
Conflicts=plymouth-quit.service
After=plymouth-quit.service 

looking at the comment, seems like lightdm makes sure to stop plymouth, but should be not the case of entrance so sounds like this code is not needed and may confict (in other words, it may be the cause of the issue)

if you want to test:

apr --purge entrance
apir entrance

it is not tested, but maybe you don't have the issue with plymouth anymore (or maybe we have another now :slight_smile: )

Without removing/purging but simply not using entrance through "dpkg-reconfigure entrance" and enabling lightdm solves the issue i.e lightdm turning off plymouth is not overridden.

The trouble is that this plymouth issue does not happen all the time. Looks like it only happens when entrance has a new/changed configuration.
Which would also be the case on a first boot if it was already there after an upgrade. :thinking:

So: For now it's not advisable to keep "entrance" installed when upgrading i.e use it on first boot until the issue is fixed.

Topic

It seems to be going off topic but is actually a side step. I ran into this whilst looking into the "unable to reboot/shutdown" issue i.e setting Entrance to auto-login and back again.

So: IMO that shutdown/reboot issue is related to "autologin" being used in the live/install/upgrade session.

since systemd is a paralel booting system, processes may run in different times, which makes the issue happens "sometimes", that's why the .service file needs to include the correct specific "dependencies" (before run X, after to run X, better if run X before, etc...). On this case, I removed an entry about plymouth which should conflict (unless we add the code in entrance to close plymouth, which is not hard), but as said, I have not tested it and probably more improvements needs to be made on the .service file of entrance

it is not (unless you specifically added it in the packages-list-to-maintain)

UPDATE: Entrance issues are not directly related (ATM) with the Elive system itself, but is good to keep it updated and fixed for the future, so i moved the last posts of the other thread to this one specifically for entrance issues :slight_smile:

1 Like

They only grey-out if one sets the autologin from the /etc/entrance/entrance.conf file. :thinking:

Using the autologin from the"preferences" -- "user configurater" panel allows access to all the system options including shutdown/reboot in E23. :shocked:

maybe this should be reported to entrance?

@triantares confirmed, autologin in entrance makes those "system" options to be grayed out, this means that the autologin is starting in a different mode than the normal mode and it lacks some privileges / options, for compatibility they shoudl use the same login system... can you report the issue with autologin to entrance ?

Will do, although this opens the question whether it's an entrance or enlightenment issue. :thinking:
...... there's more. like setting a "user" as remembered not working and not getting .edj files to work as a personalized background (.png works but OTH .jpg does not)

well, every bug should be reported :slight_smile:

it should be an entrance issue and not E issue, because it works on a way but not in another (of entrance), and lightdm works by default too

1 Like

I had another issue in entrance tests: it makes entrance to always restart (like every minute or a similar time), same if you are logged in E, the cause is entrance receiving signal 15 (something like a restart requested, aparently by systemd), im trying to improve the .service file and seems like it is not restarting now... updated packages are now available :slight_smile:

works correctly with and without plymouth now

You mean this restarting is responsible for the not quiting of plymouth ?

mmh not sure, something from systemd in any case seems to have been the cause, in any case, new version should include many improvements from the .service file:

apr --purge entrance
apir entrance

Doing that and booting into entrance shows me the same personalized entrance wallpaper I had set earlier --- so much for purge. :thinking:
Then editing /etc/entrance/entrance.conf to autologin into E23 (Enlightenment) and ...

OK, this works....also with autologin enabled albeit that suspend/hibernate/reboot/power Off in E23 are still greyed out.
Logging out and opting to reboot (bottom left) from entrance takes a very, very long time.
Then rebooting with autologin choice to E16, boots into E16 but then opting for reboot only logs me out to entrance....which this time has lost the wallpaper.

Logging into E16 again from there leaves me with a disappeared cairo-dock. :thinking:
Logging out and opting for reboot again takes a veryy, very long time with only an indication of LSB scripts in and eventually reboots into E16.

Cairo-dock is there again and opting for restart there gives an error message that "logind" requires interactive authentification.

note that this can cause more than one problems, since user is starting with different (less) privileges

reported: Autologin starts with missing privileges · Issue #45 · Obsidian-StudiosInc/entrance · GitHub

this sounds like an issue with the .service file or something similar, or just with your system, more specifically: with "staying processes". Make sure to close / kill all your apt tasks, background tools, etc... before to perform reboots. It worked fast the reboot for me in my tests on vbox with it

then, this sounds like the same privileges issue (and you mention autologin), since reboot is not allowed but e16 exits from itself, you are back to entrance

uh, that's confusing lol, I assume you can run it when you run it from a terminal. Does all the other startup applications are run?

logind? mmh... did you played with sysvinit or similar? :thinking: im wondering if you have some extra packages installed that may conflict in your normal boot procedure :thinking:

No, it's my upgraded (to 3.8.9 a few days ago) machine.
Going back to lightdm solves all problems.

Actually only doing this because you had issues with first boot and wanted to find a way to reproduce it.
I never use autologin, I think it's stupid on a laptop.