How to install the latest Firefox version


#1

A few tips on how to install Firefox Quantum on Elive, especially for those of us interested in Amazon Prime Video. This is a detailed, step-by-step instruction aimed at every level of linux experience (also those of us not familiarized with using terminal) :

(!!!terminal commands are put between ‘’)

Let’s start:

  1. go to Directory Listing: /pub/firefox/releases/62.0/linux-i686/ and pick up your language version of Firefox.
  2. enter the language directory of your choice , right click on firefox-62.0.tar.bz2 file and copy the link
  3. open your terminal (Ctrl-Alt-t)
  4. enter cd /opt/
  5. enter sudo wget and paste (Ctrl-Shift-v or Shift-Ins) the link (remember about the space after wget )
  6. enter sudo tar xf firefox-62.0.tar.bz2
  7. enter sudo nano /usr/share/applications/firefox-quantum.desktop and paste the text below
[Desktop Entry]
Version=1.0
Name=Firefox Quantum
Comment=Browse the World Wide Web
GenericName=Web Browser
Keywords=Internet;WWW;Browser;Web;Explorer
Type=Application
Exec=/opt/firefox/firefox %u
Terminal=false
X-MultipleArgs=false
Icon=firefox

Actions=ProfileManager;new-window;new-private-window;
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;$
  1. Ctrl-Shift-o to save
  2. Ctrl-Shift-x to exit

It’s almost ready…

The Firefox Quantum is available. You can check in your apps if it’s so.
Now, there are some issues with sound. I solved the problem by installing ‘pulseaudio’

  1. enter sudo apt-get install pulseaudio

There is one more thing to do.

  1. open audacious player and in File/Preferences/OutputSettings Change ALSA to PulseAudio

  2. now, try to open a music file in Audacoius to check wether it works.

  3. open Firefox Quantum go to Netflix / Amazon Prime Video … Et voilà

!!!Of course remember about enabling DRM!!!

If there are any issues, just let me know.


Long live Elive !!


#2

Tks for the info !!
I it install but I am googling on how to enable DRM
Usually something pop asking if we want to enable DRM, but this little bar at the top, didn’t pop, so I have to figure out how to enable drm

  1. the audio configurator @Thanatermesis created does’t allow me to listen on my USB headset if I am using Pulse Audio, I suppose the audio configurator was created for Alsa, I need to figure out how to may my audio play on my USB headset if I am using pulse audio

#3

Forget about my audio problem, it is now using my headset… I am not sure how I fixed it but it is ok


#4

OK I recommended to people to INSTALL IT AT THEIR OWN RISK
I expererienced this

  • if I close FireFox Quantum, the process is still there, I need to quill it
  • I can’t 100% of the time choose my headset or speaker, Pulse Audio messed up a bit y audio config LOL

I will uninstall PulseAudio as I can’t easily use my HeadSet anymore

No worries @buzzy I still appreciate what you did, if you don’t use a headset or it’s working well, and you don’t have the Firefox process that stay there, you can still continue to use it


#5

I uninstalled PulseAudio, now my audio is back to normal. Can’t switch to Headset to speaker the opposite
As for the FireFox quantum not closing properly, it’s not doing it everytime
JF


#6

@buzzy

How is it going with Firefox 32 bits Quantum version 62, is it still working well for you ? I’ll continue testing when I have a minute… If we can make it work well, without any glitches, it could become the main browser Eliver’s user would use…


#7

This might be useful (works with me) linux - How to configure PulseAudio to input/output via ALSA? - Super User

After editing settings for pulseaudio, you can skip steps 11-12 of the instrucion.

BTW I haven’t experienced any problems with FirefoxQ not closing properly.


#8

Do you happen to have a Bluetooth headset? IF yes, can you switch to the headset and back to your speakers?
I will try anyway

Tks a lot


#9

@kneekoo
@buzzy was able to make firebox Quantum version 62.x working … THis is good news


#10

Found this latest Firefox ESR 60 (32bit): Mozilla Firefox Web Browser — Download Firefox Extended Support Release in your language — Mozilla
Netflix and Amazon Prime work, but you still must install pulseaudio.

As far as bluetooth headset is concerned, found this:

and this
https://wiki.archlinux.org/index.php/Bluetooth_headset
Might be helpfull.


#11

@buzzy
Is this version better/more stable for us than FireFox Quantum V62 you posted earlier in this thread ?
I was able to install it but as for the audio :
The following worked for you ?


#12

in the past your command to install pulseaudio worked but now :
Type ‘help’ to know the ton of Elive features available…
~ ❯❯❯ sudo apt-get install pulseaudio
[sudo] password for jfbourdeau:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package pulseaudio is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘pulseaudio’ has no installation candidate


#13

@Thanatermesis

Could you help me on this one ?
It that we have 2 version of FireFox ver 60 and 62 in this thread

  • they are more recents
  • as for me, my Amazon Prime Video could work on it LOL
  • need pulse audio

Can you tell me the easy way / good way to install it and how to make pulse audio work ?

Unless there is something I don’t know under the hood, one of those 2 version could be the default for Elive, no ?

Firefox Quantum 32 bits ver 62
https://ftp.mozilla.org/pub/firefox/releases/62.0/linux-i686/

and

Firefox ESR ver 60


#14

betatest everything on live mode

install pulseaudio on it, like: api pulseaudio

note: pulseaudio can break your entire elive system lol (just play with it to test it all)

you can also try the command “apulse firefox” which runs firefox pipelined to alsa (default elive audio system) making it compatible as it was working over pulseaudio

you can do it for your own purpose but not for elive default… I mean, not for 3.0, this is major changes that can break too much things, is better to use the actual browsers, compatible and stable, next development will simply have by default updated browsers

for you, just try the last version and see if works (do all your tests in live mode which should work too)


#15

looks like your lists are broken, update them:

apu

note: api is the same as “apt-get install”

try this to understand them:

alias | grep apt

finally, the most used command that i always say is “apui”, this includes updating the packages before to run sudo apt-get install, so having used apui pulseaudio would have directly worked


#16

❯❯❯ apulse firefox
zsh: command not found: apulse
The program ‘apulse’ is currently not installed. You can install it by typing:
sudo apt-get install apulse
apulse: command not found

I install it ?


#17

it worked apu fixed it
Apt get-install pulseaudio worked after tks !


#18

yes try it

if works, you don’t need pulseaudio, which will make “less broken” your system


#19

If I installed Pulse audio before your told me that
If I apt-get remove or use synaptic to remove it, will it fix what is may be broken ?


#20

probably this:

~ ❯❯❯ apr pulseaudio
~ ❯❯❯ api pulseaudio-compat-notinstalled