Installing Anbox on Elive - error

Hello guys,

I'm trying to install Anob on Elive, following these page:

I started by these first step:
sudo add-apt-repository ppa:morphis/anbox-support

When I run the command, i get this message:
"command not found"

So trying to solve the problem. I tried:
sudo apt install software-properties-common

and them

sudo apt-get update

But the problem continues.

What else more I need to do?

Welcome to the forum! :applause:

First of all, PPAs (and custom repos in general) are unsupported on Elive. They're typically meant for Ubuntu and have screwed stuff up (mostly for me :rofl2: ) many a time.

Have you tried restarting your terminal after installing the software-properties-common? It shouldn't be necessary but that's the only thing I can think of.

That's correct, that command does not exist on Elive (or Debian) but one can add a repository manually if needed.
Be aware, .....that as already stated ..... these ppa repos are Ubuntu oriented and might not work as expected on Elive.

If you get a 'command not found', start with a look at the sourced OS:
-> ah, the package is named software-properties-common

As Elive is build on a dpkg based system, there is a little chance to get lucky:
-> Debian -- Details of package software-properties-common in bullseye Since Bullseye it is even available at Debian ...

But what base am I using?

lupus@zoe:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 11 (bullseye)
Release:	11
Codename:	bullseye


Even If I (personal) would not use a ppa, if there is any other chance to get the program working, every user should be aware of the power from cat /etc/debian_version and lsb_release -a' as well as the search of filename in (or

I can't find a source right now, but why I am avoiding PPA?

There was a somewhat popular program. Some random guy package it and made it public available via PPA. Soon a lot of people are installing the package from his home computer and he loses a lot of bandwidth.
As he understood the whole mechanic, he was aware a lot of people must trust him and give root access. As shocking as it be, anything performed by dpkg needs root.

He read a little about the ubuntu behavior and how tho change the background image. A little later a lot of people got their background changed. This was a long time before 'Ransomware' was a thing, but the look was similar. There was a black background with a a warning, reading something like 'This change of the Desktop does no harm to your computer. But Think of what I've could have done, just because you inserted my home computer as source of your packet manager and as result give me all permission on your system'.

Be careful with your /etc/apt/sources.list, keep it clean as possible!

1 Like

Well, the feature is implemented in elive if I'm not wrong (you can use it) but the problem is that it needs to have compatible repos (on elive beta 3.8.x must be made for "debian/buster"), otherwise yes, you can screw your system like @TheTechRobo apparently :slight_smile: , so first is needed to know that is a compatible repo

Problem is that this design is not meant to be made to verify this compatibility, is just try & error (then regret lol), in that way, flatpack's and similar systems are more reliable

The story of @LupusE said is true, when you install a package or some software from someone you need to take care of that, you must -trust- from where the source comes / who made it, but we have the same problem with all those packages as flatpack's and similar systems in a smaller or bigger way, in short: only use the official repos :slight_smile: and if you want to install extra software do it from their official site and making sure the software has a good reputation