Installing Elive fails because of startx error at boot

I’m having trouble to boot Elive. Every time it shows the message ‘‘Fatal server error:
no screens found’’ I’ve tried Graphical Problem & failsafe option to resolve the problem but couldn’t. I’ve tried to upload screenshot but this site showing error of maximum upload size then i’ve compressed the image although i couldn’t upload it.

My Graphics property is Intel® HD Graphics 5500

Report Date: 31 July, 2018
Report Time [hh:mm:ss]: 10:19:27 PM
Driver Version: 20.19.15.4835
Operating System: Windows* 10 Pro (10.0.17134)
Default Language: English (United States)
Physical Memory: 8102 MB
Vendor ID: 8086
Device ID: 1616
Device Revision: 09
Video BIOS: 0.0
Current Resolution: 1366 x 768

Processor: Intel® Core™ i5-5200U CPU @ 2.20GHz
Processor Speed: 2195 MHz
Processor Graphics in Use: Intel® HD Graphics 5500
Shader Version: 5.0
OpenGL* Version: 4.4
OpenCL* Version: 2.0

  • Microsoft DirectX* *
    Runtime Version: 12.0
    Hardware-Supported Version: 11.1

  • Devices connected to the Graphics Accelerator *

Active Displays: 1

  • Built-in Display *

Display Type: Digital
DDC2 Protocol: Supported
Gamma: 2.2
Connector Type: Embedded DisplayPort
Device Type: Built-in Display

Maximum Image Size
Horizontal Size: 13.39 inches
Vertical Size: 7.48 inches

Supported Modes
1366 x 768 (60p Hz)
1366 x 768 (48p Hz)

1 Like

Hello,

Unfortunately sounds like your problem is that the machine is more recent than the included drivers (which yeah, they are old), of course I assume you are using a recent beta version

So the failsafe options doesn’t makes it working on this machine at all?

1 Like

I’ve tried many linux distro but everything seems to very common although they have their own repository but they couldn’t bring something unique to the user which can make them different from other. But Elive does it all :heart_eyes:. I really appreciate it’s unique features . I’ve tested Elive 2.9.99 beta in an older laptop it works very well not just very well beyond my imagination :yum:. But when i’ve tried to install it permanently on another laptop it fails which is very frustating :persevere:. Failsafe option goes into blackscreen after splash of Elive boot… Hope the problem will be solved very soon…:slight_smile:

1 Like

@Fantasy_Apple Thank you for your beautiful words :happy_dance:

I would be happy if you create the first testimonial in Testimonials - Planet Elive with your last comment :relaxed::relaxed: :smiley:

Seems like the problem with your other laptop is that it requires a newer graphical driver, but it should be possible to make it working at least using the vesa driver

I have added some improvements in the live system, fallbacking to different graphical drivers, please try it so it will be included for the final version, there’s the simple steps:

  • Boot Elive from live mode on that laptop, selecting the option “Console mode without desktop” having the laptop connected with the LAN cable to have internet
  • When you will reach the access to the shell, update the needed package by running the command: apui deliver
  • Then run the command “startx”, you may need to wait 1-2 minutes while testing different settings, hopefully you could reach the graphical system starting

Please report me the results, if this not works I will check in more detail how to make it working

I’ve tried the command apui deliver but it didn’t work. Also tried dist-upgrade to upgrade the packages to the latest version but the problem remains.:confused: Please have a look at this. Dropbox - 20180812_105530.jpg

Oh wait, I just found that was not so simple, startx will only start the graphical system but what you needed to do is to run the updated tool that runs the graphical system (and includes the needed reconfigurations), this is the list of the exact steps:

  • same as before (boot, have it connected to internet, update deliver)
  • edit with your prefered editor (nano or vim) the script like: sudo nano /usr/lib/deliver/scripts/shell-login/zx-live_config_xinit_elive.sh
  • search for the line (line 78) that contains the word “nox11autologin” and replace the entire line with this code:

if false ; then

  • save and exit, this will allow you to run the script, otherwise it would consider that the graphical system is not needed to run
  • make sure that you are in the first TTY, which is the only one from where the script can work (run “ctrl + alt + F1”)
  • then run the script as: bash /usr/lib/deliver/scripts/shell-login/zx-live_config_xinit_elive.sh

Tip: use TAB to autocomplete the address of the script and ensures the correct typed names

I’ve followed these steps but still didn’t get the GUI. Here is the result…Dropbox - 20180813_005148.jpg :thinking: I’ve a Q in my mind that in the same machine it works well in the VM but when it comes to real hardware it fails why is that?

Thanks! this is very useful log messages

Unfortunately I think that the drivers simply doesn’t detects your screen

Yes the VM works well because all the hardware inside it is “simulated”, and the hardware of this VM (which is the same in all computers) is correctly detected and working by Elive

1 Like