Live -> installation problem with 3.0


#1

Material: laptop Acer Aspire VN7-592 Series - Intel Core i7 - NVIDIA Getforce GTX 960M

Boot mode: Legacy

Elive 3.0 on USB key.

Mode Live and Install
After a few seconds, this screen
1_copy
the problem is: my laptop have only one graphic card…
next screen:
2_copy
I answer «Yes» and go further; then:
3_copy
With the free drivers, the results are the same: no Live session
Then:
5_copy
I choose the 1st time the mosts recents drivers: no Live session, the 2nd, 3rd and so on, all the others choices: same result.
Then:
8_copy
Once more: my laptop have only one graphic card, and nothing in the BIOS (also a nVidia) give the possibility to disable the graphic card.
Then:
10_copy
11_copy
17_copy
18_copy
Anyway… all other choices lead to the same result: no Live session, thus no installation. I have to say that nevertheless there is a graphic result:
21_copy
the mouse (in the white circle) is there when we move it, the white square moves… But it is the only thing which is graphic.

Thanks for your help.

Bernard


#3

your laptop has at least 2 graphics card, one integrated in your i7 and the other one the nvidia dedicated one,

why legacy mode? you have a almost brand new laptop, no reason to use such an older kernel. probably that’s the reason why you’re unable to install the drivers (i may be mistaken): they’re not supported!
try to reboot and avoid using legacy mode!


#4

Boot in UEFI mode is impossible, even deactivating the Boot Secure option in the BIOS (Windows 10 is already installed on the laptop, I would want to replace it by Elive). The only method which allowed to launch the beginning of Elive-Live is with the Legacy mode. I’ve tried (UEFI mode) to start with a Linux-Mint Live CD and that’s work perfectly…


#5

Legacy you mean “old computers” boot option ? this is an old 486 kernel for very old computers, you should not use this kernel for that i7 computer

In fact, it is possible that these drivers doesn’t install in the old 486 kernel

Can you show us the output of this command?

lspci | grep VGA

Nope this is not graphical, is “gpm”, mouse on console :slight_smile:


Well, looks like the drivers installs correctly, but it doesn’t loads / uses it, the cause should be that your laptop is too much recent for the included drivers, so you would sadly need to wait for a future version of Elive to use it in this computer, unless you use a VESA configuration, the boot of Elive should try to use the VESA mode too but it has never been tested fully, you can try to follow a howto on internet of “use vesa xorg.conf” or something similar and, accessing to the console SHELL as it suggests you, adding that configuration to see if you can boot the graphical system (it will lack hardware accelerated features but having a working desktop)


#7

Alright this version of Elive doesn’t supports UEFI, but if you deactivate it correctly in your bios you should be able to boot the normal kernel of Elive

Note: there’s some bios, specially in laptops, that they doesn’t allows you to disable it, or at least the secure boot or other options, this is really bad and if im not wrong it is even ilegal that the manufacturer forces / stricts you to use a specific operating system (windows)

Make a look in the website of Elive (FAQ sections) where shows the exact options that you need in your bios


#8

I mean that I’ve disable the UEFI mode in the BIOS and choose the Legacy Boot… otherwise the CD or the USB key with Elive don’t work

The lspci command is not recognised under Windows 10… but in fact I’ve better search in my system… and have discovered that my laptop have neverteless 2 graphic cards:
-Intel® HD Graphics 530
-NVIDIA GeForce GTX 960M
…sorry for the false info…

Ok… I shall tried these options…

Thanks a lot.

Bernard


#9

Two options in the BIOS: or deactivate the UEFI mode and thus choose the other option: Legacy; I have done that… and the result are to seen above on the pictures;
or disable the «Secure Boot» option (under UEFI mode) and in this case nothing change: impossible to boot with the Elive CD or USB key…

I fully agree with you…


#10

Oh ok, that is correct then :slight_smile:

About the graphical card, sounds like you are using the OPTIMUS mode, this has been not fully tested in Elive (and thus not implemented correctly) due to lacking the specific hardware where to do tests of the correct implementation of it

If you agree, I can try to make it working for you connecting remotely to your computer, this will also help every other user having the same type of cards, making it directly working by default.


#11

I once found a workaround to avoid the annoyance given by the UEFI thing. Try to use something like plop. In the past I used it on a floppy to boot USBs, but I found it useful also for booting and installing Windows 7 despite the UEFI mode was enabled and the USB drive didn’t support it


#12

It sounds promising. I agree. :+1:


#13

Can you explain this «plop»… in the style: «Plop for dummies» :sweat_smile:


#14

https://www.plop.at/en/bootmanager/download.html
Burn it to a cd or a floppy disk (if u have one eheheh) or any bootable device then select the drive you want to boot from within it. it worked for me


#15

@stoppy98 does this tool makes Elive 3.0 being able to boot from Live & Installed modes? If so, I could add this tool in the website so that users with UEFI can use it too :slight_smile:


#16

i need to test it. my main computers are based upon a core2duo t6600 and a pentium e5400, so you can guess i’m not that familiar to uefi eheh i will give it a check. tell you asap.
p.s.
as soon as i find out wherever i put my plop cd
edit:
need some more time


#17

:sweat: not for me… My laptop have a Core i7… maybe is that the problem…


#18

i checked it again. on the same computer it worked, on another one… well i do not find the way to boot from a cd :confused: So i cannot really give a sure answer, especially after this


#19

Is it that you mean that you think your computer is too recent @bameylan ?
Mine (Desktop, HP) is i7, SSD drives and Elive boot without any problems if this is what you mean


#20

Really, I don’t know… I’ve try several times to start a Live session AND with «plop» AND with the CD Live Elive… untill now: nothing… If somebody can explain step after step the way to operate…

Anyway, thanks for your reactions…

Bernard


#21

It is probable that a non-UEFI bios/machine simply cannot boot an UEFI bootable system (os), on such case the CD/DVD could not boot


#22

I was a bit lost with the conversation, but looking back at the post seems like your only problem is with the driver, unfortunately I cannot assist you right now to make it working, Im talking about that part:

But remember me it and I will try to help you the next days, I’m actualy in a place where the internet is ridiculously not enough for anything