LXDE Mint VS Elive

Hi there, this is my first time here, and i am currently using LXDE Mint on my Dell Inspiron 14 laptop.
It only has 2GB of RAM so I think elive will be fit for this machine.

So, today I tried the live version of Elive.
First off, I tried the "for Old computer" live version, and i encountered a problem where it doesn't detect the wifi card, and the screen turning on and off, goes the same to the touchpad (on and off). not sure why, but yeah, i gave up for the "old computer thing".

then, i try the regular live version. my first impression was like, hmm, it got some speed, well thats good. then i tried running some apps, and opening something like files and suchs. everything good until i tried some video, which opened by VLC media player, it got no sound, and the constant changing background made it even worse, increasing the lagness from the screen. then it freeze.

i did hard reset again and gave it a retry. it got sound this time, the F2, F3 sound setting worked, no problem on everything. well, it's good and tempting to switch over my mint, but for now I still want to stick with mint. these are my conclusions:

  1. It is faster for first time starting up the browser on my LXDE Mint rather than Elive. well, I use browser alot rather than apps or games on this old laptop. so this is priority.
  2. It is faster for first time starting up the LibreOffice Writer on Elive rather than Mint.
  3. There is no indication which my sound increasing or decreasing when pressing F2 / F3.
  4. I am not sure if install Elive directly will got more speed rather than live version.
  5. It took me some time and a lot of efforts to set up old canon printers on LXDE Mint, this is another reason I am not changing to Elive yet because I think I have to do the same thing too since Elive is based on Debian.
  6. The file manager is good, compared to LXDE Mint Thunar file manager which has a problem showing image/video thumbnail. (this also took some time to fix/to find the solution)
  7. I am not very sure how good Elive on managing the RAM, but I think installing it will provide me a better experience (or worse) idk. because the desktop is looking very graphical, I am afraid it will disappoint me on some point after installation. For Example, Ubuntu or MINT regular installation is VERY heavy on my machine, that's why it needs LXDE or XFCE environment. something that is No graphical at all. But if Elive can guarantee the Graphical display without sacrificing the Speed, tell me.
  8. Last but not least, so far I have not encrounted any manjor problem YET on Elive (live version). I think elive has a positive future, I can't donate anything but good job on dev on making this OS.

First off, a hearty welcome here on the forum. :wink:

I suspect you're using the stable (32bit) version: 3.0.0 but let me know if I'm wrong.
Anyway..... the installed system will always be faster than the live version so do try and install.
With 2G RAM your machine will have quite some slowdowns using Mint (again depending on the version) but should work fine using Elive .... although one should still be careful as to how much (and what) is opened at the same time.

Elive is very good at managing RAM (read: keeping usage down) so that's a very easy guarantee. :applause:

As to your canon printer: If it's connected (live or installed mode), Elive should see it and automagically try to configure it.....especially if it's an older type. If it doesn't just ask here on the forum. :smiley_cat:

TIP

If you aren't using one already, try to install/use an SSD as harddrive.....that is a real speed-upper.

Welcome to Elive, @Ahiung_Lim.

The 'Dell Inspiron 14' isn't that old. In Fact, it describes a vendor, a class and a size. There are 4 digits following that describes it better.
See: Dell Inspiron laptops - Wikipedia

I'm a huge fan of Thinkpad, and I've used it on a T61, T400, X200s R500 and T470s. These are all different laptops from different times.
Even if the systems with Dual Grapics (ATI Radeon in Power mode and Intel something in Power Saving mode) are great, for me it is much easier without NVIDIA or ATI and I'm disabling the extra power 3D magic graphic for the first test and add them if everything else is working fine.

May you've want to tell us something about your system. Such as graphics. lspci is helpful.

bm@lydia:~$ lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

I've used Elive 3.x on a 32bit Netbook (Samsung NC10) with 2GB RAM. It runs better than anything. And after the installation even faster. But really slow, compared to my X200s with SSD, as @triantares already mentioned. A SSD and max. RAM will give new life to any old system.

1 Like

On an old Thinkpad X61T with 2G ram using Elive 3.0.0
Running fast, sturdy and beautiful, :w00t:

I have "elive_3.0.6_stable_usb.img" file in my download folder, i guess it's not 32bit then.

Well, I'll try it again when i got time then. right now my flash drive is occupied with puppy linux. :smiley:

3.0.6 is 32 bit only. The beta version (3.7.x) also has a 64 bit version

Which will run OK on low spec laptops too, albeit not as pretty as Elive.
The whole point of Elive is to deliver a full (really full) and snazzy desktop experience without slowing down the machine.
Others like Puppy do so by toning down the amount and sort of installed programs or window manager. You can always see by the look&feel that it's 2nd rate.

  • Elive is the only one that allows for running a virtual machine, a full office suite and one of the most complete desktop environments (enlightenment) without bogging down the machine.
  • It's complete, fast and good looking too. :w00t:
    So now you also know why the .img file is so big compared to others. :wink:

See you back soon. :smiley14:

I don't think my laptop spec is on the list. I am not really sure about my laptop, can you please make sure that this is Dell Inspiron 14 5100? because I can't really find anything about it on Google except some ebay site describing about it. it has only 2GB of RAM.

This is my lspci output:

lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 21)

The download link they sent to my email was just that...so, you are saying that there is no compatible/stable one for my laptop which has 64bit?

Yes, stable is compatible. 32 bit will run fine on a multicore (64bit) machine without any issues, utilizing all cores and available RAM.
It's the other way round: 64bit will not run on 32bit machines.

Like I mentioned, there are 64bit beta versions that run 64bit-only but they are a very different experience in comparison to Stable with a very different desktop (E16) and might be a tad slower due to not being fully optimized yet.

A trouble is, that once a hardware feature is available it will be used by most software makers to cover up "mistakes" that slowed down machines before.
If vendors say a machine is too old or even obsolete, they're not saying the machines are broke (which they obviously aren't) but that their software needs heavier hardware to do the lifting for them.

  • I know people running Windows who get told their 4 year old machine is too old to fix and that they should buy a new one. :shocked:

BTW

If you want to tell us what specs your machine have exactly, use this command:
"inxi -Frnz " :smile_cat:

Hmmm, i see, so it's not safe for me to use the 64bit version of elive. Anyway, I'm creating the USB bootable elive again right now because i don't know why i have to re-set everything everytime i booting up the puppy, I was pretty sure i SAVED everything upon shutting down. so....yeah, I gave up on puppy.
Tomorrow I'll try on connecting the Elive to my canon printers, and I'll tell the news about it. :slight_smile:

Please do, especially if there's a problem.
If there are problems we can find what's the cause and eliminate that for other users in the future. :+1:

Oh, it's safe enough only very different and still being worked on. :smile_cat:

Hello and welcome!

As long you run your machine with less than 4GB RAM

the 64 bit is useless then anyway.
You will have the best experience with the 32 bit release as @triantares pointed out before.

And even that has been solved with PAE
ttps://www.geeksforgeeks.org/paging-in-operating-system/

okay, so...I just booted up elive again and plugged in my printer cable, the problem is there is no plug and play thing and idk where to start and what to do. I also couldn't find the "printer settings", the only one i can find is something like desktop, wallpaper, graphics, mouse, wifi, and so on.
I tried to print on Writer, and it only shows "generic printer" which idk what that is also.

I have Canon iP1980 plugged in, it's on, i already make sure that the light indicator is ON also.

it will be very helpful if there is a "search" feature, like on Macbook you can bring it up using Command+Space, or Windows/Mint/Ubuntu pressing the Special button(Win Button). All I can find on Elive is "Search for Files", it can only search for files not settings or other things.

There is a search feature but you are not looking in the right places. :wink:
Don't expect Elive to be like most other OSes and you'll be fine.
Simply "right click" anywhere in your desktop and you'll open the "everything launcher".

For printing, access the aplications menu by clicking somewhere on the desktop and going to "administration" like in the shot below and add your printer.

With the normal cups configuration options:

Oh yes:

Do read the "hotkeys" file to know where to expect what on Elive. :smiling_imp:

haha, sorry, i wasn't expecting that also actually, I was hoping Elive to be more different, and it did haha.

So, I found the printer setting. and I am stuck with a problem, this is maybe almost the same problem I had on Mint and Chromebook upon installation. The Driver of my printer is not listed.

I have a Canon PiXMA iP1980 printer (it is recognized as iP1900 series on the system)


Too bad for my printer, it's driver is not in the list tho....:pensive:
I hope this problem will be fixed in the future...
I'm not sure what to do next if it's listed, but no matter what driver i chosen to install, I couldn't press "Forward" button, I thought it was freezing or something but I can press any other button other than that.

Oh another minor problem I want to mention about, I forgot about it before this. The on screen menu always popped up to the right, it will be a problem when user open the menu from the very far right of the screen.

And lastly, I am not sure this is a bug or enlightenment feature, but I have an extra wide desktop, only about 1 or 2 mm wide tho, whenever my cursor reached to the end of the LEFT or RIGHT screen, it moves a bit to that extra space.

If it gets recognized it generally should find the right driver. If it doesn't it might be worthwhile to check out the Canon site.
https://my.canon/support/PIXMA%20iP1980/model
They've got a .deb for your printer there on offer:
http://gdlp01.c-wss.com/gds/0/0100001590/01/cnijfilter-common_3.00-1_i386.deb
Just install that.

No, .... the menu should shift itself to the left automagically.

That means you're desktop resolution is set to a slightly bigger size than it really is. Try a slightly smaller resolution in the same proportions if you find it disturbing.

So, upon installing it, i got a familiar problem.
as what i remember, the deb file has to be modified and can be only obtained on a specific repository, which i forgot what. The company itself halted the support for old printers such mine. So here is the picture about the error.