LXDE Mint VS Elive

sorry Elive, this round, it just the same as other linux distro.

Also, I tried to install the printer using the PPD file I download from the google search. This is the first time I tried to install using this, I thought it is done, but it still have problem too.
This is done in another new session.

And what happens if you run "sudo apt-get install -f"?

Does it install or do you get other errors?

So it's a driver problem.

Did you try the 1900 driver BTW?
It's offered on the same download page by Canon.

I gather this is all being done in "live" mode.

  • be aware that if you don't enable "persistence", all changes will be lost on next reboot.

Sorry, wrong image uploaded for the PPD install error.

Not yet, I will do it tomorrow.

Yes, but i assume that it is close to regular install, except the speed.

yes, its just for the experiments, nothing is needed to save for.

I did, in terminal I typed it all, and manually typed the location ~/Downloads/cnijfilterblablabla.deb (because when I drag and drop the file into terminal, nothing happened)
alas, it replied couldn't find the file or folder.:face_with_head_bandage:

and what I did before, I couldn't click the "forward" button, no matter what I choose. a bug perhaps?

this indeed looks like a problematic printer with a shitty driver support ..... too bad.

I'll have a look into it given time.

Don't bother with the 1900 driver ..... same problem:
missing libcupsys2.

Download page in the printer settings? or Website?

Sorry for troubling you, as I recall the only working driver for this specific printer can be found at someone called michael cruz repository or something...
something like repo:michael_cruz/cnijfilter_trunk or something like that, i remember the "trunk" word.

after adding this repo, updating the repo and installed it from synaptic package manager.(under linux Mint, but i guess it is the same process for all debian based)

I did get the debs to install using "--ignore-depends=" flag. You could try that and see if it works.

I don't have the printer myself so I cannot test if it prints.
Adding 3rd party repositories usually causes a lot of trouble due to inconsistencies and adding ubuntu ones will certainly pose problems on Elive..... It is not ubuntu based.

yeah, I definitely will tomorrow. because right now im at home already. :smiley:

1 Like

Using "--ignore-depends=" flag does not help, I found out.
It only suppresses the error messages. :slightly_frowning_face:

So I rebuilt both debs changing them to depend on "libcups2" in place of obsolete "libcupsys2".
They install fine here.....so try by installing both and see if your machine gets recognized when you plug it in afterwards.
Both changed .debs are here:

With a bit of luck, they'll work and Elive will have another :+1: over other distros. :smile_cat:

oh, i c...I'll try it now and tell you about it after.

Yes, it does look quite normal here so far

So, I plugged in the printer and open the print settings

Well, at first sigh there is something new, The "USB Printer #1 with status readable", it wasn't there before, when I didn't install any driver. I tried to proceed with the "USB" thing and it brings the same option like a regular add new device searching driver from the server dialog. So, I cancel it and went back checking the "Canon iP1900 (41185E)".
The problem here is that, when i click forward the canon it search for available driver and stops...the next time I click again the forward button, it just showing the hourglass loading icon on the cursor, and the after a while it switched back to arrow cursor again as if nothing happened.

so, I guess this is a fail too?

So, about the "I can't click forward upon the driver selection dialog" is like this video i uploaded to youtube.


Have you tried configuring the printer through the CUPS web interface?
That would require opening a browser at and adding or searching a printer from there. The user and password asked for there would be you and your password (same as sudo).

I very much doubt this'll work but maybe there'll be more error logs.
Looks like the correct driver is not showing up or not reachable by cups.

That's normal behavior there if the driver doesn't correspond to the recognized printer (according to CUPS) it's to avoid trouble. :smiley_cat:

Maybe @Thanatermesis has some ideas on this issue.

I also doubt about it too. I don't use CUPS printing much but I know about it because I used it to print files from my android phone, which connected on the same wifi network as my laptop, and my laptop is connected to the printer.

I don't think setting up CUPS will make it better because it's a very different thing, it's more like a network thinggy, while, what's troubled is about the driver and the system are not handshaking very much.

there isn't much information or debug about the error :pensive: