LXDE Mint VS Elive

You use CUPS all the time when you print on Linux.
It's our only option available (connected or over the network) so that is the only path to take.

The is the local machines IP (same as localhost) and 631 is the port. It will allow you access to drivers and configuration on the machine. It actually does the same as the "configure printer" interface you have been using until now, but is a tad more versatile. It's a web interface to the settings, that's all.......it can be done through the command line too, if wanted.

What info are you referring to here?

another option:

Open a terminal and run "elive-health" command with the printer connected. That will re-run the scripts normally used at startup and with a bit of luck recognize the printer or prompt for a driver.
Give it time to finish ...... it will take a while. :smile_cat:

I meant when some error came out, it just too little information about the error. whatever that is, I'll try your suggestions tomorrow then. it's late here already.

Yeah, timezone differences .... it's early here in Europe. :smile_cat:

okay, so today I tried this thing.
opened the browser and put the address, and it brings up CUPS page. I selected the printer administration, then under the printer list, I clicked the "add new printer".

At first, it pops up a username and password for me to fill, this confused me because idk what should i fill. i fill user, user, it gave me an error, I filled root, root, also gave me an error...I didn't make any user since i'm trying the live version.

Then, I look for a code for me to create user, so I use this:
sudo adduser user
i entered UNIX password, reenter the password, filling information such as full name, room number, work phone, and other. after completed I tried to add new printer again from the CUPS. The user i created works but there is a problem. Something forbid me to add new printer on my system, idk what that is , it just give me a "forbidden" word. I think this is the root of the problem.

Ah, yes ..... well I take it this is still the live version.
In that case you will have to give your created "user" admin (especially sudo) rights or ..... create a (temporary) root account or ..........
use the password for the live user. That would be: "eliveuser" with password "elive".

Sorry about that. :face_with_head_bandage:

ill try this tomorrow

@triantares well, guess what, the problem is solved beautifully without any problem or missing any libs. I installed the *.deb drivers, and added the printer using CUPS with the eliveuser account.
So, the conclusion for the adding printer thru settings dialog still have to be modified a little bit.
Since the iP1900 series printer is still rare to come by, i think elive should add it in the installation package, so that the other user won't have the same problem.
The one thing I learned from this problem is that the one that managing the printer in Linux OS is the CUPS, CMIIW.
Now, I want to try my other printer and see if it has some problem too. (it's MP258, it has scan ability)

This note is printed by ip1980 printer using Linux Elive OS on a small note paper.

smooth install, smooth test, print OK, scan OK.
Also, I tested the touchpad inverted scroll setting, which I encountered a problem in Linux Mint (where I have to create a script and put it on startup, to make it work)
So far, I think Elive outmatched Mint(or Ubuntu) by many points.
I think my research about Elive close to conclusion, i just have to retest some of minor features to make sure of it. btw, how to stop the wallpaper from constant changing? because it cause a little lag when it changes.

Okay, so the printer problem solved. Now, I have another problem. The brightness problem.
Normally, by pressing F11 and F12 by default, it should increase or decrease the brightness. But, nothing is happening when I press the F11 (decrease brightness), and F12(Increase brightness). Also, I can't find any brightness settings, the only thing i found is backlight only (idk, what that is, i tried messing up with it and it seems nothing is happening to the desktop).
F1 (No sound) - works
F2 (- sound) - works
F3 (+ sound) - works
F4 (backward) - works, maybe
F5 (play pause) - works, maybe..because it opens rythmbox when i press it.
F6 (forward) - works, maybe
F8 (change display) - it works but i rarely use this
F9 (search files) - works, but i use other search more often
F11 (-brightness) - not working
F12 (+brightness) - not working
PrtScr (screenshot) - works

Also, as i mentioned in earlier post, Elive lacks of indicator (for sound or maybe brightness too), it should show the user some icon or bars if the sound is increasing/decreasing. or the brightness is at the lowest or highest setting.

As for brightness, I tried to google it on how to set the brightness thru terminal, but it seems I got some dead end. from what i see from the tutorial, it should return something like VGA1 or something like that.

xrandr | grep " connected" | cut -f -d " "
xrandr: Failed to get size of gamma for output default
cut: invalid byte or field list
Try `cut --help' for more information.

I'm happy we got the printer issue sorted out.
As to your other points:

  • There are no visual indicators (OSD) for sound and brightness afaik.
  • Not sure how to stop the background switching in live mode but if/when you install to HD it will not be turned on.
  • Brightness is not run by "xrandr" but you can use "preferences" , "screen settings" to manipulate xrander. To find the output use "xrandr -q" it will return the current screen and its settings.

Normally brightness/backlight (same thing) can be manipulated with the slider on the bottom right side of the screen:

That should work.

Im sorry but this isn't working. when I clicked the icon, the "O" is at the lowest (maybe at zero as for number), pulling it up does nothing to my screen. my screen maybe at 50% brightness at default.

Xrandr might be an option but I'm not sure as I don't have a physical machine running Stable, mine's on virtualbox in 3.7.x beta.
As a matter of fact you might want to test your printer(s) on beta too ..... that would be very helpful. I can PM you the download link (32 and 64bit) if you feel like running some tests on that.
They are stable enough only the desktop is very different, for now.

You can try the command `"xrandr --output default --brightness 1.0" to set the screen to max brightness, as a test. I have my doubts though. :face_with_head_bandage:

Maybe some of the others know how to manage a Dell. :thinking:

bump @Thanatermesis (for adding the .debs to repo too :smiley_cat: ) @Rebel450 @yoda or @LupusE :idea:

well, alright, i'll give it a shot tomorrow.

sure, why not.

this doesn't work I guess.
xrandr --output default --brightness 0.1

xrandr: Gamma size is 0.

xrandr --output default --brightness 1                                  1

xrandr: Gamma size is 0.

xrandr --output default --brightness 0.1                                1

xrandr: Gamma size is 0.

xrandr --verbose |egrep '(Bright|Gamma)'                                1

xrandr: Failed to get size of gamma for output default

ls -l /sys/class/backlight                                              1

total 0

cat brightness

cat: brightness: No such file or directory

cat brightness                                                          1


cat /var/log/Xorg.0.log | grep "intel"                                130

[    65.503] (==) Matched intel as autoconfigured driver 0

[    65.503] (II) LoadModule: "intel"

[    65.508] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so

[    65.554] (II) Module intel: vendor="X.Org Foundation"

[    65.578] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:

lspci -k|grep -iA3 vga

00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 21)

        Subsystem: Dell Device 06ac

00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 21)

        Subsystem: Dell Device 06ac

I suspect the fix can be found here:


but im not sure if I should try that.

2 posts were split to a new topic: Black screen on boot with 3.7.16 beta

it seems you already split the topic to somewhere else, thanks for that. since im kinda busy.

A post was merged into an existing topic: Black screen on boot with 3.7.16 on Dell inspiron