Black screen on boot with 3.7.16 on Dell inspiron

Today, I tried the beta version of Elive. I'm really sorry if I can't get any result on it because it just doesn't run. Out of many options, the regular live boot will give me black screen with no output. As for Safe mode or anything with problematic mode gave me some graphical error output upon running it, and cannot get in the desktop, stuck in terminal mode.

This is the error output from the safe mode, and other problematic mode.

Can you put this on the a separate thread and mention that its version and betas status.
apparently your system is running and only the Xserver (startx) is having trouble for some reason.
This thread is better kept to the topic it initially had.

Take a look around the forum using the search option ..... I recall hearing/reading others with similar problems.
To see all the hardware parameters on your machine use:
"inxi -Frnz:"

Some had luck through using an external monitor, where apparently the first display wasn't recognized correctly and it looks your monitor isn't either.

No, that shouldn't be needed as 3.0 Stable is Jessy based and 3.7 is Buster (and Kernel version 5.2). The thread there, might indicate the origin of the issue, though.

Moved to new thread.

This is the output of inxi, did it on Mint:

  Host: tentram-pc Kernel: 4.15.0-66-generic x86_64 bits: 64 
  Desktop: Xfce 4.12.3 Distro: Linux Mint 19.2 Tina 
  Type: Portable System: Dell product: Inspiron 14-3452 v: 4.0.7 
  serial: <filter> 
  Mobo: Dell model: 0KT6WF v: A02 serial: <filter> UEFI [Legacy]: Dell 
  v: 4.0.7 date: 04/26/2016 
  ID-1: BAT0 charge: 41.4 Wh condition: 32.9/41.4 Wh (79%) 
  Topology: Dual Core model: Intel Celeron N3050 bits: 64 type: MCP 
  L2 cache: 1024 KiB 
  Speed: 608 MHz min/max: 480/2160 MHz Core speeds (MHz): 1: 481 2: 513 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell) 
  v: 4.5 Mesa 19.0.8 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k4.15.0-66-generic 
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Atheros type: USB driver: btusb 
  Local Storage: total: 480.43 GiB used: 37.74 GiB (7.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade 
  size: 14.66 GiB 
  ID-1: / size: 457.45 GiB used: 37.74 GiB (8.3%) fs: ext4 dev: /dev/sda1 
  System Temperatures: cpu: 50.0 C mobo: 47.0 C 
  Fan Speeds (RPM): cpu: 0 
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/gezakovacs-ppa-bionic.list 
  1: deb bionic main
  Active apt repos in: /etc/apt/sources.list.d/home:stevenpusser.list 
  1: deb /
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb tina main upstream import backport
  2: deb bionic main restricted universe multiverse
  3: deb bionic-updates main restricted universe multiverse
  4: deb bionic-backports main restricted universe multiverse
  5: deb bionic-security main restricted universe multiverse
  6: deb bionic partner
  Active apt repos in: /etc/apt/sources.list.d/thierry-f-fork-michael-gruz-bionic.list 
  1: deb bionic main
  Processes: 180 Uptime: 4h 17m Memory: 1.86 GiB used: 867.2 MiB (45.5%) 
  Shell: bash inxi: 3.0.32

Good, I would certainly advise attaching an external monitor and see if it can be handled by X.
That way we can maybe narrow down the "problem" to monitor settings.

After that we can check out the logs and see what went wrong exactly, if need be on TTY1 or TTY2.

Did he ever send the inxi output ?

Yeah, see above.....what's your point?

On the first screen grab there's mention of a parse error in /etc/X11/xorg.conf.0 concerning the monitor. The screen works fine on Stable.

This is not about my main post's laptop but

I just want to mention the discovery I got just now.
I have a Macbook Air 8GB and a damaged ASUS 4GB laptop at home, Here are the results:

-stable: blackscreen with "boot error" written <-right after select which to BOOT
-beta: successfully get into the desktop, no problem with anything. brightness working. one thing i dont understand is that, when i use "free" on terminal, it shows i only have 2gb ram, with 0 swap.

-stable: graphic error on regular live boot, not trying the other yet
-beta: successfully get into the desktop, with "ndivia" option on boot selection, brightness working.

I dont have any spare monitor, neither at my workplace or home.

as i can see, every machine has its own problem, lol.

It means swap probably wasn't created ... or found.
If you know for certain that there is a swap partition available on your HD you can activate it with:
"sudo swapon /dev/sdaX" where X is the partition number. Remember you are using the Live version, installing gives more options to accessing HDs and frees more RAM.

A macbook is a special beast and as it has sufficient RAM (the Asus too): I'd use the 64bit iso for that.

Stable does not support UEFI, that will be the boot problem. It requires switching to "legacy mode" in the BIOS.

Then that would require some trouble shooting from the command line... :coding:

and what should we do now? :thinking:

First and foremost we'll need to look at "/var/log/org.0.log" for errors and/or start another instance of X from a virtual TTY to see what what errors (if any) crop up there.

I'll sum up the actions:

  • Go to a virtual TTY by hitting Ctrl + Alt + F2.
    Normally you should already be logged in as the "eliveuser".
  • Check Xorg.0.log for errors with: "less /var/log/Xorg.0.log |grep EE" and check what errors are there.
  • Start a second X Session with the command: "startx -- :1" (watch the white spaces there!) and see if that starts up X normally. If not, you will be confronted with error messages so see if they differ from the previous ones.

Good bug hunting. :coding:

Oh yes, do run the "inxi -Frnz"`command again. that way we can compare if Elive sees the same hardware as Mint. :smile_cat:

idk what that is, but I automatically entered the SHELL command after sequences of graphical failure when booting up. I guess it's the same thing.

This is what i got from the startx.

It seems that the file is not there.

I'm sorry but this is what i can get, I don't know how to scroll up during SHELL mode.

Well, not quite. I was hoping you had a black screen but a working X nevertheless ...... apparently not. :thinking:

The output there recommends checking "/home/eliveuser/.local/share/xorg/xorg.2.log" we might want to see what's up in there.

Use Shift + PagUp or PagDown for that.

Or, pipe the the out put through "less", letting you read with PageUp or Down and exiting with q
To save typing effort, recall the previous command with key "arrow up", or start typing "inx" and it will autocomplete to your last used command by using "arrow left" and then adding "| less" :coding:
"inxi -Frnz | less"

But clearly inxi shows that X is not running. We already knew that.

The output also seems to tell you are "root" there which puzzles me :face_with_head_bandage:
Does the command "whoami" tell you, you are "root" or "eliveuser"?
If it says "root" you might try a "telinit 3" and see if it will go to a graphicall shell but I suspect you'll be dropped in the same console again.
Another thing to try (grasping at straws here) is:

  • "su eliveuser" --Contrary to popular belief "su" does not mean "super user" but "switch user" .... with no user specified it defaults to "root".
  • and then the "xstart" "startx" command again (root normally shouldn't be getting a GUI)

because i run it with sudo. before, i ran it normally, and it gave me "something only can be access by root" or similar to that.

i typed "users" and the output is "eliveuser"

i'll try and see

That tells you what users are there on the machine.

You definitely need "whoami" output to be sure.

so, here's the result of everything.

the SHELL appear after fails

checking the user, using 'whoami' and doing 'xstart'

I caught an error during booting up...

and here are the full inxi

The command should've been "startx" my bad ...... :face_with_head_bandage:

Anyway, it's clear from your first screen that there's a (i915) driver/module problem.

I found a thread for an Asus that implied the following might solve the issue, it's worth a try:
First do:
"sudo telinit 1" which will put you in root console (aka rescue) mode.

"Xorg -configure"

Which should ouput/create the file

and then:
"cp /usr/share/X11/xorg.conf.d/xorg.conf"

and then "exit" or hit Ctrl+D and see if it starts up X.