Module dm-raid45 not found in module.dep error when installation

#1

During the installation phase of module dm-raid45 not found in module.dep error given. Unable to install. Live does not work.

#2

Hello Herkul,

As how you write it, looks like your hardware is too much recent for this version of Elive (yes it is based in old packages / kernel drivers actually), but don't worry, I have been hardly working in the next beta versions and they are pretty madure, I will release the first builds soon ! They will include kernel 4.20, debian buster based, 64bit builds, and secure boot enabled among other things, please keep updated to the newsletters to be notified :happybounce:

3 Likes
#3

Many thanks for your reply, I'll look forward to the new version.

#5

You got me excited again
Yoda

1 Like
#6

Spoiler:

:eyepopping:

1 Like
#7

Hi, Thanks
I test to download and install it and found some problems:
With the Elive I get this screen:
Elive_Screenshot_2019-04-29_21%3A22%3A43__684x129
I test with Rufus in Windows XP and when reebot to launch Elive I get this and stop: (USB led is blinking)

Module dm-raid45 not found in module.dep error when installation
Persistence do not save some configuration
#8

I forgot.... The MD5 is the same as in web

#9

Looking at the image it looks like the problem is with the permissions of the file, like if this owned by another user, sounds like no read permissions in your downloaded file, you should first record the Elive version without this error showing up

And, it should boot without problems just like the previous version, so nothing changed about that :slight_smile:

#10

Ok, Thanks.
I download again Elive (USB 3.0.4) and get to install to USB directly and OK.
But when try to run from USB shows same (2) window as before


This is a 32bit Old laptop (10years) and with Elive 3.0.3 works,,,, why now do not found module dm-raid45?
Any idea? Thanks

#11

If Elive 3.0.3 worked that's an important information... what changed? hum...

Can you try to boot with the "debug" boot option (menu)? and put here a screenshot of the last messages in the screen

Which tool you used to record the USB ?

Can you try with a different USB too ? (but if worked this one with 3.0.3 it should work too...)

That's strange, I'm not able to reproduce the issue here with 2 similar computers where I tried the USB version :confusing:

Have you verified the MD5 ? but if you downloaded it again it should be correct, hum...

#12

I have also tried to write with Etcher and this tool is not the issue, let's try to find the cause...

  • Try the "debug" mode and show a screenshot here
  • try with every boot option, all of them gives the same issue?
  • try with a different USB media (strange that it worked with 3.0.3)
  • the download may be broken, check the MD5 of your USB download (use winmd5 dot com if you are in windows)
#13

Hi,

Not necessary, these one works from time.

It is good
Elive_Screenshot_2019-04-30_20%3A42%3A05__538x325

I do with big notices.
.- Live and Install......... NO!!!! work
.- Live and Saved (Persistence).........NO!!!! work
,- Graphical........ WORKS YES!!!!
.- Safemode....WORKS YES!!!!
.- Console....WORK YES!!!!
.- Free Drivers..... WORK YES!!!!
.- Debug and Verbose WORK YES!!!!
-
.-Old Computers Live and Install....NO!!!! work
.-Old Computers Live and Saved (Persistence).........NO!!!! work

It seems as is only in "Live" booting
While doing booting in "Live" before crash I see something in screen very fast, I take a video with my mobil and look for the frame before fails:


after this (in a short time)

Only in "Lives" mode booting is failing.

#14

I didn't know this way to get the MD5 of the files :slight_smile: but looks very simple and friendly, I will try to add this info in the website too

Perfect! After to show me that list I can see the main differences between every boot mode, let's try this:

  • Boot the USB
  • In your first menu line, just press TAB key so it will show the list of options
  • Change them and see if boots (try each one per boot attempt):
    • by removing the "splash" entry
    • adding vga=normal
    • replace "splash" to "nosplash"

I think that "splash" is the problematic one, or maybe there's a dialog that should appears in your screen and it doesn't because you are in a different tty, so this is also worth to try (in the failing mode, when it is stuck):

  • press Ctrl + Alt + F1 to switch to the first console (try with each console from F1 to F12, to see if you are missing an interactive dialog or something like that

Oh hum... It is possible that you should be able to see a dialog for your Nvidia or ATI card (if you have one?) and then it fails to show it... interesting, im gonna test that here

#15

BUG FOUND !

Note: @Herkul , @vesteve58 I moved the other topic to this one, the ISSUE has been found and this the explanation of how to solve it while I rebuild a new updated version

too bad, too many people downloaded this version, affecting to all the users that had nvidia / ati cards :frowning:

1 Like
#16

3.0.5 available for download with all the small issues fixed! :cheerleader:

1 Like
#17

It is the "thunar-gtkhash" from repository