Nvidia Privative Drivers installation

Hi!

In a new try, with dual operation: installation by morphing (migration) from CAELinux, with CUDA, on the eeepc 1015pn, same screen blablabla recursive fault blabla...

Ih!

Should I use the Nouveau or proprietary drivers for an Asus GTX 1650 Super? (I'm building a PC, and would love to use the open source drivers but heard that they're CRAP.)

Try both!!
This is beta testing after all and it would be good to hear more experiences.
In my experience Nouveau just about makes the card work, not much more....for more GPU features, you will need the proprietary drivers.

2 Likes

Hello!

New tests with 3.8.17 /64 live usb, for now on:
Precision M4400: impossible to run it, from start or elsewhere;
By the way, can't find the command nvidia-privative-drivers-install: What's up????
Eeepc 1015pn: runs ok but the option for setting CUDA is gone...?

EDIT for completion: on M4400, when usb booting with nvidia privative drivers, it starts until the double "OK" before E16 desktop launch, then going to write errors, tryings without x, y, .... and nothing more.......

Salutations!

sudo :slight_smile:

sudo nvidia-privative-drivers-install -h

mmmh... i need more info:

  • this means that no "nvidia installer" is run ?
  • I assume you tried with both new and old kernels? (that's important to know if the issue is with the kernel or with the driver of nvidia)
  • what driver of nvidia is the one you use for it? the 340-xx one?

Hi!

I'll verify, but I'm quite sure to have fit the sudo (if not, it should write a blabla, isn't it?)...

On the M4400, I didn't think about testing with the old kernel >> will asap..!

For those two machines, it's still 340-xx!

What about the disappeared CUDA install option that was in precedent 3.8.15 (even if not working yet with Blender)..?

Salutations!

If it doesn't work, nvidia<TAB> is your mate.

Never forget tab in Linux. It may just save you an hour. :smiley14:

1 Like

Hi!

So, for the M4400, the nvidia privative effectively works on old kernel! :+1:
But still no CUDA... So I´m trying to check opencl, and:
Well, good idea to clean this thread, but doing that you erase the special command to force coming back nvidia settings to a legacy after a synaptic install that automatically fits the new one... :frowning: So I have to crawl finding it back... :thinking: :face_with_head_bandage:
nvidia-privative-dirvers-install is back...

EDIT: When installing on HDD (still on M4400 fx770m, old kernel & nvidia privative), at the "end" of the process, it asks about fitting CUDA or not; Well, but replying "yes" or "no", instantly got a full black screen, trying some *F12, *Fx no more, just having eventually the HDD led blinking... At first try with "yes", hard restart after a while gives no boot option, second test with "no" gives by chance the option to reboot on installed Elive... ...but..?

Ih!

1 Like

Like overclocking/fan manager I assume?

What is CUDA? There's nothing that I can find that explains it in a way i understand

No, for 3D rendering on the GPU itself.

Hi!

It permise to use full skills of nvidia GPU's, with parallel computing, not only for graphics (as in Blender 3d), but too for neural simulation, and many other things...

Salutations!

1 Like

Hello!

On Asus EeePC 1015PN, 3.8.18 x64:

Nvidia privative goes as usual, but the option that was in the precedent 3.8.17 to fit CUDA tools seems to have disappear..?

Now a question is about if it's worth or ot to wait nvidia dev's that are supposed to work on last Linux kernel to make it run... But perhaps letting a gap for "old" 1015PN or M4400 alike machines? Have to spend time on this...
Seems OpenCL isn't yet useful (at least I can't figure out to run it for Blender...)...

Salutations!

Hello!

On Asus EeePC 1015PN, 3.8.19 x64:

Nvidia privative goes as usual, but when Elive asks about installing CUDA tools, if saying "yes!", the screen turns black and nothing more, even after about half a day as it, connected on the web; After reboot, Cairo & conky are away, and other things...

Salutations!

  • the ISO 3.8.19 had problems with the kernel compiling modules, this is fixed in 3.8.20
  • @Franc : when reporting errors, tell the other needed details to know in order to reproducude the issue, for example:
    • which version of the nvidia driver you used for the CUDA
    • which kernel version you used
    • live or installed mode
    • how you are running the tool to install the drivers AND cuda, and which options you used
      • are you running the tool with the graphical mode running?
1 Like

Didn't detect my 1030, even though the tool even showed it at the bottom of the lspci output:

04:00.0 VGA compatible controller: NVIDIA Corporation GP108 [GeForce GT 1030] (rev a1)

once I used -f though, worked like a charm! "current" worked.

I've also noticed that E16 is quite laggy while switching desktops, where it wasn't before.

Ctrl-Alt-Left/Right - anyone have the same issue?

A post was merged into an existing topic: Steam will not run becuase it has glXChooseVisual issues on elive 3.8.19. Using Nvidia 460.39 Drivers

interesting... can you confirm me that the Live mode installer works "out of the box" ? so in short:

  • you boot a recent beta version of Elive
  • nvidia card is detected and automatically the nvidia-installer tool of elive is run (not manually)
  • the installation finishes successfully (no need to do -f options or other tricks by the user)

not me, we need to investigate the cause of this issue:

  • run a recent beta version in Live mode (see if happens)
  • upgrade the live mode and re-login in the desktop (see if happens)
  • do the other things needed to make it happen if didn't :thinking:
  • related to the drivers? (with nvidia, without nvidia, etc...)

note: the last post was about Steam, so I moved to the other thread: https://forum.elivelinux.org/t/steam-will-not-run-becuase-it-has-glxchoosevisual-issues-on-elive-3-8-19-using-nvidia-460-39-drivers/2751/

How do I install CUDA in an already-installed system? :thinking:

EDIT: Trying the -x option

Seems like @sprinterdriver has issues installing drivers, apparently because the nouveau driver is not blacklisted before to install nvidia, does anyone else has this problem? I don't have an nvidia machine to test it

let's see:

the issue is that nouveau module is loaded and that's why the nvidia one cannot be used, if you select the nvidia option in the boot menu and press TAB you can read an option that blacklists the nouveau driver (this is needed in order to install nvidia), but I'm reading now on internet that the needed options are different now (why kernel devs always change things? damn...), so, we need to test this:

  • boot in live mode
  • select the nvidia option and press TAB to edit the parameters
  • change the blacklist of nouveau to these options: "rd.driver.blacklist=nouveau nouveau.modeset=0"
  • boot and see if you can install nvidia drivers now...
    • if worked, try the same thing without the "modeset" one (only the first blacklist option), report me if only with this option works too

so we need to have it fixed correctly for the next iso build, nvidia drivers are very important to have them working