Nvidia Privative Drivers installation

Maybe you need to run "apug" first to have access to the newer repositories?


apug, when full installed just recently with the new 3.8.9 .iso (& internet connexion)???


Always run apug, first thing.
Buster repos change continiously.

sure, first update your packages lists with "apu", then let's assume you are using the 340xx driver, so you can simply:

~ ❯❯❯ apse nvidia cuda 340xx

libnvidia-legacy-340xx-compiler/buster 340.108-3 amd64
  NVIDIA runtime compiler library (340xx legacy version)

libnvidia-legacy-340xx-cuda1/buster 340.108-3 amd64
  NVIDIA CUDA Driver Library (340xx legacy version)

libnvidia-legacy-340xx-cuda1-i386/buster 340.108-3 i386
  NVIDIA CUDA 32-bit runtime library (340xx legacy version)

libnvidia-legacy-340xx-nvcuvid1/buster 340.108-3 amd64
  NVIDIA CUDA Video Decoder runtime library (340xx legacy version)

which will show you the cuda packages related to the 340xx driver which comes from the elive default repos and should be the correct version to use. Then:

api libnvidia-legacy-340xx-cuda1

to install the packages that you want to install, like in that example, and BTW tell me -which- one is needed for blender to run correctly :slight_smile: (try one to one, re-launching blender at every package that you install)

there's no much difference but they are different tools, and this mean that they can behave differently, so its better to use api just because is well tested and we know its expected results, but you can use any that you want

BTW this should be not needed at all if you install the packages from the repos


The cuda files you point here "never" have problems to install & run on Elive with eeepc 1015pn (well I rarely use it for encode/decode video for now (no time for videos))...
The one (set of ones) needed for blender processing is, for 340xx, the one that can be find here: CUDA Toolkit 6.5 | NVIDIA Developer , findable as .run, .deb (ubuntu) local or web...

EDIT: an other thing I already write somewhere is that it seems Elive didn't count on the "main cpu gpu": on the eeepc 1015pn (didn't tested on the Precision's), there's two gpu's, the one integrated in the cpu, and the nvidia Ion2, but it seems impossible at install or usb start, to run on the "cpu one" (it's "nouveau" or "privative" nor "cpu"); If it could go on "cpu", it would be easy to, say going from "nouveau" to "privative a" to "privative b" for testing ... And here, we're still not about talking around Optimus (that, yes, may need to take time to ßtest too; yes I have to, but for me CUDA toolkit is very first in the list...))


yes but we need to use the packages provided from the elive repositories

did you tried to install the cuda packages from the elive repos to see if they makes work blender ? like explained in the previous post


Just re-tested, after full Elive re-install (on eepc 1015pn) to be sure having no precedent tests elements, from apu to:

...but again, the lack is of installable cuda toolkit 6.5...
I remind you that for the Dell Precision M6700/nvidia M5000M, just installing current cuda toolkit via synaptic makes cuda ok for Bender to detect & deal wth it...


which is the exact package name?


For 340xx, the best one seems to be: http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/x86_64/cuda-repo-ubuntu1404_6.5-14_amd64.deb,
or it's .run version: http://developer.download.nvidia.com/compute/cuda/6_5/rel/installers/cuda_6.5.14_linux_64.run...


@Franc but you said via synaptic, we cannot use other packages than the ones provided from the elive repo

please try to install one to one those packages, and then run blender after each one is installed to see if any of these makes blender working:


Just done (eeepc 1015pn nvidia340xx synaptic): for libcuda1:

libcuda1 curr-lega
As you can see, it's all 440xx (so sudo update-alternatives --config nvidia choice "2")

libcuda1-i386 matches nothing with synaptic;
ok via >>>api ... (no cuda in Blender...)


Still no cuda in Blender here, even launching by sudo (a known trick sometime to fit cuda ok for the frist Blender run) ...

A side thing, out fo thread but I let it here: seems an ALSA problem at Blender start: Blender ALSA

Same for Blender 2.80, but with some errors too (due to lack of the correct drivers I thing): Blender 2.80 error

(In a first time I fit one+one+one, now un-install the first, than the second...)

hum... I see...

seems like the cuda is only available for the 440 version but not for the legacy one, that's strange :thinking:

please also try this command (in live mode probably, in order to not mess up your system):

api nvidia-cuda-toolkit/buster-backports nvidia-cuda-dev/buster-backports libnvtoolsext1/buster-backports libnvvm3/buster-backports libcupti-dev/buster-backports

it will install some cuda packages that are avaialble from the backports repo (which are updated), im not sure if these are the cuda packages needed or not, probably not because they are pretty huge


Tryed, no luck... (On installed Elive: I use the eeepc 1015pn quite only for testing Elive, so...)
Beside this, I test back on the Precision M4400/FX770M (nvidia 340xx too), with 3.8.9 usb (an installed Elive is on it too, but not updated & Reiser4): The .iso doesn't want to start with privative drivers (writing from it, on "nouveau")...
So I opportunely look for opencl way, with no result at now...


After to read a bit on internet, seems like what you need is to install (our) package nvidia-cuda-tookit, which we can try now to install it from this command:

api nvidia-cuda-toolkit/buster-backports nvidia-cuda-dev/buster-backports libnvtoolsext1/buster-backports libnvvm3/buster-backports libcupti-dev/buster-backports

but you said 3.8.9 doesn't want to use the nvidia drivers? mmmh.. what is the error message? why they not works?

3.8.10 will be uploaded soon


For usb boot on Precision M4400/FX770M... On the 1015pn it's ok (same 340xx drivers)...
Just launched the commands you give upside, on installed 3.8.9, 1015pn, no more for now...

so... with this next command, to install nvidia-cuda-toolkit from elive provided repos, does blender works correctly?

api nvidia-cuda-toolkit/buster-backports nvidia-cuda-dev/buster-backports libnvtoolsext1/buster-backports libnvvm3/buster-backports libcupti-dev/buster-backports

Well, no more success: the command asks for an autoremove, done, but no more...
Perhaps having to re-test with fresh usb boot or new install in order to be sure to have no parts of precedent tries?

Just for the precision, Blender works, even 2.80 (last test with 2.82 didn't run: glitches and off (but hardware necessity increase with this one)), but doesn't see cuda on 340xx...


Im confused, these are not the versions of blender provided from the repos

the important thing is that the version provided from the repos (and in the iso in fact) does work correctly


I test systematically both the one furbished an new (2.80 & next) ones...
If I didn't give nuances between the twos in my reports, it's that there's none; Be sure that if one run or have a problem and not the other, I will tell...
In facts there's here tree cases: the "original" 2.79b, the 2.80, and new ones...


3.8.9 loads Nvidia drivers for me
Well, not the same graphics card though...