Ralink 3290 wifi card's Bluetooth is not working

I'm having an issue with my bluetooth in elive 3.8.34. Coinky shows bluetooth running (blueman, sorry, not in front of the laptop) but cannot access bluetooth manager or the taskbar icon. When initiated from their menus in applications, an icons appears for less than a second. WiFi is functioning perfectly btw.

I'm running Elive on an HP Pavilion 11-n010dx X360. Thank you for any help.

I've seen this issue too (albeit not on all my machines) where the "bluetoothmanager" hides itself somehow, where it should appear......or at the least put itself in the systray.

I can sort of replicate what's happening on another machine (similarly, I don't have access to the quirky machine now) by killing "blueman-manager" where the systray icon is still running.
Subsequently a next call for "blueman-applet" wil give:

~ ❯❯❯ blueman-applet
blueman-applet version 2.1.4 starting
There is an instance already running
~ ❯❯❯ 

Checking what's actually running use:

lsof / grep blue

and it'll show "blueman-tray" and "blueman-adapters" still running as a "blueman-t" and "blueman-a" entry.....so blueman is still up and running and accessible in the systray (but not always visible :frowning: ) ...... Not 100% sure but I think its in the way the E16 systray handles stuff opposed to gnome.

A remedy can be to:
1- Restart the laptop (clunky, windowsy and overkill)
2- Logout and back in as the user (or better yet do "sudo telinit 1" in a terminal) but both risk losing open work.
3- From the terminal kill the running bluetooth instances with "killall -HUP blueman-applet" and see if starting it on the commandline with "blueman-applet &" does work (hint it should). Starting it from there is only to see if it actually does what it should.

It should show something like:

~ ❯❯❯ blueman-applet &
[2] 1909803
~ ❯❯❯ blueman-applet version 2.1.4 starting
Stale PID, overwriting
blueman-tray version 2.1.4 starting
blueman-applet 09.48.48 WARNING  PluginManager:148 __load_plugin: Not loading PPPSupport because its conflict has higher priority
blueman-applet 09.48.48 WARNING  PluginManager:148 __load_plugin: Not loading DhcpClient because its conflict has higher priority
Terminating blueman-tray
blueman-tray version 2.1.4 starting
Stale PID, overwriting

Personally I've found the "blueman" GUI lacking sometimes in which case I switch over to "bluetoothctl" in the terminal to have finer control over stuff like connection permissions or scanning...but that's rather off-topic here.

Thank you! I will try this as soon as I get back to the laptop. Also I would like to provide further details of the problem that I can't recall at the moment.

1 Like

Strangely enough I've not had that problem on other laptops I've installed to, including but not limited to: MacBook 2010 (external microphone/audio line-in issues however); Lenovo Thinkpad L460; Dell Lattitude 2100.

Ok, finally back in front of the laptop. The Wifi + Bluetooth card is a Ralink RT3290. Tried everything and still no Bluetooth manager...

Might have to change the card out.

Also forgot to mention that I think bluetooth was functioning before I installed KDE Connect.

Did change the card out but was not happy that it was a Realtek 8188EE; that model has no bluetooth and didn't post wifi stats in Conky...

So back to the original problem...

So I ran blueman-applet &
I got the same output as you described but it is still going; it's been 20 minutes...

Any other advice? Card upgrade? Suggestions for the latter?

I'm not sure but it could be that that is hogging bluetooth i.e has it running in some form on an invisible KDE tray or bar.
Bluetooth should work but the GUI doesn't show.

Yeah, try out "bluetoothctl" in a terminal which'll put you in a interactive mode. Type "help" to see all the options ( a lot, where the blue ones are sub-menus whith more options) such as "devices" or "list" ....... and use "exit" or "quit" to leave that shell again.

Actually if you hit "Enter" the prompt will appear again. The additional "-&" flag in the command let's the command continue even after closing the terminal. It's its own instance now and will have to be terminated through itself (the GUI) or using "killall -HUP bluetooth-applet"

Replaced the network card with a broadcom bcm43142 and everything is functioning well with the exception of conky not recognizing the card or reporting its stats. Will backup and reinstall Elive.

Don't reinstall ..... just remove/rename conkys configuration file (~/.conkyrc) then log out and back in.

Alternatively you can create a new user (for testing purposes) and log into that account to see if conky gets the card correctly.

Yeah,wanna see if the card is dying or not. Here's the output of lspci:
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
00:13.0 SATA controller: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller (rev 0e)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0e)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
00:1c.0 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 (rev 0e)
00:1c.1 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 2 (rev 0e)
00:1c.2 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 3 (rev 0e)
00:1c.3 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 4 (rev 0e)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
00:1f.3 SMBus: Intel Corporation Atom Processor E3800/CE2700 Series SMBus Controller (rev 0e)
02:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
02:00.1 Bluetooth: Ralink corp. RT3290 Bluetooth
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

The system recognizes the card, the Ralink corp. RT3290 Bluetooth -

  • but when I try to interact with the card in bluetoothctl:
    [bluetooth]# discoverable on
    No default controller available
    [bluetooth]# list
    [bluetooth]# select
    Missing ctrl argument
    [bluetooth]# select ctrl
    Controller ctrl not available
    [bluetooth]# power on
    No default controller available
    [bluetooth]# scan
    Missing on/off argument
    [bluetooth]# scan on
    No default controller available

I then tried to select my controller:
[bluetooth]# scan on
No default controller available
[bluetooth]# select RT3290
Controller RT3290 not available
[bluetooth]# select 02:00.1
Controller 02:00.1 not available

What am I missing?

Well "bluetoothctl" should've shown the registered controller device mac address when starting ...... obviously it isn't there. :frowning:

I very much doubt that, so let's see by doing this step by step:

  1. See/show output of "inxi -Ex" To see if bluetooth is seen by the machine ("inxi -Frnz" shows full hardawre list, if wanted)
  2. output of "lsmod |grep blue" To check which modules are loaded
  3. output of "sudo systemctl status bluetooth.service"

After which we'll have a lot more info (hopefully enough) to go on.
Bear in mind that that Ralink chipset is one of the worst to encounter on Linux. Despite it being old it's hard to configure as they've got loads of different, cheap chipsets on them.....even counterfeits.

inxi -Ex
Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A
bus-ID: 02:00.1
~ ❯❯❯ lsmod |grep blue
bluetooth 950272 12 btrtl,btqca,btintel,hci_uart,btbcm,bnep
ecdh_generic 16384 1 bluetooth
rfkill 36864 9 hp_wmi,rt2x00lib,bluetooth,cfg80211
crc16 16384 2 bluetooth,ext4
~ ❯❯❯ sudo systemctl status bluetooth.service
[sudo] password for ZRVoyyd:
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; preset: en>
Active: active (running) since Tue 2023-10-17 01:51:53 EDT; 8h ago
Docs: man:bluetoothd(8)
Main PID: 5752 (bluetoothd)
Status: "Running"
Tasks: 1 (limit: 4430)
Memory: 1.9M
CPU: 50ms
CGroup: /system.slice/bluetooth.service
└─5752 /usr/libexec/bluetooth/bluetoothd

There ya go. Thanks!

Well, that was quick..... there's no driver.
Now like I said, these cards are notorious (especially for a working wifi but not also simultaneous bluetooth) but let's give it a go anyway.

Now the driver for the 3290 should be in the "firmware-misc-nonfree" package so check if it's installed ... you can use "apse firmware-misc-nonfree" to check and if it is .... you can do a more fine grained search with "apt-mark showmanual |grep firmware" to see if the RT3290 is among them.

After that we can check if the kernel even has them available to load but error-ed out with "dmesg |grep firmware" .
Which isn't a silver bullet: On my Helix2 the BCM (broadcom) firmware load fails but I've got working Bluetooth none the less using "btusb". :innocent:

All in all, if the "firmware-misc-nonfree" doesn't deliver the driver then chances are very slim to get it working AFAIK.

Have you the bluetooth firmwares already installed?

api bluez-firmware

Can be worth to try in bookworm too (or maybe from a bookworm iso when available)

That should show up in the output of "apt-mark showmanual |grep firmware" if already installed (or not)

~ ❯❯❯ apt-mark showmanual |grep firmware

and "dmesg |grep firmware" ?

~ ❯❯❯ dmesg |grep firmware
[ 0.132227] Spectre V2 : Enabling Restricted Speculation for firmware calls
[ 22.419789] platform regulatory.0: firmware: direct-loading firmware regulatory.db
[ 22.431435] platform regulatory.0: firmware: direct-loading firmware regulatory.db.p7s
[ 45.831058] r8169 0000:04:00.0: firmware: direct-loading firmware rtl_nic/rtl8106e-1.fw
[ 46.179031] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt3290.bin'
[ 46.213698] rt2800pci 0000:02:00.0: firmware: direct-loading firmware rt3290.bin
[ 46.213717] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.37

if firmware is installed, dmesg shows correct messages and all, maybe you should directly try with bookworm which is a pretty more updated system :slight_smile: , on it you have also the kernel 6.4 available, also, we should focus more like "if things are working for bookworm" where the actual work is going into

Does Elive 3.8.35 have the 6.4 kernel?