Setting resolution not found by the system

#1

This concerns the Elive 2.0 Topaz. Maybe the same is with 3.0. How to set a resolution not found by the system.

So far I have tried different instructions from different forums which give advices for xrandr, how to make a new code, how to make a newmode, how to make newmode with “newname” etc. But in the end where one should get --output it says tcrp error 0.

I’m trying to get my resolution to 1024x768. I found from the old forum to start xterm as root and Xorgconfigure gives me options to choose. I click and it says start your graphical interface again. How? I would really like to see would I get 1024x768 with this. And then if this really changes this (which I doubt) how to make the change permanent?

Anyone interested to help?

0 Likes

#2

i had problems with a crappy kvm switch which makes my computer think that the monitor resolution is 1024x800 (thought it is 1920x1080…), so i ha dto create my own custom resolution using cvt. You probably know already what i’m going to write since you said you messed around with xrandr, skip at the end of the answer.
Open up a terminal and write (changing the paramters at your will):
cvt 1024 768 60
where the first two parameters are the resolution, the last one is the monitor refresh rate.
You will get something like this:


copy the underlined string.
now write xrandr --newmode [paste the string previously copied]
and then xrandr --addmode [your video output] [the name of the resolution]
and finally let’s switch to the right resolution:
xrandr --output [your video output] --mode [your res name]
If you don’t know which video output you’re using, the easiest way to find it out (without involving any command line) it’s opening arandr (you’ll see something like LVDS, or VGA-0, DVI-0, HDMI…)!. The name of the resolution (look at the screnshot ^) the part of the string we copied between " " (like “1024x768_60”).
THIS IS MY SOURCE:


Ok so let’s say you already got to this point and everything worked out properly. You shutdown your laptop and got to sleep satisfied. When you’ll reboot, everything is gone. what to do now?
well basically you have to redo it. there may be some complex solution but seriously, none ever worked out for me so the way i took was just writing a simple script to run at every boot.
So let’s home a notepad and write it down:
vi res.sh
If you never used vim, to insert text press i and write:
#!/bin/sh
add the commands we used before:
xrandr --newmode [paste the string previously copied]
xrandr --addmode [your video output] [the name of the resolution]
xrandr --output [your video output] --mode [your res name]
press escape and then :wq (return) to save and exit
let’s set this script to executable for your user:
chmod 700 res.sh
to run it just type:
./res.sh


Unluckily, this won’t solve the problem since it’ll need to be manually executed by hand at every boot. To avoid this, you should make run the script at boot but unluckily i’m no really useful from this point of view since i’m familiar with systemd only which is not present (and for some good reasons) in elive. I unded up running the script anually at every boot xD
Hope this could be useful!

1 Like

#3

Thanks. Gonna try. Before it just didn’t work or give any --output, only error 0. I will get back. And nice to see I’m not posting to an empty forum.

0 Likes

#4

I have had these nasty black frames on the screen. When I was frustrated cause nothing worked and started to press all the buttons with either fn or ctrl on I found out that fn + t makes the picture full screen. But with 800x600 resolution Elive on a big screen does not look nice so I really need th 1024x768. Gonna try tomorrow your instructions.

0 Likes

#5

I had followed these instructions before without success but tried again.

I don’t have arandr and not absolutely sure from what source to install it. Is it in the old debian sources (http:// archive dot debian dot org ) or is there some other debian sources specially for elive where to get it? Xrandr -q gives only “default” as the video output name and if I use the --output with xrandr with this default as a name it gives tcrp error 0.

I would like to try to change the boot Vesa number in the cheat list for booting but where is the confiq file? The correct number for 1024x768 16bit would be 791.

And how do I restart the graphical desktop without rebooting so i could check if something have some effect?

I also found this get-edid command but it doesn’t show any monitor info. Just that VBE (Vesa Bios Extension) is in use, string at “Chips 65555 Super Vega”, real mode call succesfull but DDC1 and DDC2 transports have no support.

0 Likes

#6

Ummm, are you sure that your video card is capable of that resolution? Did you ever have that resolution with any other OS?

0 Likes

#7

Simply logout as the user you are and log back in. It will restart X for you.
If you’re worried this might cause trouble:
after you made your changes

  1. Hit CTRL, ALT and F2
    and login as your user

2)type “startx – :1”
!mind the space before and after the double dash there, or it wont work.!
3) and a new desktop will open on CTRL,ALT,F8 (the old one will be on F7)
that way if things go wrong you can see the output errors on F2 i.e if things go really wrong you wont have left there anyway. :innocent:
To kill the second desktop hit CTRL + c on F2, stopping startx.
Ultimately, you can reboot the system from F2 by hitting CTRL, ALT, DELETE

1 Like

#8

I have full screen on Enlightenment starting screen but when the loading bar is finished and the desktop environment shows up it is smaller with black frames and resolution is 800x600. There has to be a way to correct this, I just haven’t found it yet.

And does someone know how to change/add a Vesa code for screen resolution to boot parameters?

0 Likes

#9

You still haven’t been clear on what [old] video card you have and it could be that your fullscreen resolution combined with the depth is just too much for it.
Multiplying your resolution with the color depth gives the amount of pixels needed… at 32 bits you’ll need a minimum of 3mb available video memory. Try scaling down the depth from 32 to 24 ( 3Mb to 2.2mb) to see what that gives.
But …
I gather framebuffer does apparently run OK, so stick to that.

This is also an option that can be chosen when booting the live version with the “graphical problems option” and subsequent installation.
If the live version does run a full desktop, make a note of its X settings and copy those.

EDIT:
Just found out (google) the armada only has 2mb so you need to go down to 16 bit color for that resolution.

1 Like

#10

Thanks. I have now tried to install Elive 3 cause could not find out how to get enough up to date browser on Elive 2. If this just wont work I will then try to find a browser but if nothing works I will have to change distro.

0 Likes

#11

Feel a bit stupid. When you come to the boot screen you see the cheat codes underneath the boot menu. I just didn’t know how to modify them cause it is not said anywhere. Now I noticed that I can just move there with arrow keys and change the codes or add. Now I changed the vesa code to 791 (1024x768 in 16bit mode) and add xres=1024*767 and screen=1024x768. I have for sure that screen mode on the text screen as well as the lightment loading screen with the white loading bar but as soon as I get to login screen it is changed. Why? So annoying!

And it does not show that mode in options for screen resolution in elive.

0 Likes

#12

I found a both xorg and x86 conf files for my machine for debian 3. I made changes to xorg.conf but there are that, then couple xorg.conf with numbers (date+some more numbers), then there elive.conf. I don’t know which would affect. Last I opened the X with scite and there are a lot crypted stuff and then some lines with clear info. I tried to add needed info there but it did not aloud me to save even I’m root. Starting to be in the end with this.

0 Likes

#13

Can you be more specific as to what you changed in which files?
Check the output of lspci and find your card mentionned as VGA (it will probably be numebered 00:02.0)
Then “lspci -v -s 00:02.0” … the prefetchable output is the memory size available.

If you want to, you can create your own xorg.conf . Personally I’ve had very mixed results doing that and found X going back to it’s defaults again and again.
99% of the time X configures itself just fine but then that Armada is not an old machine but more of an antiquity.

0 Likes

#14

I started to try with one old instruction to get to play with bios if I could there affect the resolution. Link to the bios utility .exe applications was dead but managed to find it at last from the net. Win7 did not open it in dos even when chose win95 compatibility mode, dosbox could not use usb floppy drive where I had to install the program. Finally remembered that I have win98 machinr with floppy drive for qbasic use, managed to install there on dos the application to floppy. But when I finally after mnay hours work got to bios there was no setup for display. I think I’m stuck on 800x600 but it just annoys that it is 1024x768 until getting to desktop.

0 Likes

#15

That’s because it’s running in framebuffer (same as the BIOS screen) which usually is not very much deeper than 8 or 16 bits… That goes for the login screen as well…no need to waste memory there.
Your card is (methinks) just incapable of running a higher resolution at 24/32 bit mode.
At the time it was built 800x600 wasn’t a bad resollution at all.

The only option you have is to run in 16 bit mode…but then again I’m not 100% sure about your graphic card: Need to see the specs first!!

0 Likes

#16

How to get that 16 bit? I’ve tried to put it xorg.conf as depth but can’t figure out how to make it to work.

0 Likes

#17

Which xorg.conf where, did you use?
I’m surprised you actually found one on Elive 3. :innocent:

0 Likes

#18

No, I’m on Elive 2 cause I was not able to install Elive 3 even I tried with many ways.

0 Likes

#19

OK, that’s clear and doesn’t surprise me actually. :innocent:

If you need more help, you will need to give info on exactly what video card you have you have and what the original xorg.conf looked like. I cannot help without exact information and don’t feel like guessing, anymore. :nerd_face:

0 Likes

#20

Sorry for giving too little information. I can’t copy paste here from xorg.conf cause the browser in Elive 2 doesn’t support this site. I can try to give more information soon. Thanks for all your help so far.

0 Likes