Using 64 bit software in Elive 3.0?

This is a small howto about how to enable your Elive 3.0 to have 64-bit support, this little hack will install you a debian kernel in 64 bit where you can be able to boot from it and run 64 bit software.

Note that running from this kernel you can have lack of some extra drivers included in the kernel of Elive or a difference in performance, so do it at your own risk!

Let's do it simple, open a terminal and just paste all these contents:

sudo mv /etc/apt/sources.list.d/aaa-elive.list /etc/
sudo dpkg --add-architecture amd64
sudo apt-get update
sudo apt-get install -y libc6-amd64 multiarch-support linux-image-3.16.0-0.bpo.4-amd64 linux-headers-3.16.0-0.bpo.4-amd64
sudo apt-get -f install
sudo mv /etc/aaa-elive.list /etc/apt/sources.list.d/
sudo apt-get update
sudo sed -i -e 's|^GRUB_TIMEOUT.*$|GRUB_TIMEOUT=22|g' /etc/default/grub
sudo update-grub

That's it, you can reboot in your other amd64 kernel and start using / installing 64 software. Just make sure that if you add any repository it needs to be for debian / wheezy


  • Google Chrome: unfortunately if you try to install it (64-bit versions available only), it will not work because the package is not made for debian / wheezy, so it ends up in unsatisfied dependencies
  • Virtualbox has stopped to provide packages for debian / wheezy


Since the system is not entirely 64-bit, you can only run direct executables, installing packages can lead to more amd64 dependencies that will probably not work in this i386 system.


received several error running those commands… don’t know which are normal or not
DO you want the output ? ( long,…)

~ ❯❯❯ sudo mv /root/*elive.list /etc/apt/sources.list.d/
mv: cannot stat `/root/*elive.list’: No such file or directory

I can send you all the output if you prefer

As for to boot for the kernel allowing 64 bits apps, I supposed I just need to be quick on the keyboard at boot time to change from which I want to boot ?

@yoda bad news, the system perfectly works in 64 bit and can run 64 bit binaries, but I was unable to install any useful thing in my tests (no chrome, no virtualbox) so bad…

sorry to hear.

BTW you can install 64 bits OS within actual version of Oracle VirtualBOx in Elive
SO this is a workaound for people that need 64 bits apps to run within Elive

I just installed a 64bits version Ubuntu in a VM within Elive as a test

If I want to install them ost recent version of VBOX, here is what I found

They say :

  1. Add Debian Backports sources to /etc/apt/sources.list, also including the “contrib” component. For example:

Backported packages for Debian 7 “Wheezy”

deb wheezy-backports main contrib

If the file in BOLD does not exist, can I create it ?

  1. Update the list of available packages:

apt-get update

  1. Install the relevant linux-headers package for your system, for example:

apt-get install linux-headers-$(uname -r|sed ‘s,[^-]-[^-]-,’)

  1. Install the wheezy-backports/virtualbox package:

apt-get -t wheezy-backports install virtualbox

I want to upgrade to last 32 bits version of VBox as some VM important to me have been created with Version 5.2.14 r123301 (Qt5.9.5) and I want to put chances for this to work, on my side

I tried one VM already with actual ELive Vbox version… It worked but was slow a bit…

The only important limitation is 4 gig of RAM for the guest VM, but I don’t care… Can deal with that

SO I would run within a VM the 64 bits I need, and the rest on Elive ( host) natively

1 Like

We are already using wheezy-backports and also the last version of virtualbox available in backports (which is old)

See the result of: appo virtualbox

oops your a right
same version

the only bad thing that has elive right now, is that is old…

and this is not possible to change in the near future, too much work (right now, trying to move the full main server with the website and all the related things on it to a newer debian base, and to swith it to httpS)


you do not need to be quick on the keyboard, you can easily change the default os and the waiting time of grub editing:


change GRUB_DEFAULT = 0 to whatever grub’s boot entry you want to choose (for example amd64 is listed as 3rd boot option in my grub, so i changed it to GRUB_DEFAULT=2. Grub begins counting from 0 NOT from 1!!).

If u want to change the boot waiting time you can edit the next line, GRUB_TIMEOUT. I think 10 seconds should be enough.

finally update grub:
sudo update-grub
sudo update-grub2


Please don’t have yet expectations about this topic and specially don’t expect results soon! but…
check my recent comment here