Using Elive on my daily driver Lenovo Yoga (as a tablet)

C640-13IML Lenovo Yoga

I am now using, ELive of my TV PC... It will probably also become an Elive mirror.

But consider using ELive ( Retro) on my Main Laptop.

Some recent ( 2-3 years if I remember) Lenovo Yoga Laptop that if you FLIP the screen backward, it become a tablet (it's a touchcreen)

I did a test with ELIVE LIVE (USB) and :

  • Important things seem to work, I need to make more test
  • touchScreen work

But, I would love if I flip the sceen, that the DISPLAY somekind of Switch over ( reverse)... I guess you know what I am trying to say...

Would it be something easy to fix ? For Elive to recognize when I " Flip the screen on the back " ?

IF it goes well with the laptop LOL I'll then may be make the ultimate move on my Daily Driver ( Main Desktop on which I spend all my life LOL )

I had some scripts for my yoga 2-13. I'll see if I can pull them up again.
Just that:
There was a script to automagically flip the screen but it would also turn the screen quite unexpectedly like with phones when putting it flat ---- so I made it to be rotated with an icon and or a key. (it rotated mouse and touch along with it too)
I've still got both but I can advise against the automatic's maddening.

I also had a proximity script that ----- when the stylus was seen/detected, touch would be de-activated to avoid weird stuff when accidentally having your palm touch the screen while drawing.

I'm quite sure I ripped off the code from all over the place, so don't credit me for it. :madness:

1 Like

The yoga autorotate script.

the proximity:

And setting it as a service

Another proximity script:

And the manual rotate script for the Helix but can be fixed for yoga depending on the 'xinput list' output:

1 Like

These scripts sounds like a good adition to Elive :thinking: maybe could be good to create a package with a "tree" structure with autoloadings, which, when installed, will make all these things automatically working (and if the hardware is not these ones, it will not hurt at all)

1 Like

If it's to integrate them, I'll wait and APUG when ready ?

yes, well i don't know how exactly these scripts are meant to be run but the idea is to have things "directly working by having the package installed", the only bad thing is that I don't have the hardware to test, so I think that this will be a job for @triantares since he has the hardware and already knows these scripts, if he describes me "how" these scripts must be run / how / when I can tell him in which place to put them or how to integrate them in the best way and then finally creating a package

if all goes well, the package will be installed by default in next versions of elive and deinstalled later if the hardware is not detected

another thing to look into is if there's not already a debian package for these things, or supported by default with some package or github project

I will try @triantares scripts on my Yoga Lenovo when I have a minute (the least I could do to help LOL) .... I guess I create a file with the script and execute it LOL (Am rusted a bit )

It's a base they work differently with various degrees of success depending on the hardware.

They definitely need some work .... this is just a quick selection.

1 Like

Well, if they don't work stable and all that then is not worth to create a package for them :thinking: i mean they should make special hardwares better working autodetected by default, it can use detectors of hardware models to see if the package should be installed or removed etc... it all depends

Yeah, these are old scripts and tailored for my needs.
I'll have to check them and add proper recognition ..... I don't mind helping out @yoda to make them fitting for his device but they're certainly not 'catch-all' scripts.

Anyway there's only a few devices like the Yoga and the Helix that come with 'Wacom' hardware and touch combined.

1 Like

~ ❯❯❯ . /home/eliveuser/Downloads/
[3] 27781
~ ❯❯❯ warning: output Screen0dmesg not found; ignoring
unable to find device SynPS/2 Synaptics TouchPad
easystroke not found
sudo: input-events: command not found
warning: output Screen0dmesg not found; ignoring
easystroke not found
unable to find device SynPS/2 Synaptics TouchPad

[3] + 27781 done watcher

For any of the scripts to work you'll have to probe the name of the hardware first with 'xinput list' and replace them accordingly.

But that yoga-rotate doesn't look like it's going to work anymore (if it did at all). Like I said I didn't want it.

Here's a script that I did use for my X220 (@Rory has that one now).

With all the scripts, read the instructions in the comments.

1 Like

That yoga-auto-rotate isn't going to work.
What it does is check if the screen has been rotated by checking that signal -- which apparently emits keycode e03e ... or did, I'm not sure with your Yoga. This script is 10 years old after all.
There's also a way of having the screen rotate with the accellometer but that's quite maddening.
I think I could get it to work again but not straight away .... not enough time for that.

The first 2 errors are easily repaired but the 'input-events' command doesn't exist anymore.
So just forget that one for now.
Same goes for the first proximity script in the list above -- it wont work.
The .service depends on getting the script working in the first place i.e is useless without it.

The second (another) proximity script will probably need changes for your device, it's specifically set up for a Helix2. I doubt your hardware has the same name.
The script can be changed to probe for your hardware but I'm not doing that just yet .... unless there's demand for it.
Anyway I would love to see your 'xinput list' output, if only to see what has changed. :innocent:
With that output we can alter the manual-rotate script easily (only 2 digits) to accommodate your Yoga.

1 Like

❯❯❯ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Wacom HID 5204 Pen stylus id=10 [slave pointer (2)]
⎜ ↳ Wacom HID 5204 Finger touch id=11 [slave pointer (2)]
⎜ ↳ MSFT0021:00 06CB:CDB0 Mouse id=12 [slave pointer (2)]
⎜ ↳ MSFT0021:00 06CB:CDB0 Touchpad id=13 [slave pointer (2)]
⎜ ↳ Wacom HID 5204 Pen eraser id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Integrated Camera: Integrated C id=9 [slave keyboard (3)]
↳ Ideapad extra buttons id=14 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]
~ ❯❯❯

I just tried installing Brave (I'm in Elive LIve mode - USB stick)

When I run my Yoga Lenovo with Ubuntu, I can Pinch or enlarge BRAVE Web browser window to enlarge or shrink the screen at my need.

Any ideas why it would work in Ubuntu and not Elive ? Not the end of the world to not be able but it's cool....

It's not Elive, it's Brave itself.
I suspect that Ubuntu uses a different version of Brave. It needs the application itself to support those gestures. Try some other apps like 'evince' (aka 'document viewer') and check if it works there.

Good ... now I need you to do another thing and that is:
start 'xev' from the terminal and move your cursor inti the white square. Then press i.e "Escape' and see if it shows the key press and key release.
It should look like this:

after which (be carefull to not touch the screen) you rotate the screen and make a picture of the 'xev' output.
Explainer; I want to see if the kernel sees this event and what code it generates. According to that old script the Yoga uses 'e03e' when folded but yours could be different.
Take a photo with your phone and post it to me (on 'signal' or here).

We'll get this beast auto-rotating yet. :smiling_imp:

1 Like

Nope, can't Shrink or enlarge Document View window with my TouchScreen. (Not urgent... will google later)

Try booting Elive with the 5.10 kernel and see if that gets 'evince' to react to your fingers or ........Take off your gloves! :rofl2:

1 Like

LOL not working with 5.10 neither

Grrr still trying to boot with a CLoneZilla USB stick to backup my Laptop, I tried all version of CloneZilla and the Laptop do not wan to boot with it... But will accept to Boot with Elive USB Stick or other Distro USB stick... Weird... I would have loved to backup the Laptop just in case...

I had similar issues on my X1 Carbon.
I juggled around using a USB grub2 boot disk to find the Clonezilla USB disk and boot from there.
I said juggling as I suspect your yoga is as short on USB ports as my machine. :frowning_face:

Eventually it worked.

Of course you can back up yourself from a running live Elive .... using 'dd' to copy to an external disk.
It will take quite some time though so make sure you add 'status=progress' at the end of the 'dd' command ...... that way you'll know it hasn't died on you. :innocent:

1 Like