3.7.4 (32bit) betatesting experiences

I ran 32 bit version in live mode.
Not bad at all. I notice this is a non-PAE kernel .... in that that not all RAM is recognized.
Is this a feature i.e will we be able to chose?

In itself I don't mind ...... maybe I can get som llife back into my old Linutop2..... Just barely I suspect, it only has 512Mb of RAM. :happy:

I'm downloading it now and I'll run it tomorrow too :blush:

yeah, there's IMHO no sense to make it PAE, in short:

  • you have a recent computer with more than 3gb of ram, so this computer should better use the 64bit version
  • you have a very old computer, that doesn't supports 64bit, so you need the 32bit version, and of course your RAM is less than 3GB

i also dont think that there's a netboot (no-64bit cpus) with more than 2gb of ram

by other side, in the very rare case that somebody wants to use the 32bit version in a machine that has 4 or more GB of ram, he can manually install the pae kernels later :thinking:

i could build 3 different versions of elive... but i dont see the sense to make a third one, because of the previously said points (or A or B machines)

note: non-PAE is needed for old computers, I have see even good old computers unable to boot the default PAE kernel of 3.0-stable because it was PAE (and just because of the pae :slight_smile: ) and then booted with the old kernels, which are simply non-pae

1 Like

note: the 32bit version should be also a bit lighter in RAM usage

I agree, not much sense to make it PAE in 32 bit release

No sense the work for a third version PAE, you have so much work with both 32 and 64 bit release to work in another 32bit PAE version which has no real utility IMHO

and again, if somebody wants PAE, since can install perfectly with the kernel in non-pae can do it later

but in any case, i think that the 4GB of ram hardware limitations are strongly related to the 64bit hardware, if im not wrong, 64bit was created in order to support more than 4gb of ram (but then, the PAE "hacky" feature appeared to support more than 4gb of ram in 32bit kernels... BUT, only for single-processes, this means that you cannot create a vbox machine with more than 4gb of ram if you are using 32bit+pae)

1 Like


Well, the thing is that "they" can have weird logic, as in cars or even planes, and even now, it's possible to buy "brand new" computers with 64bits but 2Gb ram: when engineers are slaves commanded by ""commercials"" or better say "crappy in my pocket", such things becomes...
My eeepc 1001xp have something of an excuse to be not so young, and got 64bits & 2gb ram max (but running quite well with 3.7.4/64, even with swapoff, launching Yandex, Vivaldi...)! :wink:
@Thanatermesis: there's always things to tune up, but your work on Elive got really something impressively good..!
Thanks again! :slight_smile:


Well there is the point of upgrading!
Admittedly, installing the PAE kernel can be done in hindsight. as 2G RAM should be enough for te installer.......maybe a thought to offer it during installation procedure?

I for one have 3.0.6 running on a helix2 Thinkpad (6G RAM) which is also (for now) my work machine when it comes to my business administration as well as being used for graphics and work on websites.

There are quite a few essential 3rd party (32 bit) apps on it that definitely will not survive an upgrade to 64bit.
Frankly I'm not sure if they will survive a 32 bit upgrade to 3.7.4 either.... so all in all, I'm waiting another day with enough spare time to try that. I've allready made a backup of the whole disk so that iata loss is not going to be the problem.:popcorn:
Methinks it's smarter to clone that disk to another machine and test with that.:thinking:

On the whole, a word of warning in the installer might be usefull when it encounters an existing 32 bit install. Now it brazenly offers to upgrade it.:omfg:

I must say that I doesn't think at those possibility... :thinking:

And why do you think those applications won't eventually survive a 32 bit 3.7.4 upgrade?

Well because 3.7.4 installer is limited by what is on offer in Buster repositories (so the installer will not be able to find them) whereas the 3rd party ones will probably be relying on other dependencies.
I do have some slight hope for those that installed in /opt.

in fact the 64bit versions should be able to run 32bit software by default without problems (not tested) :slight_smile:

the point is:

  • you can download the 64bit version
  • you can download the 32bit version

if you -want- to use the 32bit version, is because:

  • you have very-old hardware, that requires 32bit system (64bit not works)
    • in such case, you will probably ALSO need non-PAE kernel in order to make it boot on those machines (i have see computers that doesntt boot because of the pae)
  • you have a cheap nettop toy with 1GB of RAM and a cpu that doesn't support 64bit
    • even if the nettop is a good one that has 2GB, it wont have 3 or more

in any of the (real-world) cases, you won't need to allow/support more than 3-4 GB of ram for such machines that requires the 32bit version

but if you do, you should then want to use a 64bit system and not a 32bit one

this sounds logic to me in a 99% of the cases :thinking:

the only "newer computers" cases that would -require- the 32bit version are those cheap nettop that amazingly they doesn't support 64bit, but again, i dont see the sense to want to put more than 4gb of ram on these extremely-slow machines (investing on them this way), this should be a very 0.0001% of the cases, in such case, since users are "hacking" the computer this way they should know about pae and installing it themselves

we need to look now at the 32bit versions like systems for really old computers, and not like a standard, because standard is meant to be 64bit in today's computer since long time ago

Yes, but before 3.7.x we only had the 32bit option available so that got installed on 64bity machines too and (in my case) got cluttered enough to not properly survive an upgrade to 64bit.

hum... in fact you should be able to switch between 32/64 bit systems (upgrade mode of the installer) without problems, it should not affect to anything, so all the binaries of the OS are changed to 32 or 64bit

this means, users of 3.0-stable should upgrade to 3.7.x (64bit) without any issues :thinking:

That's where I have some serious doubts, considering the major diffs in the repos there.
Will try later but running short on machines to try on. :rofl:


I tried 3.7.4 32bit in live mode and here are my first impressions:

  • Live boot shows a "barcode" with a console message origin just before E16 starts and leaves it all the time at the screen. Is strange because if I made a screen capture isn't shown but is always present in my screen (but mouse pointer is visible over this "barcode"), take a look:

In this picture the barcode is blue and I was starting live mode with persistence, in live mode w/o persistence the barcode is at the same place but it's green and not blue:

You can see where is it located at screen in these picture where I was trying to copy screen captures into the USB stick, that wasn't possible, probably because the USB stick was available in read only mode:

And as you can see here, if I open the screen capture and I reduces zoom, for system the barcode isn't captured, like it was between the user and its screen:

  • Persistence is not available because system says that the USB stick is only in read mode (maybe a USB stick HW failure because I can't had persistence with the some stick when I made first test of 64 bit), Gparted shows a FAT32 partition, but it seems to be R-O file system inside and persistence error message says that it can know the size of file system:

If I run apug the console shows me that I'm effectively in a R-O system:

  • Live mode doesn't use the swap partition (even if at start it looks for it), I know swap is not the best solution, but in my 1 GB system I arrive to be almost out of RAM only with 1 chromium tab (radio streaming) + Abiword (a blank document) + system monitor:

  • BTW, if I try to open a document in Gnumeric or Abiword, the window is much more bigger than my 10" screen so I have the 4 boundaries outside my screen and I can move or resize the window (I think like a non experimented user that can't open his document because he doesn't find where to click :wink:):

Those are my first impressions out of the box. The read only failure maybe is due to my USB stick, I'll try to buy another new ones next week. I found the system speed more or less similar to 3.0.6 installed, but we doesn't forget that 3.0.6 is installed in HDD and use the swap partition and 3.7.4 doesn't. I must also says that even at 93,5% of RAM used my system has been unresponsive only for a few minutes and I finally can close all my windows that were only 3 (1 chromium tab playing accuradio.com, 1 Abiword with new blank document and the system monitor)

For the applications choice my personal experience in 3.0.6 is that Opera is faster than Chromium and even more than Firefox, but maybe is only in my system. Chromium isn't bad, but I thinks Opera is a little bit faster with 3-4 tabs opened.
Also in my daily work LibreOffice from 3.0.6 is widely usable with no constraints, I know that 32 bit support will be stopped but I think that in final release installer should propose it also (Abiword and Gnumeric by default) as actually 3.0.x propose the choice between the web browsers.
Concerning e-mail apps, I think that a IMAP / POP client is necessary (I don't remember to see it but maybe it was), of course Thunderbird is not usable actually because is too RAM eater and too slow. Maybe Sylpheed would be nice or even some other lighter (I was in love of Pegasus mail in my old Win98 20 years ago, but I think Pegasus Mail dead long time ago)

I'll try it sometime in live mode before to install it (as less until the barcode bug will be solved) and maybe I should let 1 GB RAM to perform the test (I must go to pick up a parcel to increase RAM in both laptops so HP 32bit will have 2 GB RAM, but if you want, I can wait for some time before increase the RAM in this machine)

Integration of E16 is as nice as 64bit alpha/beta and even if isn't still as polished as E17 from 3.0.X is cool to have similar work environments to change from one machine to another in a "transparent" way.

I think I saw all my impressions, @Thanatermesis please let me know in which way I can help you to solve the bugs / make aditional test or perform specific ones if you need.

And thanks to maintain 32 bit release alive even with 64 bit one in the oven :+1:

1 Like

You can make it use the swap partition with the command:
"sudo swapon /dev/sda2" -where sda2 has to be changed to where your swap is
It makes more sense to install anyway, that would free up some RAM now being used by the live-mode..:idea:

In those cases I usually hit F11 (full-screen mode)to see the whole content. What's also possible is to find the right hand bottom corner to resize the window. That might be in the next desktop to the right --- Use CTRL,ALT and ARROW-RIGHT to go there.-- alternatively you can use the arrows to navigate up, down,left if there are any virtual desktops there.
Once the window is resized to your liking it should reopen as you closed it.

Installing might just solve that. :blush:

I, for one certainly hope not. :1up:

A post was merged into an existing topic: 3.7.4 betatesting experiences

looks like a drivers issue, have you tried the other boot options? try also the boot parameter vga=normal

also, maybe the installed mode will not have it, probably its a wrong use / detection of the modules or drivers or idk...

yeah, like my recent post in the betatests page seems like is not possible with the iso-hybrid images (dvd), we need to use the usb (.img) ones for persistence

thats not an error, its a feature, your system is RW in live mode (over layered ram), that message refferes that the update of initramfs file is disabled because is not needed

hum... if you have only 1gb of ram and its detected a usable swap partition in your disks (not hibernated state), it should be automatically used, try to run "sudo htop" and see if swap is already enabled (or "sudo swapon -s" )

Mmmh, I will need to do tests with those fonts which aparently are too big for small screens :thinking: (/me hides from @Rebel450)

the new versions of the browsers behaves different, but you should feedback that after to install 3.7.4 and checking / comparing these browsers to see which ones are more optimal

you should be still able to select all those options from the installer, and they should be installed if they are not (sometimes this needs some fixes in the installer)

nice one, added for the 32bit versions (only), since its pretty light and opening a web browser to access email will break the hell out! lol

well, if you can do many tests on the OS to see which things can be optimized / removed in order to make it lighter, these feedbacks are very welcome :slight_smile:

Yes, I know that, I was only informing of an issue

Thanks for the trick :blush: F11 seems doesn't work, but arrows does.

I'll install in a few minutes, as I perform some test in live mode, my problem was that these morning I had a video call with someone in Mechelen, and HP is the only laptop with a webcam, so I can't install 3.7.4-32 yesterday to make the video call with our loved 3.0.6, now I finish to verify Unison, and I'll install it in a few minutes

I'm now in live mode started with "graphical problems" menu, and "barcode " is still present et the same place :frowning: i'll try vga=normal and then I'll finally install it, wait and see....

BTW, Open GL works very fine in 3.7.4-32 with my HW, but it wasn't supported in 3.0.6 (systems was very slow with GL and I musted to disable it), it's a very good news for me, but I doesn't understand why now GL works and it doesn't in 3.0.6????

EDIT: Is an issue of E17 with my HW, E16 seems to support GL but E17 doesn't in my laptop

Yes, I have a swap partition in my 3.0.6 that is not apparently found by live mode htop says me Swp: 0k / 0k

sudo swapon-s doesn't shows any output, and swap continues missing

For screen size, I have also the problem in Acer with 3.7.4-64 and its 15,4" screen when I open a LibreOffice document, but less than in HP due to its bigger screen size.
It seems that fonts are not dinamically resized as in other applications.

As I installed the system I'll test Opera vs Chromium. I'll volontarily keep my RAM at 1 GB only until the alpha/beta 32 need to be optimised, then I'll upgrade to 2 GB

As soon as I install the system in my HDD i'll confirm you those

Don't worry, I'll install it to test as much as possible all default applications (and maybe another ones) keeping only 1 GB RAM for some weeks and I'll give you my feedback. If you need that I perform specific test or try specifics applications, plese say to me.