3.8.10 beta release

This release includes many internal rewrites and improvements in multiple parts of the system, including the live and the installer with a small footprint in automated cases, kernels and drivers updated, preconfigured things and drivers are better, etc...

Because of this, I recommend to install your previous system with this version :slight_smile: , elive-pm is also integrated as the new pwoer-mangement system and other things, so this version is better made for a daily to use computer, but you probably won't notice much anything externally

note: my thinkpad computers works better with the 4.19 kernel!

BTW Betatest needed: live mode reciclating wifi (since 3.8.10)

1 Like

Hello!

First test (x64) on the eeepc 1015pn, live usb, nvidia drivers:
Return of blackscreens, during language configuration, and the one at man-db (plus, seems shorter to fade than before)...
During startup indications, I notice nvidia-modprobe (418.xx), but perhaps it's normal and 340xx-able?
Runs well, "as usual"!
Still Conky a bit overscreen on this machine: last line has letters half cutted... :wink:
All for now: further exporlation tomorrow, with more energy, usb & installaled...

Thanks & salutations!

blackscreens? :thinking: i don't remember... what was this issue about?

During startup indications, I notice nvidia-modprobe (418.xx), but perhaps it's normal and 340xx-able?

yes, there's a single package of nvidia-modprobe on this version that is generic for every version

what about cuda and blender? does blender (the one provided in elive) works out of the box?

about conky, tell me if this command fixes the issue:

sed -i -e '/^$/d' "$HOME/.conkyrc"

it will remove useless blank spaces, making it shorter vertically

what is your result of el_resolution_get ? i will implement it on elive by default

:
EeePC's likes to switch the default video-out to the external connector after login screen, remember?
That's why I send the old EeePC to your operation_base in Spain.... :ohmygod: :ohmygod: :ohmygod: :mwahaha:

Strange, but the speaker is muted on both systems I tried it on.
Oops... correction. The audio works with youtube or music, but not for the sounds, even with Enable Sounds ON in the Audio Settings menu.

And I can’t switch to french. It accept my choice but even by logging out, it stays in US

hum :thinking:

the only reason that comes to my head (both stable & beta versions) on which this issue can happen is from elive-multiscreens, in other words, its the only tool that could set this setting (unless its really the graphical system which wants to use it this wrong way), but only if the user saved this setting to be used from elive-multiscreens, see:

cat ~/.config/elive/elive-tools/el_config/%%usr%%bin%%elive-multiscreens_conf.sh

in any case, these settings are meant to be loaded only if the external screen is connected :thinking:

anyhow, it needs to have a deeper research:
@Franc is this the issue that you have about blank screen? check also if you have this file, you can try to delete it

E16 has the audio theme disabled by default for the installed system and enabled for the live if you are between the daily hours of the day (you can enable them by yourself), is this the issue that you have I assume?

can you tell me how to reproduce the issue? the language configurator worked correctly in all my tests (live or install? tell me the steps)

Holà!

Yep! During startup process, at the points I tell, there's quite long times (specially man-db) where screen fade out for economy, but the fact is that it's better to avoid those, in order to let an eye on what's going on, even if it's static-for-a-moment writes on the screen; If it turns black, one's surely can't figure out what happens... Or it's needed to prevent the user that if it goes black, it comes back when process (writings) continues? No: it's better to let the screen displaying texts, in order to know somewhat about where it is in the startup, and white texts on black screen didn't really justify the fade out to economy...

Makes it ok! (except little horizontal spaces to fit it more readable, up to PROCESSOR, DISC I/O USAGE, NETWORK, should be top is doable... :+1:
And Cairo's bar can go over last conky writes (ULS...), but it's a bit of an other thing...

1024x600

About Blender (furbished one, on eeepc 1015pn) runs ok as usual but still didn't see cuda (out of the box; Having to try installing separately cuda toolkit?)

Halo!

which startup process? live mode? installed system? only the first installed boot?

i need more details to know where this happens and how to solve it

or are we talking about the elive-installer? :thinking:

Mmmh, I assume you are talking about the boot of the installed system :thinking: but this does happen on every boot? I assume no... non-reason to run any man-db thing on every boot (only the first one maybe), and in any case you should see messages on your boot splash (plymouth), assuming that you don't have it we are talking that you installed the 32bit version?

well, by removing those vertical spaces it correctly fits in the screen, the only other alternative is to remove useful elements from it, so i assume is better to remove spaces

About blender:

  • the default blender version provided in elive should work out of the box
  • if it needs special cuda software for an improved render on blender, you should be able to do it by installing the cuda toolkit packages from the default elive repos (not external sources)
  • if the previous step doesn't works, we need to see how to make it working, or maybe we lack another package, but the idea is to use everything from official repos

Hi!

Usb live boot...

usb live boot long times showing man-db processes? :thinking: this makes no sense... oh, I assume you are talking about the step where you are installing the nvidia drivers? yes this is normal, sadly it is normal, the apt processes are a bit slow to process, and its common to be stuck at man-db steps for a minute or two

In any case is an important slowdown pretty useless for the live mode, I will try to optimize apt / dpkg to not run these useless & slow things for live for the next version :thinking:

I reloaded the ISO today, checked the checksum, all from my mac this time, and it works well.

This time, the sound was ON right from the start. I had nothing to do...

To swith the language to french, I had to use the "restart the desktop configuration" item from the "settings" menu to get it in french.
Unless my memory tricks me, before I only had to restart Enlightment from the Elive menu to make it work, but it doesn’t work like that this time

fixed for 3.8.11 by including a forced restart of the desktop if the languages has been reconfigured :slight_smile:

2 Likes

Hello!

Now, upgrade from usb live, from 3.8.8 to 3.8.10 x64, for the Precision M6700 / nvidia M5000M:
Starts without any problem via live usb, privative drivers;
When wanting Discs, impossible to launch from cairo > from LMB menu ok...
In live mode, >>>api synaptic and from it, cuda toolkit install, gives flawless cuda reconition in Blender (from the .iso one)...
Reboot on installed, ok, but Terminology didn't want to go > have to use rxvt
If trying to launch Terminology from rxvt, got errors


Discs here launches ok from cairo...
Salutations!

1 Like

CUDA finally worked for you from the official repos? :slight_smile:

Try apug which includes an update of terminology, it does works good for me :thinking:

Hi!

May I say, "as usual" when it's on the precision M6700 / nvidia M5000M?
And underline cuda toolkit installed from synaptic, that (seems to) have straight Elive sources?
On the M4400/FX770M nor eeepc 1015pn it still not working for now...

Ih!

1 Like

im confused, if the cuda toolkit is the one that blender needs to render nicely, why it works on a computer and not in another? (we are talking about the same blender version and cuda-toolkit version)

yes, those cuda toolkit packages comes from backports repository, the version 3.8.11 will include pinned preferences which means you can install them straight without xxx/buster-backports tricks

but what I need to know and it stills not clear to me is which nvidia packages should be installed by default in order to improve the user experience, they will be installed on the installed system and not in the live mode (live mode has limited ram resources and installing packages takes a lot), so I want to create a list of extra packages for nvidia like:

  • cuda
  • nvidia-settings
  • vdpau
  • and theres many others if you "apse" them, but i need to know which ones and for what they are for

What is the download URL for this. I am eager to see if this fixes my little annoyances

BH :slight_smile:

That would be 3.8.11 now. :madness:
I'll PM you the link.

1 Like

Hi, is the update / grade installed automatically?

It should offer to upgrade once you reboot or log out and in again into E16.

You can manually do it yourself too with the "apug" command.