Enlightenment (E24) installation / Testing

Sure, I tried many Ubuntu based distros, and RedHat based ones.
(Sincerely, I started with Slackware, but it happened many years ago)
Perhaps I'll decide to give me a Christmas gift, buying a new laptop and installing only Elive Beta. Who knows ? :blush:

1 Like

I tried so many distros in the last few years, Several Ubuntu ones and finaly Manjaro/XFCE / Arch that was the closest to what I wanted but to this day, I still prefer Elive stability and the E16/22/23 DE ( Desktop Environnement). as for E23, it's a bit experimental, more modern but some glitches.

I loved E16 during the last few months, but recently decided to move to E23 that I like (as I used E22 during a long time with a previous version of ELive 32 bits).

But ELive Beta 64 bits worth spend time try it and along the road, up to you, if you're adventurous and want to try E23.

1 Like

Ah, yes that was one magnificent distro. :w00t:
The only way I could get to install on my P1 Thinkpad .... using the floppies and getting a parallel port CD (single speed) drive to be recognized and allow the ISA graphic card to be configured. :face_with_head_bandage:

1 Like

it is? :thinking:

it is meant to be the FM replacement by E, and in fact not only very fast but 100% light (no extra resources needed to use it)

Yes, but if you mount for instance a large USB disk it will want to create thumbnails for all those files ..... actually freezing the window until it's done.. That is not a good thing :frowning:

The FM might be light on resources but the playing/showing of media files on mouse over, isn't.

1 Like

Interesting, can you report this bug to the E guys? Login

well, mouse-over requires to "load" the file, but stills should be pretty light as compared as loading it with any external app

I would like to but actually I have no way of telling if

  • this is my machine only
  • this is the system having trouble with EFM or the whole desktop conking

as I don't get to see any tracebacks or dumps ..... it just totally freezes over for a while and then suddenly does all the vainless clicks that had been made before I realized it actually froze.
So I don't have much to go on for reporting. :frowning:

Well, the most important thing for that is to tell the details of how to reproduce it, so they can see the bug

The first thing will be to know if happens with any directory (i assume no?) or in such case, see which types of directories (let's say for example, a directory of movie files (large video files), with more than 50 videos)

Optionally could be good if you can try this on a different machine, but I assume its not needed (we are talking about processing files, unless rendering is involved)

1 Like

Reproducing is the hard thing.
IIRC @IamElive had similar issues but haven't heard from others if they've seen this behavior.

I'll try on some other machines too.
Any idea where EFM caches it's thumbnails? Maybe I could reproduce by deleting them. :thinking:

The trouble is that EFM is no fun compared to Thunar and I find the "preview" option extremely irritating as more often than not it blocks my view of the directory I'm looking through. :frowning_face:

If you want me to test something just let me know
1- Do this
2- Do That

with the exact steps to reproduce, I could try

If it's important for you... For now I am 100% ok with Thunar.
JF

Yay, found what's causing it !

On opening a window, using EFM it causes "qtdemux" to segfault.....prolly when trying to generate thumbnails from videos.

Here's a screenshot whilst running "tail -f /varr/log/syslog" and opening a directory with videos.

This happens on different laptops ..... so definitely a bug.
@Thanatermesis I will report on enlightenment.org. :smiley14:

1 Like

Hi!

I'm testing the last E mainly on the eeepc 1001px (3.7.x upgraded (not from the last 3.8.2 .iso)) and it's generally ok, exept the same problem as in E16 with over screened windows (for e.g. asking where to download a file), witch is a bit more problematic because here the ctrl+alt+mouse is not here... Is there a way to fit it (keyboard pass-thru), or better, to resolve this windows dimensions thing?

An aesthetic / usable thing: is it possible to use the Cairo-dock icon for battery level & time to replace the one in the E23's dock witch is really less readable?

How to modify the image of a .edj background (not changing bg but taking a former image, made modif's & using it as a new bg image)?

Many thanks!

I always use the right-click in the top window bar and select the "window" option there and then the "resize window" but I agree it's a PITA and puts one off E23 after a while. Browser pop-ups generally wont have borders provided so that will remain a "problem" there.

No, you're stuck with what E23 has on offer, for now ... unless you want to alter the .edj for the theme and add/replace it there yourself.

  • There is a thread (sort of) on theming E23 which might (eventually) be open for requests. :madness:
    Having fun with themes

Of course you're free to not use (or put it elsewhere) "ibar" and startup "cairo-dock" if you want to. :smiley_cat:

The best way is to import the image "again" and provide a different name. The importer will create the required .edj in that case.

Updates from the last Enlightenment version available on the repos :slight_smile:

if your update fails, just remove it and install again

BTW I just received a notification about a bug fixed that I reported some time ago, one bug less in E23* ! :rainbowyay:

If I apug, it should show it ? Or I need to do something else
I am using E23 all the time so I am interested in this update, whatever it fixes

apug should do the trick, if E23 repo is up to date.....which I very much suspect it is.
Lots of enlightenment updates there.

I don't see any updates when running apug.... May be I already installes those updates without paying attention

How could be compare our version of E23, the easiest way to know if I am using the last version ?

Well mine now comes up with this error:
Elive_Screenshot_2020-01-24_15:43:23__342x136

And the built--in screenshooter now comes up with an imagae editor but no way to save the shot. :frowning_face:

Maybe wait a while ..... looks like there's some new bugs there. :scream_cat:

My version is still 0.23.99.0 as shown.....same as before.

@Thanatermesis are we looking at Elive or Enlightenment bugs ??
In the latter case how do I submit these bugs (in reference to version) at phab.enlightenment.org as some of them (got a few more) are new ??

1 Like

I have version :

~ ❯❯❯ enlightenment --version
ESTART: 0.00048 [0.00048] - Begin Startup
ESTART: 0.00115 [0.00068] - Signal Trap
ESTART: 0.00116 [0.00001] - Signal Trap Done
ESTART: 0.00200 [0.00084] - Eina Init
ESTART: 0.00460 [0.00261] - Eina Init Done
ESTART: 0.00465 [0.00004] - Determine Prefix
ESTART: 0.00528 [0.00063] - Determine Prefix Done
ESTART: 0.00530 [0.00002] - Environment Variables
ESTART: 0.00531 [0.00002] - Environment Variables Done
ESTART: 0.00532 [0.00001] - Parse Arguments
Version: 0.23.99.0
E: Begin Shutdown Procedure!

Added the screenshot issue:
https://phab.enlightenment.org/T8585

Invalidated that one ..... it was a size issue. There were buttons underneath that weren't visible when the screen is magnified. :madness:

and some strange compositor settings behavior:
https://phab.enlightenment.org/T8584

Where the latter submission has a link to the a screencast:

Can anybody stat this experience?

@Thanatermesis what command do I need to show more debug info ???

Added the "enlightenment_system service" issue

https://phab.enlightenment.org/T8586