3.7.1 betatesting experiences

#1

This thread is the same as the 3.7.0 betatesting experiences , but specifically for the new built version, so everything tested on 3.7.1 should be talked on this one instead the other :slight_smile:

3.7.0 betatesting experiences
#2

Hey! I just tested Elive 3.7.1 Alpha. It's wonderful to have Elive x86_64 system. On first boot the theme it's very impressive. As it's in the Alpha stage i encountered several errors that I would like to mention here. I've booted in the e-16 and it's awesome. Reports: Ethernet working well but Wireless module didn't work i've tried several times. Window resizing a bit buggy i guess because when i opened 4k video it opened wide and window control goes off from the screen there was no way to resize the window. And by default e-16 has sound effect enabled although the sounds are sweet but it's also irritating for use i can explain this when i have 3-4 application opened on my screen it's very common that i will switch over them again and again and the sounds are beeping seems to irritating to me. My suggestion is that limit the sound effects to particular thing like if a command goes wrong it should beep just like terminology do and if a task accomplished it should beep. Another thing is keyboard function keys aren't working. [More to explore]

1 Like
3.7.1 changes and expectations
#3

Hi @Fantasy_Apple! glad you liked it :slight_smile:

You mean the e16 theme? :slight_smile:

Which wireless driver you have on that machine?

Mmmh, unless the application itself doesn't allows you to resize, you should resize it, try the handy combo "ctrl + alt + middle-mouse-click-while-dragging", also try the "switch to fullscreen" on the video player (sometimes the key "f")

I personally like them (enabled all the time), but they can be disabled from the settings, I assume that is good to have them enabled by default becuase of this reason too (motivating the user to search where to disable them, and so, to found all the nice options that can be configured for the desktop)

Unfortunately the "volume for the theme" cannot be changed, but the theme clips can be improved if there's a very (specific) annoying sound :thinking:

Which computer model? and which keys doesn't works?

#4

3.7.1 e16 failed to install on my HP Desktop with 2 screen will try with one scree connected

On the Dell Laptop, I don't have the problem

1- I choose e16 ( that is choosed bu default)
2- a screen appear but I don't nothing... (nothing meaning one of the default screen with an horizontal line but I am stuck there and can do anything)

WIll take picture when I retry....

  • will continue 3.7.1 install on my latopstop and restart install on Desktop with one screen connected

Yoda

3.7.0 betatesting experiences
#5

What exactly failed? any error by the installer? btw always enable reports on the installer (i didn't see them for this install)

will need a screenshot, i dont know what can be this "horizontal stuck & blocking line"

#6

OK everything went fine on Laptop and I used btrfs (laptop flies)
Did you changed something, luminosity is working now !
Tks!
On both install I said no to the email / report to see if it would be asked a 2nd time LOL
It didn't.... So that's why you didn't got the report

For the desktop, with one screen connected, installation in progress and working normally
SO i'll have to do it again (wht 2 screen to show you a picture), but you won't see the report as I can't reach the main desktop to start the installation... The only you'll get is a picture of where it stop...

Stay tuned...
JF

#7

Here is my wireless interface..... I meant plymouth theme that looks great..... i know how to resize screen but every time if you have to resize it you know it is not a permanent solution perhaps elive should bind application windows to workspace resolution. And i know how to turn off the sound from the settings and i also like this sound effects My point on sound was in every click it beeps if you just can make it more option on sound to control it just like application menu FX effect as i know your are very very good on enlightenment development. About function key i meant F1, F2, etc. i tried to mute sound from function key but failed. [Here my opinions are as like as end user]

#8

Yes, this is fixed on 3.7.1 :slight_smile: - @triantares happy :happy:

ok, this has been improved in the installer too :slight_smile:

#9

Here
Stacked here After choosing E16, I see this and hear the welcome to enlightenment

Nothing else
Yes I can change tty

#10

looks like an iwlwifi driver, firmware is included too:

❯❯❯ dpl | grep iwlwifi
ii firmware-iwlwifi 20190114-1 all Binary firmware for Intel Wireless cards

maybe you need newer firmwares (new versions included), I have see that the SID branch of debian includes an updated version: Debian -- Package Search Results -- iwlwifi can you try to install the package from sid manually? you should not get package/dependencies problems with that, or just run "apif" in such case :slight_smile:

well, the dimension of the window (we are talking about the video player, right?), depends on how the video player manages it, if you are using VLC, maybe there's a setting like "scale / resize window to fit screen" or something similar (if you see it tell me, so i should include this option by default), mplayer instead always plays the video in -its- resolution (this means, 4k video windows will appear big), but "mpv" which is a newer fork of mplayer should open the window in a more friendly default size

you mean an e16 setting where the user can select "which sound clips to enable/disable" and/or change them? :thinking:

yep, these should work by default, unless your hardware is not "well" recognized by the kernel (looking at your wifi issue seems like you have a newer computer), or you just need to install an extra package to support this hardware (try "apse keyword" to see if you see any)

#11

I see, e16 is stuck on start, this is probably due to an init script that doesn't finishes :thinking: , let's try to remove them: be out of e16 (from console or from another desktop) and run "rm -r .e16/Init", this will delete all the startup scripts. Try to login again in e16 and see if works (this is not a solution since it will disable some features, but we need to know first if is the cause)

#12

You mean CTRL + ATL F1, F2 etc to reach a console and from there do what you suggest ?
After CTRL + ATL something to go back to GUI ?

#13

yes:

  • first exit from e16 (ok, you can't)
  • go to the console, run those commands
  • assuming you cannot logout from e16, just restart the login manager: sudo service lightdm restart
  • login in e16 and see if works
1 Like
#14

Failed to restart lightdm.service: Unit lightdm.service not found

#15

Cannot test 3.7.1 yet. Will do so later.
What did you change in the sudoers department?

#16

:thinking: then reboot

#17

i rewrited most these configurations in a similar but better structure, implementing (moved) all to user-manager (installer uses it to create users now)

#18

Which still doesn't explain why "/etc/sudoers.d/network_privileges" wasn't being activated, i.e not evne manually.
I hate it when I don' t know how something works ..... that's usually the point where I start to take things apart. :angry:

#19

I don't understand why didn't worked for you too :woman_shrugging: , if you used the same entries and chmod 0440 the files it should simply work, but anyways, 3.7.1 has the needed settings updated :slight_smile:

#20

@Fantasy_Apple looks like i can enable to sid/unstable repos to allow it to install updated firmwares by default (-only- those packages priority), can you confirm that the firmware package makes your wifi working?