Eltrans: How to improve the English sentences in Elive (proofreading)

Well "eltrans" on my machine seems to think so and I don't see any way to create a new one.....just the same old zenity pop-ups over and over again.

I had the same issue a while ago,
then @Thanatermesis ' did something' -
and after it worked.
If ! I remember right,
I had to delete the Eltrans stuff in my user space ... (?)

1 Like


What I have:

So it seems well about root stuff but Eltran user...

Could you please give the way: didn't find anything about it in my /usr or /home/USER/..?

Can't it be an option to have those Eltran usr/pass via forum's pm?


You have to delete .eltrans/ directory in your "HOME" . For that use:

rm -r ~/.eltrans

That is wrong too, its .eltrans in your /home/elive folder i.e full path is /home/elive/.eltrans
If it isn't there, then either "rm" did it;s work or ..... you've never run "eltrans" as that user from that install.

To check run:

sudo ls -a /home/* |grep eltrans

Which should not give any output if indeed .eltrans isn't there.

Ok let's see:

It is true that the actual code of eltrans has not been updated in a long time, this means that I assume that everything is working correctly on it :slight_smile:

Now, I have betatested it from an installed clean system, and all the steps are perfectly clear to me (well explained messages), I also improved one of them in order to make it even more clear.

So your issue @triantares & @Franc is that you both don't have an eltrans account, removing the ~/.eltrans dir is not really needed (eltrans ask again for the valid username if doesn't works)

But what im more worried about is that looks like eltrans is not enough clear for people to know "what to do now", and like i said, it is very clear for me trying to use it... so I need to ask you*, how it can be improved? where is the usability issue from?


Note: run "apug", there's a minor-updated version of elive available with an improved sentence

BTW, as you may know, the dev.elivecd.org website is a good source to "control" what happens in teh translations, from Timeline – Elive Development , for example i changed the sentence of an eltrans message and this is how it looks like: https://dev.elivecd.org/changeset/4821#file14

(login from your translator account should be probably needed)

TIP: you can improve the english wording and messages for better and clever ones in eltrans, by using eltrans :lollipop:

I did try a session this afternoon but all the sudo calls are fairly irritating to say the least.
Here's the session:
(video down)



Do you know what makes me think these "password" things at the start? i dont think that is related to eltrans but related to subversion, i think that there's a bug in gnome* stuff that try's to use / store the passwords and are not compatible with subversion :thinking:

Can you investigate more? Clicking in "details" tells you what is trying to run as root? running 'eltrans' from a terminal does the same thing?

Also try to edit your:

scite ~/.subversion/config

making sure you have these contents (set to nothing):

password-stores =

and all the "store-" possible entries should be commented

This should probably fix the asking-passwords thing related to "env" :thinking: (or try to google about this passwords / subversion issue), we will need to know why is this happening in a first place... i think that it doesn't happens in a fresh new user install

now, there's your issue:


why you are inserting this ? :slight_smile: this username-account doesn't exist!

so again my question is: why is this not clear enough in eltrans? :thinking: it is not asking about your username but about the "translator account username"

Which i still think that should be all the process clear, in your next steps too:



here's clicking in "details"

I edited subversion accordingly to not store passwords but doesn't change a thing. Just as many pop-ups.

Because I asked for an account a while ago (almost a week now) and want to see if it maybe has been created in the mean time. :smiley14:

I deleted .eltrans/ and tried again with the following result:

Where I find the commit page thoroughly unclear and discouraging. :eyepopping:


In fine, it's ok for me! :slight_smile:
Having now to find how it works; Already made a little "tour" on Poedit web, but needed more or somewhat tutos...


Well, Eltrans asked some times for root password, then asked user to get an account contacting yourself and open a browser tab that shows your profile, some minutes later it asked for an user and a password for eltrans, so first time is confusing, and once an user had his username+password he must wait a few seconds / minutes until eltrans ask for those user name+pass so maybe user close the window thinking that it doesn't works (that was my case first time); then eltrans download an update some paquets and then we can start to use it.

BTW, I'm now starting the French version and I have a doubt; as you can see in picture below, in English version there are some thing like \n\ without spaces between 2 phrases ans with \ in red. I suppose that is some kind of code, so I copy / paste it in French translation, without spaces too, but \ are not in red in my copy, before to continue I want to know if I'm doing this correctly or not...


EDIT: I found the answer here:


I didn't knew this web page, I'm sorry, I'll read it before translating anything.

Hi Franc, in which language you'll translate?

I'm starting in French translation so we have 2 options:

  • We divide our work (any of us translate some sections and the other translate the others ones), I mean to divide those sections into us to avoid to translate them twice:

  • I give you completely French translation works (my native language is not French but Spanish) and I take a look for Spanish translations, but I think that Thana maybe works in Spanish language son maybe Elive is almost 100% translated in Spanish (not sure)

@Franc, what do you think about?


Cleaning english & french translations...
In the list you show (that I can't figure out to obtain for now), I think the first one to finish is Eltrans relative's... :wink:
The best is probably to tell "I make this one", and eventually cross control the works...
Due to many variables, I can't just say "I take it all"; Step by step way is here more valuable & do-able I think...


1 Like

OK, I started with the first one called "applications-compatibility" so let this for me, if you agree I can made impairs ones from those list and you pair ones and then we check for the other's work.

Well, strictly now, I have:

My first test will be Eltran (already 40%, so samples for me)...
After, can be ok!

Will be off probably 2-3 days from now...

6 posts were split to a new topic: Lowering temperature of laptop

don't worry, this is correct this way :slight_smile: , the \ is escaped with \ to itself
it needs to be kept this (same) way on translations too! :slight_smile:

I just added an update: HowtoTranslators (diff) – Elive Development

yep that is important in order to not lose work (conflicting revisions), as explained somewhere in a translators howto on that site

not really, i would like but i have no time to do translations :confused:

I just saw today that you did a commit there: https://dev.elivecd.org/changeset/4824 (Timeline – Elive Development) but doesn't shows anything, I assume there was nothing to translate on this one :thinking:

Mmmh.. note @Franc that your account was not created yet on that moment you wrote that error, it has been created just right now when im writing this post... so make sure that you copy your directory ~/Projects/translations to have a backup of your work already done, before to start using your account... just in case your work is removed :slight_smile: , since you have a backup of this dir, everything is fine (copy back the modified fr.pot file to the project dir and commit it)

exactly, and sincerely i dont understand why @triantares and @Franc found hard this step... i mean, "you cannot do anything without an account" (but they continue tried to use eltrans without it), so I assume that eltrans has some problem of usability... maybe needs a much stricter "blocking" step, but is already "blocking step" :thinking:, users cannot do anything without the account :thinking: :thinking:

there was a guy that ran elive for more than 1 year without a single reboot :speak_no_evil::speak_no_evil::speak_no_evil:


There's something strange here: If I didn't arrive before to somewhat login / pass in Eltran, it will reject! When I wrote

it means that at a point Eltrans ask me for user name & password and accept those... Or any name/pass can have a limited access???

Effectively, now my access is usable & I already made a test on Eltrans translations...
Now, for translations, it's sometimes needed to run the software to deal with contexts... For Eltrans, is the only solution is to re-run it in VirtualBox?

Yes on this machine, for now I can't find why it's hot; even now, at night in a not heated house, it's at about 80°... :frowning:


Mmmh, it doesn't looks like you sent them: Timeline – Elive Development

If im not wrong, eltrans also gives you the possibility to "install locally your translations", so you can run the software with the updated messages

Another solution is to run elive in Live mode or from Virtualbox (in live mode too suggested), so you can run the application in its original messages without harm to do anything